Jump to content
disteele1962

'Enhanced OS X interoperability' Corrupting Files

10 posts in this topic Last Reply

Recommended Posts

I've recently upgraded my iMac to Mojave and also upgraded my server to 6.6.3 and I've noticed that my excel and word files corrupt during a file save. I created a test share and noticed that when 'Enhanced OS X interoperability' is not ticked, the system is stable. With the option ticked I get error messages and the file size drops to zero bytes. Sample error messages attached. I'm using SMB as I heard it's more reliable/compatible than AFP.

Any suggestions?

Screenshot 2018-11-01 at 09.51.59.png

Screenshot 2018-11-01 at 09.50.52.png

Share this post


Link to post

Are you sure it’s not a permissions issue? I’ve had similar problems in the past where I would get locked out of files because incorrect permissions were being applied on write and I would have to use the docker safe new permissions plugin to correct the issue.

Share this post


Link to post

I've run 'Docker Safe New Perms' and I still have an issue. With the Enhanced OS X interoperability option disabled, I don't appear to have an issue. With it enabled it's OK for a while but once it starts to fail it remains in a fault state despite copying a new file into the share. At one point I had to restart the array to clear the problem. My test file is a small 15kB excel spreadsheet.

Share this post


Link to post

It’s my understanding that the enhanced setting just enables the vfs_fruit package with the associated share. I had hoped that some of the vfs_fruit problems might be resolved with Mojave, but it looks like there are still issues that will make the enhanced setting unusable.

 

I’m sure that compatibility with macOS is a moving target for the vfs_fruit devs since Apple is no doubt making changes to their SMB implementation with each new OS and they tend to be somewhat less than transparent about them.

Share this post


Link to post

I was playing around with the setting despite reading the vfs_fruit package documentation and I had it turned on for two shares. I haven't played extensively enough to notice any file errors.

 

However, any shares I mount within Mojave, I cannot access the sub-folders. They all read 0kb and have a "red negative icon" on them. I'm turning it off for now. I thought it might help with Spotlight searching on network shares...wishful thinking on my part.

Share this post


Link to post
8 hours ago, Zer0Nin3r said:

However, any shares I mount within Mojave, I cannot access the sub-folders. They all read 0kb and have a "red negative icon" on them

I had a similar situation a few weeks ago. Rebooting the server seems to have fixed it. I can confirm that the enhanced OS X setting does work with Mojave. Some people have also had issues due to settings that they had configured in SMB Extras (Settings>SMB>SMB Extras).

Share this post


Link to post
Posted (edited)
On 4/24/2019 at 4:43 AM, wgstarks said:

I had a similar situation a few weeks ago. Rebooting the server seems to have fixed it. I can confirm that the enhanced OS X setting does work with Mojave. Some people have also had issues due to settings that they had configured in SMB Extras (Settings>SMB>SMB Extras).

I have it turned on now for all SMB shares after upgrading to 6.6.7. 6.7.0. I haven't had much problems other than having to reset/fix permissions for my Downloads share. For some reason it doesn't mount properly and when I go to copy a file into the folder via Finder, I won't be able to at the root level of that particular share. I would fix permissions and if that didn't work, then I would create a new folder in there (for some reason it allows me to do that) and then copy the file into that new folder. From there I can drag it out of that newly created folder and drag it into the root directory of the Downloads share. Then copying of other files works normally again until the next hiccup.

 

I feel that using finder to search on SMB shares works faster with the enhanced macOS interoperability.

Edited by Zer0Nin3r
Wrong mention of which version of Unraid I was using.

Share this post


Link to post
3 minutes ago, Zer0Nin3r said:

I have it turned on now for all SMB shares after upgrading to 6.6.7. I haven't had much problems other than having to reset/fix permissions for my Downloads share. For some reason it doesn't mount properly and when I go to copy a file into the folder via Finder, I won't be able to at the root level of that particular share. I would fix permissions and if that didn't work, then I would create a new folder in there (for some reason it allows me to do that) and then copy the file into that new folder. From there I can drag it out of that newly created folder and drag it into the root directory of the Downloads share. Then copying of other files works normally again until the next hiccup.

 

I feel that using finder to search on SMB shares works faster with the enhanced macOS interoperability.

You might find that it improves with the latest (6.7) stable release.

Share this post


Link to post

I've upgraded to 6.7.0. The release notes state: "smb: when Enhanced OS X interoperability set, include "fruit:nfs_aces = no" to be compatible with Unraid security model". Not sure what it means but the Enhanced OS X interoperability is now a global setting under SMB Settings. I've enabled it and so far is behaving normally.

Share this post


Link to post
3 hours ago, disteele1962 said:

The release notes state: "smb: when Enhanced OS X interoperability set, include "fruit:nfs_aces = no" to be compatible with Unraid security model". Not sure what it means

It was added to prevent an issue where finder would change permissions on some files/folders. The setting is no longer needed in SMB extras.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.