Guide: How To Use Rclone To Mount Cloud Drives And Play Files


DZMM

Recommended Posts

8 hours ago, francrouge said:

@DZMMHi 

 

Can you tell me in you're script what user should the script put folders

 

like root or nobody

 

My folder got root permission and it seem to glitch a lot with the script normal ?

 

 

thx

Shouldn't be root, this caused problems. It should be:

user: nobody

group: users

 

Often this is 99/100.

Link to comment
12 minutes ago, francrouge said:

Here is my folder

 

image.png.75e6b781bb48db5dc5680145cda2fc8c.png

 

What should i do ?

 

 

thx

Well, we've discussed this a couple of times already in this topic, and it seems there is not one fix for everyone.

 

What I've done is added to my mount script:

--uid 99

--gid 100

 

For --umask I use 002 (I think DZMM uses 000 which is allowing read and write to everyone and which I find too insecure. But that's your own decision.

 

I've rebooted my server without the mount script active, so just a plain boot without mounting. Then I ran the fix permissions on both my mount_rclone and local folders. Then you can check again whether the permissions of these folders are properly set. If that is the case, you can run the mount script. And then check again.

 

After I did this once, I never had the issue again.

  • Like 1
  • Thanks 1
Link to comment
9 minutes ago, Kaizac said:

Well, we've discussed this a couple of times already in this topic, and it seems there is not one fix for everyone.

 

What I've done is added to my mount script:

--uid 99

--gid 100

 

For --umask I use 002 (I think DZMM uses 000 which is allowing read and write to everyone and which I find too insecure. But that's your own decision.

 

I've rebooted my server without the mount script active, so just a plain boot without mounting. Then I ran the fix permissions on both my mount_rclone and local folders. Then you can check again whether the permissions of these folders are properly set. If that is the case, you can run the mount script. And then check again.

 

After I did this once, I never had the issue again.

cool thx i will try thx a lot 

 

Should it be faster just to delete mount folder directly with no script load up and let the script create it again 🤔

Link to comment
2 minutes ago, francrouge said:

cool thx i will try thx a lot 

 

Should it be faster just to delete mount folder directly with no script load up and let the script create it again 🤔

Ah, I forgot, also the mount_mergerfs or mount_unionfs folder should be fixed with permissions.

 

I don't know whether the problem lies with the script of DZMM. I think the script creates the union/merger folders as root, which causes the problem. So I just kept my union/merger folders and also fixed those permissions. But maybe letting the script recreate them will fix it. You can test it with a simple mount script to see the difference, of course.

 

It's sometimes difficult to advise for me, because I'm not using the mount script from DZMM but my own one, so it's easier to for me to troubleshoot my own system.

  • Like 1
Link to comment
1 minute ago, Kaizac said:

Ah, I forgot, also the mount_mergerfs or mount_unionfs folder should be fixed with permissions.

 

I don't know whether the problem lies with the script of DZMM. I think the script creates the union/merger folders as root, which causes the problem. So I just kept my union/merger folders and also fixed those permissions. But maybe letting the script recreate them will fix it. You can test it with a simple mount script to see the difference, of course.

 

It's sometimes difficult to advise for me, because I'm not using the mount script from DZMM but my own one, so it's easier to for me to troubleshoot my own system.

I understand  i will try both option to see thx a lot i will keep you update :D

Link to comment
On 11/29/2022 at 4:34 AM, Kaizac said:

Well, we've discussed this a couple of times already in this topic, and it seems there is not one fix for everyone.

 

What I've done is added to my mount script:

--uid 99

--gid 100

 

For --umask I use 002 (I think DZMM uses 000 which is allowing read and write to everyone and which I find too insecure. But that's your own decision.

 

I've rebooted my server without the mount script active, so just a plain boot without mounting. Then I ran the fix permissions on both my mount_rclone and local folders. Then you can check again whether the permissions of these folders are properly set. If that is the case, you can run the mount script. And then check again.

 

After I did this once, I never had the issue again.

Hi 

 

Just to let you know that i tried what you told me on my main and backup server and it seem to be working permission owner where changed to nobody:users

 

 

thx alot

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.