Guide: How To Use Rclone To Mount Cloud Drives And Play Files


DZMM

2443 posts in this topic Last Reply

Recommended Posts

  • Replies 2.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

3/1/20 UPDATE: TO MIGRATE FROM UNIONFS TO MERGERFS READ THIS POST.  New users continue reading 13/3/20 Update: For a clean version of the 'How To' please use the github site https://github.com/B

so ive been reading for ages but theres so many pages here, my issue is that when the array is stopped the mergerfs mount is not unmounted casuing unraid to keep retrying indefinately to unmount share

Multiple mounts, one upload and one tidy-up script.   @watchmeexplode5 did some testing and performance gets worse as you get closer to the 400k mark, so you'll need to do something like bel

Posted Images

Hi guys 

 

I have a question for you. I'm trying to listen to a bluray rip that is 33Go in size and i keep getting buffering or it takes 5- 10 sec to start the movies is it normal ?

 

Can you tell me if i can modify something in my script ?

 

 

rclone mount --allow-other --buffer-size 512M --dir-cache-time 72h --drive-chunk-size 512M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs &

 

 

thx

Edited by francrouge
Link to post
1 hour ago, francrouge said:

Hi guys 

 

I have a question for you. I'm trying to listen to a bluray rip that is 33Go in size and i keep getting buffering or it takes 5- 10 sec to start the movies is it normal ?

 

Can you tell me if i can modify something in my script ?

 

 

rclone mount --allow-other --buffer-size 512M --dir-cache-time 72h --drive-chunk-size 512M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off gdrive_media_vfs: /mnt/user/mount_rclone/google_vfs &

 

 

thx

what's your broadband connection download speed?

Link to post
3 minutes ago, francrouge said:

120/20

Envoyé de mon Pixel 2 XL en utilisant Tapatalk
 

Assuming a 90min movie, you'll need about 50Mbps on average to play the movie and some bits might be higher e.g. 60-70Mbps.  On your 120 connection if the line isn't available you'll have problems. 

 

You could possibly try increasing your chunk size to ask rclone to download more before starting playback - a chunk size of 256M might stop the buffering for this movie with the trade-off being the start time will be slower whilst waiting for that first chunk.

Link to post
Assuming a 90min movie, you'll need about 50Mbps on average to play the movie and some bits might be higher e.g. 60-70Mbps.  On your 120 connection if the line isn't available you'll have problems. 
 
You could possibly try increasing your chunk size to ask rclone to download more before starting playback - a chunk size of 256M might stop the buffering for this movie with the trade-off being the start time will be slower whilst waiting for that first chunk.
Good to know thx for the info

Envoyé de mon Pixel 2 XL en utilisant Tapatalk

Link to post
1 hour ago, francrouge said:

Hi all

 

Question for you guys anyone tried the sync option in plex with a movie in gdrive for exemple ?

 

Just curious if its working or the time it took to sync.

 

thx

It definitely works.  Probably a bit slower due to the need to download the file, but I do my syncs in the background so I never notice and the biggest delay for me is copying to my tablet.

 

27 minutes ago, adammerkley said:

I'm so curious about trying this.  I have done the first few steps and rclone is working great to my Google Drive.  I just can't bring myself to fully rely on Drive in case something goes wrong!

I've gone almost all in this month and I'm uploading all my non-4k content and a good chunk of the 4k as well.  It's been working well for me for over six months and after seeing some absolutely massive plex libraries setup like this, I'm not worried.

Link to post

Having issues with excluding folders with Rclone. If I run it the first time it will exclude it. However if I add a folder like "logs" to the exclude then it wont delete it off the destination. I would manually have to do that. Is this script fine?

 

rclone sync -v --delete-during /mnt/user/backups/Usbdrive NAS:adehaan86/unraidbkup/Usbdrive --exclude "/config/**" --exclude "/logs/**"

 

a work around I can see be would if I add something to the exclude then manually go delete that directory.

 

 

Link to post
1 hour ago, scubieman said:

Having issues with excluding folders with Rclone. If I run it the first time it will exclude it. However if I add a folder like "logs" to the exclude then it wont delete it off the destination. I would manually have to do that. Is this script fine?

 

rclone sync -v --delete-during /mnt/user/backups/Usbdrive NAS:adehaan86/unraidbkup/Usbdrive --exclude "/config/**" --exclude "/logs/**"

 

a work around I can see be would if I add something to the exclude then manually go delete that directory.

 

 

wrong thread as this is for plex playback and mounting.  But, I think you won't be able to solve your problem like that as I think exclude only works on files not folders

 

https://rclone.org/filtering/

 

 

Link to post
3 hours ago, scubieman said:

Thank you! Sorry about wrong thread.

For future reference, you can always get to the right thread by clicking on the docker icon in the webUI and selecting Support, or from the Support page link for the docker in Apps (Community Applications).

Link to post

I've noticed some buffering with 4k content roughly 10 minutes in. I'm currently using DZMM's setup which works well for non-4k.

Quote

 rclone mount --allow-other --buffer-size 512M --dir-cache-time 72h --drive-chunk-size 512M --fast-list --log-level INFO --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off rclone_mount: /mnt/user/mount_rclone/rclone_mount & 

Anyone mind sharing what they have working well with 4k content? Or is that still a hit or miss. I figure I could increase the --buffer-size to 1G and see how that works.

Link to post
27 minutes ago, slimshizn said:

I've noticed some buffering with 4k content roughly 10 minutes in. I'm currently using DZMM's setup which works well for non-4k.

Anyone mind sharing what they have working well with 4k content? Or is that still a hit or miss. I figure I could increase the --buffer-size to 1G and see how that works.

Let me know how you get on with this as I've never conclusively seen any difference for my connection when I increase/decrease the buffer

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.