Jump to content
comet424

rsync issue was working now ask's password on remote yet no password

58 posts in this topic Last Reply

Recommended Posts

oh i tried a root password and it doesnt matter  still gives you 3 times and that error like i posted

 

Share this post


Link to post

was hoping there was a reset for that but nothing and no one has an answer so i guess the only answer is to format and start over

Share this post


Link to post

and i have another question  i dont know whats wrong...  if i Push to my backup server  with a folder name with a space works

but when i pull from my sisters unraid it gives errors   

 

this works

-------------------

rsync -avzu --stats --numeric-ids --progress -e "ssh -i /root/.ssh/id_rsa -T -o Compression=no -x"  "/mnt/user/Jamboree Files/" root@backupserver:"/mnt/user/Jamboree Files/"  >> /boot/logs/cronlogs/BackupNAS_JamboreeFiles.log

 

this doesnt work

-------------------------------

rsync -avzu --stats --numeric-ids --progress -e "ssh -i /root/.ssh/id_rsa -T -o Compression=no -x"  root@Mitchtower:"/mnt/user/Install Programs/" "/mnt/user/Mitchs Files/Install Programs/"   >> /boot/logs/cronlogs/Mitchs_InstallPrograms.log

 

this is the error i get

-------------------------------------

rsync: link_stat "/mnt/user/Install" failed: No such file or directory (2)
rsync: change_dir "/root//Programs" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1659) [Receiver=3.1.3]
rsync: [Receiver] write error: Broken pipe (32)

Edited by comet424

Share this post


Link to post

ok thanks that fixed it.. man there is sooo much to learn with this typing compared to windows

 

2 more questions  when i copy using the Rsync when its on my tower unraid there is a problem i loose rights   i have to goto Tools/ New Permissions and run that each time  i get this nobody user access denied...  is there a way to fix this when copying from windows or with this rsync that i dont have to keep running New Permissions 

 

and 2nd i never resolved the issue with the password thing up above.. is there a reset ... because even though i deleted passwd shadow smbpass files  it still asked me password even though  root has no password.. and when i do add a password  i type it in it either does 3 times .. or accepts it but then says connection lost or closed cant remember...

 

as i ended up just copying the ssh  folder directly from  my tower to mitchtower and backupserver to least get rsyncing to work using the windows shares..

im still really new at this last time i used a linux was 20 yrs ago with Redhat and couple others in collage but it wasnt easy mounting cd rom drives  etc so i stuck with windows and never looked back lol

 

Share this post


Link to post

oh and another question  im just using root@mitchtower  since its my sisters tower  but im just testing and setting it up at my house

 

but its going to goto her house and she will have a backup unraid as well...  how do you connect rysnc to her computer to connect to her unraid or possibly her mitchbackup (unraid)

and id like to use openvpn to connect then disconnect in the same script  but cant figure it out yet

Share this post


Link to post
13 hours ago, comet424 said:

when i copy using the Rsync when its on my tower unraid there is a problem i loose rights   i have to goto Tools/ New Permissions and run that each time  i get this nobody user access denied...  is there a way to fix this when copying from windows or with this rsync that i dont have to keep running New Permissions

You will always loose rights to a file you rsynced over will be created by root, unless you use -p option (case sensitive) in which case it will be created with the same ownership as the source files - which might not be applicable on the destination unraid

 

14 hours ago, comet424 said:

i never resolved the issue with the password thing up above.. is there a reset ... because even though i deleted passwd shadow smbpass files  it still asked me password even though  root has no password.. and when i do add a password  i type it in it either does 3 times .. or accepts it but then says connection lost or closed cant remember...

 

as i ended up just copying the ssh  folder directly from  my tower to mitchtower and backupserver to least get rsyncing to work using the windows shares..

the quick test is to use the ssh command

if you can type

ssh root@IP_OF_SERVER echo Hello

and you get back "Hello" then rsync will not have any issues running... you can replace the "root" if you are using a different user on the other server

 

You can use openvpn between your unraid and hers, but its kinda hard and might be better/easier if the openvpn was established your and her router (that way the router GUI will do all the hardwork for you)

Share this post


Link to post

ok that ssh echo command worked.. probably cuz I after all that nothing working  just copied  the ssh folder of Tower to Mitchtower and my Backuptower through windows

 

ok well we both using  Pfsense and I do have OpenVPN Server running on her machine  her network is 192.168.1.1 and mine is 192.168.0.1   I had to give her a 1.1  since I was having issues when same as mine and cant access her 192.168.1.1  has to be 192.168.100.1  to access but

can unraid OpenVPN connect to her pfsense  is what I ment like  in that user scripts... connect to her pfsense  access her unraid  then disconnect her OpenVPN...  I tried the OpenVPN Client plugin but it doesn't work  you goto it says Choose File   you cant even click Choose File like it states its not clickable as I was going to import my OpenVPN pfsense file

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now