[Support] binhex - qBittorrentVPN


binhex

Recommended Posts

Anyone having issues with PIA and the strict port forwarding? Everything was working fine for me until today. Nothing was getting downloaded. Thought that maybe the VPN server went down so I tried it with another one, still nothing. Turned VPN off and it worked again. Turned VPN back on and noticed the logs were throwing errors around the port forwarding part and the docker (or at least the webpage part) wasn't even loading. I turned strict port forwarding off and everything works again now. Not sure if it's just me or something global with PIA, hence why I'm asking.

Link to comment
16 minutes ago, Oogbal said:

Anyone having issues with PIA and the strict port forwarding? Everything was working fine for me until today. Nothing was getting downloaded. Thought that maybe the VPN server went down so I tried it with another one, still nothing. Turned VPN off and it worked again. Turned VPN back on and noticed the logs were throwing errors around the port forwarding part and the docker (or at least the webpage part) wasn't even loading. I turned strict port forwarding off and everything works again now. Not sure if it's just me or something global with PIA, hence why I'm asking.

Have you updated to the next-gen ovpn files?

Link to comment
On 10/14/2020 at 12:12 PM, DaveDoesStuff said:

Bizzarre indeed! I can clearly see in the CMD output that when I toggle it and save the changes it is indeed running with it set to true (which you probably confirmed in the logs also):
 


root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-qbittorrentvpn' --net='bridge' --cpuset-cpus='1,9' --privileged=true -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='XXXXX' -e 'VPN_PASS'='XXXXX' -e 'VPN_PROV'='pia' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='yes' -e 'WEBUI_PORT'='8080' -e 'LAN_NETWORK'='10.1.1.0/24' -e 'NAME_SERVERS'='209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1' -e 'ADDITIONAL_PORTS'='' -e 'DEBUG'='true' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -e 'VPN_CLIENT'='wireguard' -p '6881:6881/tcp' -p '6881:6881/udp' -p '8080:8080/tcp' -p '8118:8118/tcp' -v '/mnt/user/Downloads/':'/data':'rw' -v '/mnt/disks/UD_SSD/AppData/binhex-qbittorrentvpn':'/config':'rw,slave' 'binhex/arch-qbittorrentvpn'
9b76b47381e4fb14f762b1b87757888056b7aed2e9e4ae044bfc7113e0808968

Would there be any value to just blowing away the whole thing and re-installing from CA Apps? It's not ideal with 75 torrents in my queue so I was holding this option way back in reserve :D

 

Hmm, not likely to be related (or possibly already addressed) but I found someone with a similar wireguard issue from April from a different container...might be something to it. But probably not :P


https://github.com/linuxserver/docker-wireguard/issues/17

So it seems that this issue was caused by a pending restart/update after I installed unraidDVB and it patched the kernal. On a whim I decided to try and re-enable wireguard after I did the restart today and it worked straight out of the box!

 

For any other PIA people getting wireguard working with a NextGen server configured for it has restored my PIA speeds to the point where I can max out my connection again. Although it does bounce around a lot.

  • Like 1
Link to comment

Hi there folks!

 

Has anyone using WireGuard tested CPU performance vs OpenVPN?

 

I have no problem with the speed I get using OpenVPN over PIA, but if the CPU usage is lower using WireGuard I'll end up making the change. I already noticed a big improvement in CPU usage when I got an old i5 with AES-NI using OpenVPN (half CPU usage actually).

 

Cheers

Link to comment
On 10/15/2020 at 10:15 AM, binhex said:

i think this maybe PIA's DNS playing up, can you change the NAME_SERVERS to:-


'NAME_SERVERS=84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1'

 

Changed it,
and i also redownloaded a new .conf file just to be sure.
and now it works.
Time for me to test it also with rtorrentvpn and then see how the speeds are going

Link to comment

Great Docker !

the only problem i having is :

 

HOW to change Directory Name on HDD of saving or running torrent ?

 

i can use rename but its renaming the torrent name in qbitorrent browser not the REAL directory in the disk.

and there is addon Remote Torrent Adder but also not providing saving option to choose the name of directory on HDD.

please help !!!

Edited by Masterwishx
Link to comment
On 10/13/2020 at 4:30 PM, binhex said:

glad you got it working :-), if oyu want to create a seperate network then my go to post is thie one, its old but still relevant:-

https://forums.unraid.net/topic/70906-added-in-651-docker-user-defined-bridge-networks/?do=findComment&comment=651107

 

im assuming there is a new fangled way of doing it through te web ui but i havent found it :-), just ensure you set the network to something unique and you should be set!.

 

I noticed the docker doesn't ping anymore now that it's in a different subnet. I can access the webUI just fine, but pings don't work. I see the ICMP requests go through my pfSense, just no reply from the docker. It works with dockers that are in the same subnet as the host, and it also works for VMs that are in that specific separate subnet (which is a separate VLAN).

 

Networking is so complicated. Trying to fix the ping issue for my monitoring server... eh...

 

EDIT: it's only THIS specific docker that has the issue. And pings work fine if I disable VPN. So I guess it has something to do with the docker itself. It's all right, I'll just stop monitoring pings on a docker haha.

Edited by dnLL
Link to comment
On 9/22/2020 at 3:17 AM, binhex said:

no, these are the important lines:-

https://github.com/binhex/arch-qbittorrentvpn/blob/4fde9d5b17544d1d0d3b7d4c5577240a72009e8a/run/nobody/qbittorrent.sh#L69-L70

they use the qbittorrent api to set the port, whether the api can do what you need it to do i couldnt say, you would need to read the qbittorrent documentation for their api.

 

Been doing some research on this and it seems the API does support adding trackers to new torrents:

add_trackers_enabled 	bool 	Enable automatic adding of trackers to new torrents
add_trackers 	string 	List of trackers to add to new torrent

How would I go about adding this? Is there a way to add a cron script? Or could it be added as a docker command? (remember linux noob here)

 

Or maybe you could add it to the script and have an variable in the docker settings to add the link to get the list of trackers from or remove it to disable the option?

 

This is the place I get the list of trackers from: https://github.com/ngosang/trackerslist

 

I find it helps immensely.

Edited by TexasUnraid
Link to comment
2 hours ago, TexasUnraid said:

How would I go about adding this? Is there a way to add a cron script? Or could it be added as a docker command? (remember linux noob here)

Not sure how well it works but you can automatically add trackers to all torrents in the qbittorrent settings under the BitTorrent tab.

 

Link to comment

Hi,

I try to use qbittorrent docker on my qnap nas.

 

My docker compose :

docker run -d \
    --cap-add=NET_ADMIN \
    -p 6881:6881 \
    -p 6881:6881/udp \
    -p 8080:8080 \
    -p 8118:8118 \
    --name=qbt \
-v /share/CE_CACHEDEV1_DATA/Download/qbittorrent:/data \
-v /share/CE_CACHEDEV1_DATA/Download/qbittorrent:/config \
-v /etc/localtime:/etc/localtime:ro \
-e VPN_ENABLED=yes \
-e VPN_USER=xxx \
-e VPN_PASS=xxx \
-e VPN_PROV=custom \
-e STRICT_PORT_FORWARD=yes \
-e ENABLE_PRIVOXY=yes \
-e LAN_NETWORK=192.168.1.0/24 \
-e NAME_SERVERS=1.1.1.1,8.8.8.8 \
-e DEBUG=true \
-e UMASK=000 \
-e PUID=1000 \
-e PGID=0 \
binhex/arch-qbittorrentvpn

 

Unfortunately that's not working i have :

listen tcp 0.0.0.0:8080: bind: address already in use.

But also :  listen tcp 0.0.0.0:6881: bind: address already in use.

 

I tried to changed to :

    -p 6882:6882 \
    -p 6882:6882/udp \
    -p 9090:9090 \
    -p 8118:8118 \

And add : -e WEBUI_PORT=9090 \

 

Then the container is launching.

 

But when i'm going to webui i have something strange (tested on two browsers) :

<!DOCTYPE html> <html lang="${LANG}"> <head> <meta charset="UTF-8" /> <title>qBittorrent QBT_TR(Web UI)QBT_TR[CONTEXT=OptionsDialog]</title> <link rel="icon" type="image/png" href="images/skin/qbittorrent32.png" /> <link rel="icon" type="image/svg+xml" href="images/skin/qbittorrent-tray.svg" /> <link rel="stylesheet" type="text/css" href="css/login.css?v=${CACHEID}" /> <noscript> <link rel="stylesheet" type="text/css" href="css/noscript.css?v=${CACHEID}" /> </noscript> <script src="scripts/login.js?locale=${LANG}&v=${CACHEID}"></script> </head> <body> <noscript id="noscript"> <h1>QBT_TR(JavaScript Required! You must enable JavaScript for the Web UI to work properly)QBT_TR[CONTEXT=HttpServer]</h1> </noscript> <div id="main"> <h1>qBittorrent QBT_TR(Web UI)QBT_TR[CONTEXT=OptionsDialog]</h1> <div id="logo" class="col"> <img src="images/skin/qbittorrent-tray.svg" alt="qBittorrent logo" /> </div> <div id="formplace" class="col"> <form id="loginform" method="post" onsubmit="submitLoginForm();"> <div class="row"> <label for="username">QBT_TR(Username)QBT_TR[CONTEXT=HttpServer]</label><br /> <input type="text" id="username" name="username" autocomplete="username" /></div> <div class="row"> <label for="password">QBT_TR(Password)QBT_TR[CONTEXT=HttpServer]</label><br /> <input type="password" id="password" name="password" autocomplete="current-password" /></div> <div class="row"> <input type="submit" id="login" value="QBT_TR(Login)QBT_TR[CONTEXT=HttpServer]" /> </div> </form> </div> <div id="error_msg"></div> </div> </body> </html>

 

No issue with deluge container.

Thanks for your help.

Link to comment
14 minutes ago, Kopernikus said:

Because the only WireGuard container I got working was Wireguard-Go, because in the Synology NAS the Wireguard kernel is missing.

if your synology nas has a kernel older than 5.6.x then you are out of luck. you will have to stick with openvpn.

Link to comment

Hey binhex (or anyone else who might have the answer):

 

I've been using the docker for a little bit, and noticed something strange. I'm not sure if it is a bug or a feature.

 

Tools -> Options

BitTorrent tab

(very bottom)

[check] Automatically add these trackers to new downloads:

 

I add a copy/paste list, not obscenely long, only 20 trackers (so 20 lines).

 

They persist and add to new trackers correctly during the session, but when I shut qbittorrent down, they do not persist when it spins back up.

All other settings I change anywhere else on any page in options seem to persist, just that one thing doesn't.

 

Is that a bug, or a feature?  Or is it a problem with qbittorrent itself and not of your efforts?

 

Cheers!

 

PS: for anyone using binhex/qbittorrentvpn and PIA:

Tools -> Options

Connection tab

(very top)

Enabled protocol: [TCP]      #Do not enable uTP.   I had it set to both, and I was maxing out my connection to PIA at 1.5 MB/sec (and it wasn't consistent, it bounced. Turned to TCP only, and boom, up to 10 MB/sec and consistent stable bandwidth usage, no yo-yo effect.

Link to comment
12 hours ago, mooky said:

They persist and add to new trackers correctly during the session, but when I shut qbittorrent down, they do not persist when it spins back up.

All other settings I change anywhere else on any page in options seem to persist, just that one thing doesn't.

 

Is that a bug, or a feature?  Or is it a problem with qbittorrent itself and not of your efforts?

most probably a bug in qbittorrent, they have 2700+ open issues and 51 pull requests at present, so its probably in there somewhere.

Edited by binhex
Link to comment
37 minutes ago, TexasUnraid said:

Web GUI, it could be a bug as this was several versions ago (4.0/4.1 IIRC) but I know it worked on my old setup.

 ok i had a poke about and it looks to be saving to the correct location, for instance adding in two trackers writes to the file:-

/config/qBittorrent/config/qBittorrent.conf
line 9 - Bittorrent\TrackersList=test\ntest2

but as you have correctly identified, if you reboot then this is disabled and the list is shown as empty in the web ui, BUT the config is still present in the config file. So i would def say this is a bug in qbittorrent, most probably a new bug introduced after 4.1, as you said it wasn't present in that version.

 

edit - actually the data DOES disappear from the config file once you have logged in after a restart of the container, no idea why that would happen!. certainly not something i am actively doing in this container.

Edited by binhex
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.