[Support] binhex - qBittorrentVPN


binhex

Recommended Posts

47 minutes ago, Econaut said:

Might be a nice addition to default these values (at least specifying the Network interface as tun0):

this is already in place, set it to 'all adapters' restart the container and it will set it back to tun0 (or wg0 if using wireguard).

  • Like 1
Link to comment

I successfully changed the default web UI port to '9090' after adding a manual port configuration to set the new port on both the host and container side. The web UI is now available under 'http://<local-ip>:9090'.

 

I also changed the actual 'WebUI' configuration field (hidden behind 'Advanced View') to match the new port, in order for the 'WebUI' option in the Unraid context menu on the qbittorrent container to point to the new location, but this change seems to just get ignored. I tried to change this option on some other containers and they update just fine. I can put in 'https://google.com' and they happily link to that.

 

I rebooted the array/server a couple of times to make sure, but the qbitorrent container context menu always points to 'http://<local-ip>:8080'. The 'WebUI' option doesn't get reset and stays on whatever I last set it to, but it's just ignored.

 

 

 

Edited by guyyst
missing word
Link to comment
12 hours ago, guyyst said:

I successfully changed the default web UI port to '9090' after adding a manual port configuration to set the new port on both the host and container side. The web UI is now available under 'http://<local-ip>:9090'.

 

I also changed the actual 'WebUI' configuration field (hidden behind 'Advanced View') to match the new port, in order for the 'WebUI' option in the Unraid context menu on the qbittorrent container to point to the new location, but this change seems to just get ignored. I tried to change this option on some other containers and they update just fine. I can put in 'https://google.com' and they happily link to that.

 

I rebooted the array/server a couple of times to make sure, but the qbitorrent container context menu always points to 'http://<local-ip>:8080'. The 'WebUI' option doesn't get reset and stays on whatever I last set it to, but it's just ignored.

 

 

 

I don’t believe these changes will effect the webUI link in the docker tab (didn’t for me anyway). Only the app itself. Your best bet would be to manually enter the IP:port in your browser and bookmark it.

Link to comment
10 hours ago, wgstarks said:

I don’t believe these changes will effect the webUI link in the docker tab (didn’t for me anyway). Only the app itself. Your best bet would be to manually enter the IP:port in your browser and bookmark it.

 

From the description I feel like that's exactly what this setting is for: 28-09-21__00-40-21.thumb.png.9ba8f863b6abdebd1b3b2755be696c97.png

 

Again, my other docker containers behave exactly the way this description says they should, qbitorrent is the only outlier so far.

Of course this isn't a huge deal, and a bookmark is an O.K. workaround, it's just a bit irksome when I know that 1 out of my 10 containers is always slightly wrong :p

Link to comment
3 hours ago, guyyst said:

 

From the description I feel like that's exactly what this setting is for: 28-09-21__00-40-21.thumb.png.9ba8f863b6abdebd1b3b2755be696c97.png

 

Again, my other docker containers behave exactly the way this description says they should, qbitorrent is the only outlier so far.

Of course this isn't a huge deal, and a bookmark is an O.K. workaround, it's just a bit irksome when I know that 1 out of my 10 containers is always slightly wrong 😛

 

Alright I figured it out, kind of. I did a grep through all the config files in the 'dockerMan' folder to find where '8080' might still be listed. It was still set as the default value for the WEBUI_PORT variable, so I changed that to 9090 as well. After that I could set the 'WebUI' to whatever I want. (Even a hard coded link like 'https://google.com', which... why was that previously prevented by an old default port in WEBUI_PORT ?)

 

Also, changing the default value of WEBUI_PORT back to 8080 doesn't get me back into the broken state I was in before.

 

So I really don't know what was going on there, but for anyone else having trouble with this, try changing the default value of WEBUI_PORT ¯\_(ツ)_/¯

 

Link to comment
On 9/27/2021 at 9:36 PM, guyyst said:

 

Alright I figured it out, kind of. I did a grep through all the config files in the 'dockerMan' folder to find where '8080' might still be listed. It was still set as the default value for the WEBUI_PORT variable, so I changed that to 9090 as well. After that I could set the 'WebUI' to whatever I want. (Even a hard coded link like 'https://google.com', which... why was that previously prevented by an old default port in WEBUI_PORT ?)

 

Also, changing the default value of WEBUI_PORT back to 8080 doesn't get me back into the broken state I was in before.

 

So I really don't know what was going on there, but for anyone else having trouble with this, try changing the default value of WEBUI_PORT ¯\_(ツ)_/¯

 

This problem has been vexing me all day as well; I'm glad I'm not the only one. 

 

I can't get this to work even if I change the default value of WEBUI_PORT. I'm beginning to suspect there is something odd in this particular Docker image that is forcing all Unraid WebUI GUI links to the default IP:8080 regardless of the link specified in the Advanced view of the Docker configuration page.

 

My goal: Multiple instances of binhex-qbittorrentvpn, each using a different port for their respective WEBUIs.

 

I can get the WebUI to be active on a non-default port by doing the following:

1. Delete Host Port 3 (default 8080:8080)

2. Add new TCP mapping [newport]:[newport]

3. Change WEBUI_PORT to [newport]

 

But regardless of what I change in the WebUI field (Unraid advanced view), the Unraid GUI link redirects me to IP:8080. The only exception is if I manually map container port 8080 to [new port], in which case I get linked to IP:[new port]. But since the container requires a [newport]:[newport] mapping for the WebUI to function, I can't add a second mapping of 8080:[new port] to force the link in the Unraid GUI to work properly.

 

The field just doesn't seem to change even if I hard code the WebUI link to http://[IP]:[newport] or change it to http://google.com. Other containers let me change the WebUI link to literally anything I want, which leads me to believe this has something to do with this specific container. I can't find anything in the dockerMan XML file referencing port 8080 so it's got to be somewhere deeper. 

 

Yes I could just bookmark the individual links and never access them via the Unraid Docker page, but it would really be nice to have so that in the future I don't have to reinvent the wheel if I ever lose track of which ports I used.

 

I'd love to help troubleshoot this because I'm at my wit's end trying to get this to work and am pretty close to giving up and just using binhex-rtorrentvpn.

Link to comment
9 hours ago, exces6 said:

But regardless of what I change in the WebUI field (Unraid advanced view), the Unraid GUI link redirects me to IP:8080.

 

doesnt this work?, left click container icon select edit, then toggle to 'advanced view' (top right) and then change the value for 'WebUI' to 'http://[IP]:[PORT:<port number you want>]/' click on apply at the bottom.

Link to comment
16 hours ago, exces6 said:

I'd love to help troubleshoot this because I'm at my wit's end trying to get this to work and am pretty close to giving up and just using binhex-rtorrentvpn.

I edited the file on the flash as @guyyst suggested. /config/plug-ins/dockerMan/templates-user/my-binhex-qbittorrentvpn.xml.

<Variable>
      <Value>8088</Value>
      <Name>WEBUI_PORT</Name>
      <Mode/>
</Variable>

I’m using 8088. You should enter the appropriate port number. Then reboot your server.

 

Edit: Instead of a reboot you need to update the docker settings. Just make any change in the settings and then revert it then click “apply”.

Edited by wgstarks
Link to comment
6 hours ago, binhex said:

 

doesnt this work?, left click container icon select edit, then toggle to 'advanced view' (top right) and then change the value for 'WebUI' to 'http://[IP]:[PORT:<port number you want>]/' click on apply at the bottom.

 

It seems to accept this input and the XML file under dockerMan/templates-user saves the desired input correctly (unlike some posters above), but the generated link in the Unraid GUI still sticks to 8080.

 

 <WebUI>http://[IP]:[PORT:8089]/</WebUI>

 <Variable>
      <Value>8089</Value>
      <Name>WEBUI_PORT</Name>
      <Mode/>
</Variable>  

<Config Name="8089" Target="8089" Default="8089" Mode="tcp" Description="Container Port: 8089" Type="Port" Display="always" Required="true" Mask="false">8089</Config>

 

Capture.PNG.48a6fe2492264517a38f283d9bdb0e35.PNG

 

This persists even with a complete Unraid reboot as suggested by wgstarks.

 

Edited by exces6
add link photo
Link to comment
Just now, exces6 said:

 

It seems to accept this input and the XML file under dockerMan/templates-user saves the desired input correctly (unlike some posters above), but the generated link in the Unraid GUI still sticks to 8080.

 

 <WebUI>http://[IP]:[PORT:8089]/</WebUI>

 <Variable>
      <Value>8089</Value>
      <Name>WEBUI_PORT</Name>
      <Mode/>
</Variable>  

<Config Name="8089" Target="8089" Default="8089" Mode="tcp" Description="Container Port: 8089" Type="Port" Display="always" Required="true" Mask="false">8089</Config>

 

This persists even with a complete Unraid reboot as suggested by wgstarks.

 

I posted that wrong. Was just working on an edit when I saw your reply.

 

Instead of a reboot you need to update the docker settings. Just make any change in the settings and then revert it then click “apply”.

Link to comment
2 minutes ago, wgstarks said:

I posted that wrong. Was just working on an edit when I saw your reply.

 

Instead of a reboot you need to update the docker settings. Just make any change in the settings and then revert it then click “apply”.

 

I've tried this too (that's what I was doing at first), but no luck.

 

I even just tried manually editing the XML to something random for testing purposes (http://www.google.com) but Unraid still forces IP:8080 in the context menu.

Link to comment
  • 2 weeks later...

Been trying to fellow the video below. but as you can see in the picture i dont have the bittorrent config file. only folder i have inside bittorrent is for openvpn and its empty   <---im a dumbass

 

Edited the qbittorrent config file adding the line from the video. still can access webui and log just keeps spitting out e":"No such container: 31b1f9d436e2"}

 

 

 

 

 

 

 

Edited by Razielxv
Link to comment

My container crapped out all of a sudden. It seems DNS resolution is no longer working and the status for every tracker is "Not working".

I'm using WireGuard via Mullvad. I've rebooted the server and my router. I've generated new WireGuard config files from Mullvad and verified they're unchanged.

 

I've attached my debug log. Any ideas?

 

supervisord.log

Edited by KnifeFed
Link to comment
1 hour ago, KnifeFed said:

My container crapped out all of a sudden. It seems DNS resolution is no longer working and the status for every tracker is "Not working".

I'm using WireGuard via Mullvad. I've rebooted the server and my router. I've generated new WireGuard config files from Mullvad and verified they're unchanged.

 

I've attached my debug log. Any ideas?

 

supervisord.log 20.53 kB · 1 download

i see this specified in your wireguard conf file, from your log:-

DNS = 193.138.218.74

perhaps there is an issue with this name server (assuming its mullvad?), try removing that line from your wireguard conf file, this should then force use of the nameservers defined via NAME_SERVERS env var.

Link to comment
10 minutes ago, binhex said:

i see this specified in your wireguard conf file, from your log:-

DNS = 193.138.218.74

perhaps there is an issue with this name server (assuming its mullvad?), try removing that line from your wireguard conf file, this should then force use of the nameservers defined via NAME_SERVERS env var.

Yup, that's the Mullvad DNS server. I removed it and set NAME_SERVERS to "1.1.1.1,1.0.0.1" but got pretty much the same result.

 

supervisord2.log

Link to comment
24 minutes ago, binhex said:

hmm ok i can only assume isues with the endpoint you are attempting connection to, try a different endpoint.

This is what I did initially, i.e. tried a whole bunch of endpoints with the same result, leading me to believe it wasn't an issue with the endpoints, especially seeing as they all have an online status on the Mullvad website. However, now I tried a bunch again and suddenly one worked. I guess Mullvad has been experiencing some weird issues today. Thanks for your help troubleshooting!

  • Like 1
Link to comment

Hey folks, I'm really struggling here. First time setup. Everything looks like it's working well, torrents are downloading fine, but they aren't uploading. I believe the ports are forwarded correctly (using PIA on a port forwarding enabled server [Montreal]) and I'm not seeing any errors in the supervisord.log file. I'm hoping someone can point out what I'm doing wrong. Let me know if more info is needed.

supervisord - Copy.log

Link to comment

Hello everyone, hope you're all well.

 

I'm having an issue with this docker container. Until a few days ago, I could access the webui while away from home by way of the Wireguard access server built into Unraid. Lately though, requests to the webui are timing out, but only when Wireguarding into my home. If I'm not on Wireguard but am connected to my home wi-fi, I can reach the webui just fine. It's not a firewall issue; if I change the port of for example Radarr to 8080, it connects fine, even through Wireguard. So it seems to be the QBVPN docker that's giving clients the cold shoulder if they VPN into the home via Wireguard. Can anyone help me out with regards to what changed or what I need to change to give my away-from-home devices the green light?

 

Many thanks.

Link to comment
17 hours ago, exlibermortis said:

Hey folks, I'm really struggling here. First time setup. Everything looks like it's working well, torrents are downloading fine, but they aren't uploading. I believe the ports are forwarded correctly (using PIA on a port forwarding enabled server [Montreal]) and I'm not seeing any errors in the supervisord.log file. I'm hoping someone can point out what I'm doing wrong. Let me know if more info is needed.

supervisord - Copy.log 82 kB · 0 downloads

Update: I used https://www.yougetsignal.com/tools/open-ports/ as recommended in the FAQ to check to see if the port autoconfigured by PIA is open and it is not. How do I resolve this? Thanks for any help anyone can provide!

Link to comment
9 hours ago, thatsthefrickenlightning said:

Hello everyone, hope you're all well.

 

I'm having an issue with this docker container. Until a few days ago, I could access the webui while away from home by way of the Wireguard access server built into Unraid. Lately though, requests to the webui are timing out, but only when Wireguarding into my home. If I'm not on Wireguard but am connected to my home wi-fi, I can reach the webui just fine. It's not a firewall issue; if I change the port of for example Radarr to 8080, it connects fine, even through Wireguard. So it seems to be the QBVPN docker that's giving clients the cold shoulder if they VPN into the home via Wireguard. Can anyone help me out with regards to what changed or what I need to change to give my away-from-home devices the green light?

 

Many thanks.

you need to add the wireguard assigned network to the value for env var LAN_NETWORK, using a comma to separate the values, so you should end up with LAN_NETWORK value defining your LAN and your wireguard network.

 

  • Thanks 1
Link to comment
10 hours ago, binhex said:

you need to add the wireguard assigned network to the value for env var LAN_NETWORK, using a comma to separate the values, so you should end up with LAN_NETWORK value defining your LAN and your wireguard network.

 

My hero. I saw the setting, but somehow forgot to fiddle with it. I feel a bit silly now. I've donated to you again. Thank you!

  • Like 1
Link to comment
15 hours ago, exlibermortis said:

Update: I used https://www.yougetsignal.com/tools/open-ports/ as recommended in the FAQ to check to see if the port autoconfigured by PIA is open and it is not. How do I resolve this? Thanks for any help anyone can provide!

are you sure of this?, are you putting in the external ip and the port as shown in the supervisord.log?, you cannot enter in your isp's ip address as the port will not be shown as open.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.