[Support] binhex - qBittorrentVPN


binhex

Recommended Posts

Been using this for months without issue, and then the last few days I cannot access the UI after starting the docker.

 

I've tried renaming the appdata folder for it (copying the openvpn config into the new one it creates), and renaming the torrent and complete/incomplete folders in case that's a factor. Something weird is going on.

 

I've also tried with debug on but that doesn't yield any clues.

 

The last entry in the log is:

2021-10-15 11:45:33,020 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process started
[info] Waiting for qBittorrent process to start listening on port 8117...

2021-10-15 11:45:33,131 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process listening on port 8117

2021-10-15 11:45:33,155 DEBG 'watchdog-script' stdout output:
[debug] VPN incoming port is 54846
[debug] qBittorrent incoming port is 54846
[debug] VPN IP is 10.3.112.113
[debug] qBittorrent IP is 10.3.112.113

2021-10-15 11:45:33,628 DEBG 'start-script' stdout output:
[info] Successfully assigned and bound incoming port '54846'

2021-10-15 11:46:03,163 DEBG 'watchdog-script' stdout output:
[debug] Checking we can resolve name 'www.google.com' to address...

2021-10-15 11:46:03,190 DEBG 'watchdog-script' stdout output:
[debug] DNS operational, we can resolve name 'www.google.com' to address '142.250.187.228'

2021-10-15 11:46:03,191 DEBG 'watchdog-script' stdout output:
[debug] Waiting for iptables chain policies to be in place...

2021-10-15 11:46:03,200 DEBG 'watchdog-script' stdout output:
[debug] iptables chain policies are in place

 

Does anyone have any ideas?

Has there been a recent update that may have affected anything?

 

I am trying direct access, so no reverse proxy or anything like that to consider.

 

Cheers,

Pacman

 

 

PS: Oh, and if I access the console for the docker I cannot see anything going nuts in "top".

Edited by SudoPacman
Link to comment
17 minutes ago, binhex said:

that looks like a clean start from the small snippet of the log you have provided, have you changed lan network range?, created more vlan's?, reconfigured firewall etc?.

 

Yeah, I thought it looked clean too. No errors or anything. Strange.

Tried different browsers, machines, OSes. Rebooted.

Everything i can think of.

 

No, nothing has changed wrt to network or vlans. It's all been setup for months and months now!

It's on br0 and always has been. I've tried changing to bridge but see the same thing.

 

I wonder whether forcing a reinstall of the docker image is worth trying?

Is that just a case of removing it and adding it again?

Link to comment
3 minutes ago, SudoPacman said:

Nope, no dice.

Tried changing the port back to the default 8080 and still no luck. I realised that 8080 is available on br0 after all, but not some others.

 

I'm out of ideas.

are you also setting the WEBU_PORT?, this needs to match, see this from the readme:-

Quote

Due to issues with CSRF and port mapping, should you require to alter the port for the webui you need to change both sides of the -p 8080 switch AND set the WEBUI_PORT variable to the new port.

For example, to set the port to 8090 you need to set -p 8090:8090 and -e WEBUI_PORT=8090

 

Link to comment

Okay, thought I'd try your rtorrentvpn docker and same thing (just times out), which has led me to my opnsense firewall live view.

Looks like an update there may have done something since I can see it getting blocked by the "default deny rule".

 

Thanks for your help binhex, I really appreciate it (and love your dockers).

I'll report back, but sure it's something this end now.

 

Cheers

  • Like 1
Link to comment
On 10/14/2021 at 4:35 AM, binhex said:

are you sure of this?, are you putting in the external ip and the port as shown in the supervisord.log?, you cannot enter in your isp's ip address as the port will not be shown as open.

Yes, I'm entering both the IP address and the port found in the supervisord.log file. I'm using PIA's CA Montreal server, but oddly enough, when I try to geolocate the IP address, it fails; normally, PIA servers show up as the correct region. Any thoughts as to why this might be? Attaching the latest supervisord.log file. Thanks!

supervisord - Copy.log

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.