[Support] binhex - qBittorrentVPN


binhex

Recommended Posts

Hello,

 

I updated my Docker container to the latest qBT release (4.4.0) and for some reason it changed some of my config settings. The paths for completed, temporary, copy torrents to and copy finished torrents to folders had all been reset to locations inside the container. It also reset my rate limits on the speed tab. The more serious configuration setting was that it reverted to using any available interface instead of tun0. I caught it after about 2 hrs of run-time.

 

It's working as expected now that I've reset everything, but I just wanted to mention it in case others experience the same issue.

 

Link to comment
49 minutes ago, AgentXXL said:

Hello,

 

I updated my Docker container to the latest qBT release (4.4.0) and for some reason it changed some of my config settings. The paths for completed, temporary, copy torrents to and copy finished torrents to folders had all been reset to locations inside the container. It also reset my rate limits on the speed tab. The more serious configuration setting was that it reverted to using any available interface instead of tun0. I caught it after about 2 hrs of run-time.

 

It's working as expected now that I've reset everything, but I just wanted to mention it in case others experience the same issue.

 

I have a similar issue, the config file doesn't seems to have changed, but the save path of each torrent as been change to /config/qBittorrent/downloads and qbitorrent is now moving all the files to the inside of the container (into my cache drive). Reverting to the previous image (4.3.9-2-01) seems to fix the issue.

Link to comment
3 hours ago, AgentXXL said:

Hello,

 

I updated my Docker container to the latest qBT release (4.4.0) and for some reason it changed some of my config settings. The paths for completed, temporary, copy torrents to and copy finished torrents to folders had all been reset to locations inside the container. It also reset my rate limits on the speed tab. The more serious configuration setting was that it reverted to using any available interface instead of tun0. I caught it after about 2 hrs of run-time.

 

It's working as expected now that I've reset everything, but I just wanted to mention it in case others experience the same issue.

 

Just updated the docker to 4.4.0 and I have the exact same issues. 

 

In the WebUI, under the torrent list where the General / Trackers / Peers etc information is, everything was blank with 4.4.0

 

I reverted to the previous image (4.3.9-2-01) for now.

Edited by frank-unr
Link to comment

Same happened here. I was woken up by emails saying my NVMEs were overheating. Having automatic file management enabled had moved almost everything over to the config/qBittorent/downloads folder in appdata for the past 7 hours.

 

For anyone else who may have to google how to downgrade their docker container; edit the container and change "Repository" to "binhex/arch-qbittorrentvpn:4.3.9-2-01" without the quotes.

  • Thanks 1
Link to comment

Also experienced this on the new update, downloads directory and a few other things got reset and the container was consuming 4 GB of ram (at least double what I'm used to, which already seemed high). Fortunately nothing had been downloading this morning and sonarr/radarr warned me that my paths were incorrect, otherwise this probably would have quickly brought my system to its knees

Link to comment
2 minutes ago, binhex said:

 

hi guys, this looks like a qbittorrent bug, please feel free to monitor or add anything useful to this support thread:- https://github.com/binhex/arch-qbittorrentvpn/issues/121

 

if you wish to roll back to get you going then follow these instructions, see Q5:- https://github.com/binhex/documentation/blob/master/docker/faq/unraid.md

The links are missing.

Link to comment
3 minutes ago, binhex said:

updated, i have found what i think is a related issue raised on the qbittorrent github repo so ive linked to that now.

Yeah, I saw that thread yesterday and wondered if it was related. Looks like they’ll probably be pushing out a fix soon.

Link to comment
17 minutes ago, wgstarks said:

Yeah, I saw that thread yesterday and wondered if it was related. Looks like they’ll probably be pushing out a fix soon.

 

yeah, sometimes its hard to identify the correct issue with qbittorrent as there are just SO many open issues! i dont think ive ever seen a repo with 2600+ open issues!

Link to comment

My Cache drive was completely full,  I then clicked move (normally it should happen daily my schedule) and it stayed full - with numbers changing, but essentially full.  I logged in (at first it wouldn't take the login and password) - it shows everything as moving and a number of items as completed.   I stopped the docker container and the move started reducing cache drive size.

It appears that setting autoupdate for plugins and dockers may have been a mistake, this update appears to have happened at 00:01 january 8, so the moving etc has been happing for 11 hours.

1. How do i roll back to a previous qbitvpn? Will that automatically move all the files back? Answer found the following a few links above (sorry) - will see if i can figure that out.

 

"Q5. There is an issue with the latest version of an application, how do i roll back to a specific version?

A5. In order to pull down a specific version of an application you need to specify the tag with the version you want. To find out what tags are available for the docker image you need to go to the first post in the applications support thread, then copy the URL shown after the text "Docker Hub:" and append "tags/" to the end of the url and paste into your preferred browser.

This will return a list of available tag names, make a note of the tag you want (tag name denotes the version of the application) and then go the unRAID web interface, left clicking the specific Docker container and selecting "edit", then click on the advanced view option (top right) and edit the repository string, adding in ":" to the end of the name, e.g. to specify a version of 1.0.0.0 for couchpotato. the repository would be changed from:-

binhex/arch-couchpotato

to

binhex/arch-couchpotato:1.0.0.0"

 

2. I found the data that is moved here "appdata\binhex-qbittorrentvpn\qBittorrent\downloads\" about 703 GB

3. When a cache drive is completely full, does unraid still work and handle this gracefully?  Just writing it with parity to the data drives?

4. Anything else i should consider? i do have backups of my appdata last backup is 6 days ago.  Probably need to get this solved before it tries to zip up the important data again (in 12 hours)

Edited by FrozenGamer
Link to comment
23 minutes ago, FrozenGamer said:

Anything else i should consider?

I really don’t think there is a need to use cache for video files. Downloading and moving files is all done in the background so it’s not like you’re sitting there waiting for it to complete. A slightly faster speed won’t really matter.

 

Also, I don’t use auto-update. Just personal opinion but I’m sure you see why. You can set a canary period in CA for plugins (I use 3 days) and update dockers manually. I usually use “update all” whenever FCP starts complaining about “Updates Available”. As long as you follow the various support threads you’ll know about problems like this way before you get sucked in.

 

Just my 2 cents FWIW.😁

Link to comment

I reverted to the suggested version 4.3.3-1-07, started the docker

Things didn't go well.

Lots of errors

mover appears to be broken

Jan 8 12:10:39 Tower kernel: BTRFS error (device loop2): parent transid verify failed on 744964096 wanted 3046329 found 3046327

will be posting logs once i do another diagnostics. mover stopped after moving 9.9GB

 

Link to comment

I´ve googled the shiz out of this and not found f-in anything, so I apologize if this has already been answered.

(And to clearify what I want, I wanna have a folder on my array named "Incomplete" where unfinished torrents are located, when they are finished they should be auto moved to a folder named "Osorterat". Since I regulary backup my appdata folder, I don´t wanna be backing up torrents)


Im on Unraid Version: 6.10.0-rc2


Got the docker working just fine, but if I try to change the download folder I get mkdir (torrent-name) error: Permission denied. 

At first I had the target folder set as private, so I just figured I´ll set it to public and everything will work fine, but Nope, still same error in the log and the torrent "errored" in the webui. 

It works just fine if I revert back to the stock "appdata - dockercontainerfolder/data" folder, but as soon as I try to change it to any other folder on my array I get permission denied error.

 

Full error output :

(N) 2022-01-08T22:47:13 - 'torrent-i-try-to-download.file' was removed from the transfer list and hard disk.
(N) 2022-01-08T22:47:25 - 'torrent-i-try-to-download.file' added to download list.
(N) 2022-01-08T22:47:26 - Couldn't enqueue move of "torrent-i-try-to-download.file" from "/mnt/user/Media/Osorterat/" to "/mnt/user/Media/Osorterat". Both paths point to the same location.
(W) 2022-01-08T22:47:31 - File error alert. Torrent: "torrent-i-try-to-download.file". File: "/mnt/user/Media/Osorterat/torrent-i-try-to-download.file/torrent-i-try-to-download.file". Reason: torrent-i-try-to-download.file mkdir (/mnt/user/Media/Osorterat/torrent-i-try-to-download.file/torrent-i-try-to-download.file) error: Permission denied

 

 

redacted the exact torrent name for obvious reasons. 

 

 

Last edit:
The download directory I try to set is at the moment set to public with 777 permissions, but that has made No difference. 

I´ve tried without setting the incomplete folder, thats when I get "Both paths point to the same location" in the log.

Edited by BeardElk
Link to comment

Since yesterday my deluge stopped working. im running version 1.3.15_18. i also downloaded a current version of delugevpn and still gave me the same error. i made zero changes to unraid or dockers.

 

the following error from logs:

022-01-08 15:24:27,329 DEBG 'start-script' stdout output:
[info] Attempting to load tun kernel module...

2022-01-08 15:24:27,332 DEBG 'start-script' stderr output:
modprobe: FATAL: Module tun not found in directory /lib/modules/5.10.21-Unraid

2022-01-08 15:24:27,332 DEBG 'start-script' stdout output:
[warn] Unable to load tun kernel module using modprobe, trying insmod...

2022-01-08 15:24:27,334 DEBG 'start-script' stderr output:
insmod: ERROR: could not load module /lib/modules/tun.ko: No such file or directory

 

i followed the steps from the docker vpn faq:

 

SSH into the unRAID host and issue the following commands:-

echo "# force iptable mangle module to load (required for *vpn dockers)" >> /boot/config/go

echo "/sbin/modprobe iptable_mangle" >> /boot/config/go

 

Reboot the host for the change to take effect

 

Note - If you want to apply the fix straight away issue the following:-

/sbin/modprobe iptable_mangle

 

 

any ideas?

Link to comment
3 hours ago, FrozenGamer said:

tower-diagnostics-20220108-1214.zip 286.17 kB · 0 downloads

syslog shows problems at 11:43 today.

edit.  the error continues to show up every minute or so in the log.  shut off all dockers except for my kids terraria server, but haven't rebooted yet.  Should i move this to another thread?  Should i just shut down the entire server until i find a solution?

I would start a thread in general support. Be sure to include diagnostics.

Link to comment
3 hours ago, BeardElk said:

I wanna have a folder on my array named "Incomplete" where unfinished torrents are located, when they are finished they should be auto moved to a folder named "Osorterat

Attach your run command to your next post so that we can see how you have the docker configured. Also, just to be sure, what version of qbit do you have installed? There’s a bug with most recent release (see the posts above yours).

Link to comment
1 hour ago, Virus said:

Since yesterday my deluge stopped working. im running version 1.3.15_18. i also downloaded a current version of delugevpn and still gave me the same error. i made zero changes to unraid or dockers.

I would suggest posting in the delugevpn support thread rather than the qbittorrent.

https://forums.unraid.net/topic/44109-support-binhex-delugevpn/

Edited by wgstarks
Link to comment
27 minutes ago, wgstarks said:

I would start a thread in general support. Be sure to include diagnostics.

Thanks! - i rebooted the server, still every time it was moving files and filling up my cache drive, so i just deleted all of the listed torrents, which may have solved it.  Now i just need to move all the extra stuff out of my appdata folder that seems to have been dumped in there by qbittorrent.  At this point i don't know if i still have a problem with my cache drive integrity as the error hasn't been back since rebooted.  Not a good day but hopefully my data and server are intact.  Brain overloading a little.

Link to comment
4 minutes ago, FrozenGamer said:

Not a good day but hopefully my data and server are intact.  Brain overloading a little.

Why don’t you attach your docker run command to your next post. The only thing that you should normally have on cache would be the appdata. Not torrents files or downloads.

Edited by wgstarks
Link to comment
8 minutes ago, wgstarks said:

Why don’t you attach your docker run command to your next post. The only thing that you should normally have on cache would be the appdata. Not torrents files or downloads.

I deleted a few of the variables for privacy, but here it is.

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker create --name='binhex-qbittorrentvpn' --net='bridge' --privileged=true -e TZ="DELETED " -e HOST_OS="Unraid" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='DELETED' -e 'VPN_PASS'='DELETED' -e 'VPN_PROV'='pia' -e 'VPN_CLIENT'='openvpn' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='yes' -e 'WEBUI_PORT'='8080' -e 'LAN_NETWORK'='192.168.1.0/24' -e 'NAME_SERVERS'='209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1' -e 'ADDITIONAL_PORTS'='' -e 'DEBUG'='false' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -p '6881:6881/tcp' -p '6881:6881/udp' -p '8080:8080/tcp' -p '8118:8118/tcp' -v '/mnt/user/Torrents/':'/data':'rw' -v '/mnt/user/appdata/binhex-qbittorrentvpn':'/config':'rw' --sysctl="net.ipv4.conf.all.src_valid_mark=1" 'binhex/arch-qbittorrentvpn:4.3.3-1-07'
004c3ff1289adab9e8d635471e591f4fd3a9ef8f2e08215162153710ca954d82
 

Link to comment
10 minutes ago, wgstarks said:

Why don’t you attach your docker run command to your next post. The only thing that you should normally have on cache would be the appdata. Not torrents files or downloads.

Do these settings look ok? Perhaps this has something wrong as well. - i did a test download and its stuck on "moving" -

unraid problem.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.