[Support] binhex - qBittorrentVPN


Recommended Posts

12 minutes ago, wgstarks said:

I'm not sure you want your downloads saved to /mnt/user/appdata/. It's up to you but that location would be on the cache drive by default. Usually I think most people probably use a share on the array. I use /mnt/user/Media/ for mine.

 

That's not why you can't connect to the UI though.

 

Attach supervisord log to your next post. You'll need to redact user/passwords from the log first.

I was not setting anything up yet in terms of Downloads and VPN creds. Just want to make sure the docker works properly first and then will edit. Here is the log below hopefully that is the correct one i opened up appdata/binhex-qbittorrentvpn/supervisord.log. Also, now for some reason I can't start the qbVPN anymore. Thanks.

image.thumb.png.ee52f4ce118a70a4f245ec5d4911b367.png

Link to comment
8 minutes ago, BKG said:

I was not setting anything up yet in terms of Downloads and VPN creds. Just want to make sure the docker works properly first and then will edit. Here is the log below hopefully that is the correct one i opened up appdata/binhex-qbittorrentvpn/supervisord.log. Also, now for some reason I can't start the qbVPN anymore. Thanks.

image.thumb.png.ee52f4ce118a70a4f245ec5d4911b367.png

Quote

[crit] No Openvpn config file located in /config/openvpn/ (ovpn extension), please download from your VPN provider and then restart this contalner.

 

You need to install the .ovpn file you downloaded from PIA.

Link to comment
On 11/12/2018 at 3:04 PM, binhex said:

Yeah the secret sauce here is that not only do you need to change the host side port but you also have to change the container side port too to match. so this is a bit more tricky with the unraid web ui, as unraid rightly stops users doing this as you normally don't want to change the container port side but for this particular container we have to.

 

So in order to get around this you need to edit the container and then use the link down the bottom shown as "Add another Path, Port, Variable, Label or Device", select "config type" as "port" then put in the port number you want for both the "container port" and "host port" and then click "add".

 

So now you have added the additional port you can now remove the old port, as this will now clash on the host port if you have already altered it.

 

Remember - Make sure to set the  webui_port to the same value and then click on "apply" button to apply the changes.

 

Finally open up your favourite browser and point it at the http://<host ip address>:<port of your choice>

This is where I am floating. I followed this but I think i did something wrong.

Link to comment

pretty sure I put the right one. I did this before with QNAP and also on my ANDROID TV .  I fetched from the log that the VPN is connecting. I reducted few  things as ******** in the log, but it shows it successfully connects and obtaind VPN IP. What bothers me is not the VPN but the fact I can't get it to show the WEBUI. 

Link to comment
9 hours ago, BKG said:

What bothers me is not the VPN but the fact I can't get it to show the WEBUI. 

are you attempting to connect to the web ui from within your LAN or over a VPN connection to your LAN?, also what is the IP address of the machine running the web browser?.

Link to comment

Hi binhex, see my answers below and also attached visual aid to back up.

  • I am attempting to connect on the LAN. I am trying to get to the WEBUI.
  • I have two physical NICs. eth0 is bridged and allocated to server control and VM network. eth1 is bridged and allocated to Docker network(see attached). Controllers are in the separate IOMMU groups.
  • I am using eth1(br1) to connect to the QBVPN container on the 192.168.0.0/24 network.
  • I can hit other containers on the eth1(br1) 192.168.0.0/24 network(see attached).
  • I can hit VM on the eth0(br0) 192.168.10.0/24 network(see attached).
  • I don't quite get your guidance, which I quoted in the above reply, where you referencing your "SECRET SAUCE" where you tell to add an additional port and delete the original one. I think that is where the problem is in my case.

I would really appreciate if you can share the screen shot of your setup to compare.

 

Thanks,

NICs_IOMMU.JPG

docker_VM-layout.pdf

Link to comment
23 minutes ago, BKG said:

Hi binhex, see my answers below and also attached visual aid to back up.

  • I am attempting to connect on the LAN. I am trying to get to the WEBUI.
  • I have two physical NICs. eth0 is bridged and allocated to server control and VM network. eth1 is bridged and allocated to Docker network(see attached). Controllers are in the separate IOMMU groups.
  • I am using eth1(br1) to connect to the QBVPN container on the 192.168.0.0/24 network.
  • I can hit other containers on the eth1(br1) 192.168.0.0/24 network(see attached).
  • I can hit VM on the eth0(br0) 192.168.10.0/24 network(see attached).
  • I don't quite get your guidance, which I quoted in the above reply, where you referencing your "SECRET SAUCE" where you tell to add an additional port and delete the original one. I think that is where the problem is in my case.

I would really appreciate if you can share the screen shot of your setup to compare.

 

Thanks,

NICs_IOMMU.JPG

docker_VM-layout.pdf 1022.39 kB · 1 download

so looking at your pdf, are you trying to access the qbittorrent web ui from a vm with an ip in the range of 192.168.10.xxx? if so that is your issue, you need to add that range to LAN_NETWORK, use a comma to separate values if you have multiples.

Link to comment
48 minutes ago, binhex said:

so looking at your pdf, are you trying to access the qbittorrent web ui from a vm with an ip in the range of 192.168.10.xxx? if so that is your issue, you need to add that range to LAN_NETWORK, use a comma to separate values if you have multiples.

No , I don't try and use the VM to connect to QB. I presented the PDF to reflect the high-level picture of what I have and that I can connect to to other docker-containers on the 192.168.0.0/24 network. I do not use the 192.168.10.0/24 network to connect to QB. Again, I have two physical networks right now, one allocated to VM and the other to Docker. 

Link to comment
7 minutes ago, BKG said:

No , I don't try and use the VM to connect to QB. I presented the PDF to reflect the high-level picture of what I have and that I can connect to to other docker-containers on the 192.168.0.0/24 network. I do not use the 192.168.10.0/24 network to connect to QB. Again, I have two physical networks right now, one allocated to VM and the other to Docker. 

ok so to confirm then, can you answer my earlier question:-

4 hours ago, binhex said:

what is the IP address of the machine running the web browser?.

this is a common trip up point where people are attempting to access the web ui from a network that is not defined in LAN_NETWORK and it is then blocked by iptables.

Link to comment
On 11/12/2018 at 3:04 PM, binhex said:

Yeah the secret sauce here is that not only do you need to change the host side port but you also have to change the container side port too to match. so this is a bit more tricky with the unraid web ui, as unraid rightly stops users doing this as you normally don't want to change the container port side but for this particular container we have to.

 

So in order to get around this you need to edit the container and then use the link down the bottom shown as "Add another Path, Port, Variable, Label or Device", select "config type" as "port" then put in the port number you want for both the "container port" and "host port" and then click "add".

 

So now you have added the additional port you can now remove the old port, as this will now clash on the host port if you have already altered it.

 

Remember - Make sure to set the  webui_port to the same value and then click on "apply" button to apply the changes.

 

Finally open up your favourite browser and point it at the http://<host ip address>:<port of your choice>

i presented the PDF as a backup to show that each individual network is working properly with its respective components - VMs, dockers except for the WEBUI for the QB. As a troubleshooting step i downloaded and installed the other QB build which works with the same network parameters, but doesn't have VPN built-in like yours does (see attached). See attached picture. I do believe the problem is in the setup. Can yo please expand on this quote above?

 

Thanks,

qbvpn-5.JPG

qbvpn-6.JPG

Link to comment
1 minute ago, binhex said:

ok so to confirm then, can you answer my earlier question:-

this is a common trip up point where people are attempting to access the web ui from a network that is not defined in LAN_NETWORK and it is then blocked by iptables.

container LAN is 192.168.0.0/24. unless i am confusing this question with something else.

 

Thanks,

qbvpn-7.JPG

Link to comment
2 minutes ago, BKG said:

i presented the PDF as a backup to show that each individual network is working properly with its respective components - VMs, dockers except for the WEBUI for the QB.

sure, this docker is not like the rest, it has a built in vpn client and thus security needs to be super tight to prevent ip leakage, thats why you are struggling with this particular container whilst the others work, you are missing some setting somewhere.

 

3 minutes ago, BKG said:

Can yo please expand on this quote above?

im not sure how to expand on it any further to be honest, which part of it is unclear to you?.

Link to comment
1 minute ago, BKG said:

container LAN is 192.168.0.0/24.

ok yep i spotted that but what is the ip address of the tablet/phone/laptop/desktop that you are using to attempt to access the qbittorrent web ui from?.

Link to comment

the IP of the PC is 192.168.20.0/24 network but passed to other subnets in my network setup. For example, i can hit my router on 192.168.0.0/24 network, my cameras on 192.168.10.0/24 network, and my unraid on 192.168.10.0/24. 

Link to comment
Just now, BKG said:

the IP of the PC is 192.168.20.0/24

then that is your issue, iptables built into qbittorrent will block this, it doesnt matter whether your lan allows it, iptables in the container will not!. 

 

add 192.168.20.0/24 to LAN_NETWORK, use a comma to separate if you want to access the web ui from several networks.

Link to comment
8 minutes ago, BKG said:

tried that, no luck...

i see from your screenshots you are using macvlan as well (specific ip for the container), this will not work, you need to set this to 'bridge', not 'br1'.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.