[Support] binhex - qBittorrentVPN


binhex

Recommended Posts

anyone know what might be going on? so i have qbit on docker setup with torguard threw the port forwarding threw tor and config file. download speeds are good when it downloads but 90% stuck on metadata and not finding peers. those same torrents added to the one running on desktop setup threw socks5 with no firewall settings find and dl in an instant. not sure if its related to vpn but just giving my setups. ive also tried setting up docker one threw sock5 and it found alot more but not all.

Link to comment

99% of the issues seem to be with upstream qbittorrent, the 4.x versions have been a problem outside of docker on windows and linux. I've had endless problems with very large torrent download just throwing an error with nothiing in the logs.

 

I rolled back to 4.3.9 and its been rock solid since. 

Link to comment

Hi there,

 

I have an issue with the webUI loading extremely slowly when VPN is enabled. Using an identical config to before it's suddenly stopped working properly. I've tried the latest and 4.3.9-2-01 release but get the same result. The UI does load, but it hangs and takes a very long time to load. Disabling VPN fixes the issue and UI loads immediately.

 

I've tried fresh ovpn config files but get the same issue. I'm using SurfShark VPN if that helps.

 

EDIT: Just tried with NordVPN as well, get the same issue

 

EDIT2: Interesting discovery. If I have the VPN enabled and route another qbittorrent instance with the VPN disabled through the container, UI loads instantly and it will connect via the container's VPN no problem, but the UI on the container with VPN enabled will still hang.

Edited by Shinobu
Link to comment

Hi there,
 

I have a question, whether something is supported or not. I am talking about NordVPN's NordLynx protocol. Is there someone who know how to set this up? Or has it even working with still container? I am currently using NordVPN's open-VPN profile.

 

I already saw the following article, but this uses an other container. https://www.blackvoid.club/running-your-torrent-client-via-nordvpn-lynx-wireguard/

 

Thanks!

 

Edited by sem
Link to comment
22 minutes ago, mgadbois said:

Noob question, but how does one roll back to an older version of an unraid docker?

Click the name of the docker on the docker tab. In the repository field type a colon after the name followed by your desired tag number.

Edited by wgstarks
Link to comment

Hi Guys,

I hope someone can help. All was working yesterday on my install of binhex-qbittorrentvpn. This morning when I try to log in I get a log in error. I check the logs and I see the below, I have changed nothing recently. Any help would be appricated. I'm using the binhex/arch-qbittorrentvpn repository and am on the latest version. Thanks
 

Quote

(N) 2022-06-27T10:24:39 - Using config directory: /config/qBittorrent/config
(N) 2022-06-27T10:24:39 - qBittorrent v4.4.3.1 started
(N) 2022-06-27T10:24:39 - Using config directory: /config/qBittorrent/config
(I) 2022-06-27T10:24:39 - Trying to listen on: 0.0.0.0:20893,[::]:20893
(N) 2022-06-27T10:24:39 - Peer ID: -qB4431-
(N) 2022-06-27T10:24:39 - HTTP User-Agent is 'qBittorrent/4.4.3.1'
(I) 2022-06-27T10:24:39 - DHT support [ON]
(I) 2022-06-27T10:24:39 - Local Peer Discovery support [ON]
(I) 2022-06-27T10:24:39 - PeX support [ON]
(I) 2022-06-27T10:24:39 - Anonymous mode [OFF]
(I) 2022-06-27T10:24:39 - Encryption support [ON]
(I) 2022-06-27T10:24:39 - UPnP / NAT-PMP support [ON]
(I) 2022-06-27T10:24:39 - IP geolocation database loaded. Type: DBIP-Country-Lite. Build time: Wed Jun 1 01:25:04 2022.
(N) 2022-06-27T10:24:39 - Using built-in Web UI.
(N) 2022-06-27T10:24:40 - Web UI translation for selected locale (en) has been successfully loaded.
(N) 2022-06-27T10:24:40 - Web UI: Now listening on IP: *, port: 8080
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 127.0.0.1, port: TCP/20893
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 127.0.0.1, port: UTP/20893
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 10.11.159.222, port: TCP/20893
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 10.11.159.222, port: UTP/20893
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 172.17.0.3, port: TCP/20893
(I) 2022-06-27T10:24:40 - Successfully listening on IP: 172.17.0.3, port: UTP/20893
(I) 2022-06-27T10:25:05 - Detected external IP: 181.214.206.222
(W) 2022-06-27T10:25:26 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:25:27 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:25:37 - WebAPI login failure. Reason: invalid credentials, attempt count: 1, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:25:58 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:13 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:26 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:38 - WebAPI login failure. Reason: invalid credentials, attempt count: 2, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:26:40 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:172.17.0.1, username: 
(W) 2022-06-27T10:26:42 - WebAPI login failure. Reason: invalid credentials, attempt count: 4, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:26:49 - WebAPI login failure. Reason: invalid credentials, attempt count: 5, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:26:49 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:50 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:53 - WebUI: Invalid Host header, port mismatch. Request source IP: '::ffff:172.17.0.1'. Server port: '8080'. Received Host header: '192.168.68.249:8585'
(W) 2022-06-27T10:26:53 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: 
(W) 2022-06-27T10:26:55 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:26:59 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: admin
(C) 2022-06-27T10:27:15 - UPnP/NAT-PMP: Port mapping failure, message: could not map port using UPnP[10.11.159.222]: no router found
(C) 2022-06-27T10:27:15 - UPnP/NAT-PMP: Port mapping failure, message: could not map port using UPnP[10.11.159.222]: no router found
(C) 2022-06-27T10:27:15 - UPnP/NAT-PMP: Port mapping failure, message: could not map port using UPnP[10.11.159.222]: no router found
(W) 2022-06-27T10:27:36 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:28:37 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: admin
(W) 2022-06-27T10:28:54 - WebAPI login failure. Reason: IP has been banned, IP: ::ffff:172.17.0.1, username: admin
(N) 2022-06-27T10:30:59 - qBittorrent v4.4.3.1 started
(N) 2022-06-27T10:30:59 - Using config directory: /config/qBittorrent/config
(N) 2022-06-27T10:30:59 - qBittorrent v4.4.3.1 started

 

Link to comment

Tried rolling back and am getting the same error of unauthorized. Here is the log form the docker.

 

2022-06-27 13:03:39 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
2022-06-27 13:03:39 VERIFY EKU OK
2022-06-27 13:03:39 VERIFY OK: depth=0, CN=us8390.nordvpn.com

2022-06-27 13:03:39,173 DEBG 'start-script' stdout output:
2022-06-27 13:03:39 Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, peer certificate: 4096 bit RSA, signature: RSA-SHA512
2022-06-27 13:03:39 [us8390.nordvpn.com] Peer Connection Initiated with [AF_INET]X.X.X.X:1194

2022-06-27 13:03:40,363 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 SENT CONTROL [us8390.nordvpn.com]: 'PUSH_REQUEST' (status=1)

2022-06-27 13:03:40,381 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 103.86.96.100,dhcp-option DNS 103.86.99.100,sndbuf 524288,rcvbuf 524288,explicit-exit-notify,comp-lzo no,route-gateway 10.8.2.1,topology subnet,ping 60,ping-restart 180,ifconfig 10.8.2.7 255.255.255.0,peer-id 5,cipher AES-256-GCM'

2022-06-27 13:03:40,382 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 OPTIONS IMPORT: timers and/or timeouts modified
2022-06-27 13:03:40 OPTIONS IMPORT: explicit notify parm(s) modified
2022-06-27 13:03:40 OPTIONS IMPORT: compression parms modified
2022-06-27 13:03:40 OPTIONS IMPORT: --sndbuf/--rcvbuf options modified
2022-06-27 13:03:40 Socket Buffers: R=[212992->1048576] S=[212992->1048576]
2022-06-27 13:03:40 OPTIONS IMPORT: --ifconfig/up options modified
2022-06-27 13:03:40 OPTIONS IMPORT: route options modified
2022-06-27 13:03:40 OPTIONS IMPORT: route-related options modified
2022-06-27 13:03:40 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
2022-06-27 13:03:40 OPTIONS IMPORT: peer-id set
2022-06-27 13:03:40 OPTIONS IMPORT: adjusting link_mtu to 1657
2022-06-27 13:03:40 OPTIONS IMPORT: data channel crypto options modified
2022-06-27 13:03:40 Data Channel: using negotiated cipher 'AES-256-GCM'
2022-06-27 13:03:40 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2022-06-27 13:03:40 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
2022-06-27 13:03:40 net_route_v4_best_gw query: dst 0.0.0.0
2022-06-27 13:03:40 net_route_v4_best_gw result: via 172.19.0.1 dev eth0
2022-06-27 13:03:40 ROUTE_GATEWAY 172.19.0.1/255.255.0.0 IFACE=eth0 HWADDR=02:42:ac:13:00:0e

2022-06-27 13:03:40,383 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 TUN/TAP device tun0 opened
2022-06-27 13:03:40 net_iface_mtu_set: mtu 1500 for tun0
2022-06-27 13:03:40 net_iface_up: set tun0 up
2022-06-27 13:03:40 net_addr_v4_add: 10.8.2.7/24 dev tun0
2022-06-27 13:03:40 /root/openvpnup.sh tun0 1500 1585 10.8.2.7 255.255.255.0 init

2022-06-27 13:03:40,389 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 net_route_v4_add: 143.244.61.238/32 via 172.19.0.1 dev [NULL] table 0 metric -1

2022-06-27 13:03:40,389 DEBG 'start-script' stdout output:
2022-06-27 13:03:40 net_route_v4_add: 0.0.0.0/1 via 10.8.2.1 dev [NULL] table 0 metric -1
2022-06-27 13:03:40 net_route_v4_add: 128.0.0.0/1 via 10.8.2.1 dev [NULL] table 0 metric -1
2022-06-27 13:03:40 Initialization Sequence Completed

2022-06-27 13:03:56,583 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using 'http://checkip.amazonaws.com'...

2022-06-27 13:03:56,841 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 94.140.9.199

2022-06-27 13:03:56,843 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

2022-06-27 13:03:56,883 DEBG 'watchdog-script' stdout output:
[info] qBittorrent listening interface IP 0.0.0.0 and VPN provider IP 10.8.2.7 different, marking for reconfigure

2022-06-27 13:03:56,891 DEBG 'watchdog-script' stdout output:
[info] qBittorrent not running

2022-06-27 13:03:56,897 DEBG 'watchdog-script' stdout output:
[info] Privoxy not running

2022-06-27 13:03:56,898 DEBG 'watchdog-script' stdout output:
[info] Removing session lock file (if it exists)...

2022-06-27 13:03:56,923 DEBG 'watchdog-script' stdout output:
[info] Attempting to start qBittorrent...

2022-06-27 13:03:57,201 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process started
[info] Waiting for qBittorrent process to start listening on port 8080...

2022-06-27 13:03:57,439 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process listening on port 8080

2022-06-27 13:03:57,442 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Privoxy...

2022-06-27 13:03:58,453 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2022-06-27 13:03:58,462 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

Link to comment

Hello all

 

I'm still new to UnRaid, and Linux in general, but i have been having a problem with Binhex qBittorentVPN for over a year.

 

I have just done a reinstall of UnRaid 6.10.3. Before i was on 6.9.2, but QB has the same issue in the new version. I have a 1Gbps Internet Connection over Fiber, but when I download at full speed 6 Cores out of 8 is pined at 100% most at the time on the Dashboard. I have done the command htop where i can see QB using over 200% CPU often. How is that even possible?

 

In UnRaid 6.10.3 the download speed will jump very quickly up to 1Gbps and then back down to like 350-450Mbps, and then completely stop for 10-15Sec, and then repeat. I only have 49 torrents seeding and 1 Downloading when this happens.

 

I should mention that i have set "VPN_ENABLED" = no in the Docker Template, but it was the same issue with it enabled on 6.9.2 using PIA VPN, but the connection was more stable, and topping out at 850Mbps.

 

I have just noticed in the syslog.txt from the diagnostics zip when writing this:

 

Line 195 "Jun 23 21:14:18 Loki kernel: Performance Events: PEBS fmt1+, IvyBridge events, 16-deep LBR, full-width counters, Broken BIOS detected, complain to your hardware vendor."

 

Line 196 "Jun 23 21:14:18 Loki kernel: [Firmware Bug]: the BIOS has corrupted hw-PMU resources (MSR 38d is 330)"

 

what is this? Could this be the culprit?

 

 

 

Qbittorrent_htop.png

loki-diagnostics-20220629-1939.zip

Link to comment
7 hours ago, DrFeelgood said:

but when I download at full speed 6 Cores out of 8 is pined at 100% most at the time on the Dashboard.

I haven't had any problems with Qbit 4.4 but many people have. You might try downgrading to 4.3.9 just to see if that solves your problem. Just paste this into the repository field-

binhex/arch-qbittorrentvpn:4.3.9-2-01

Then click "apply".

To revert back to latest just delete the colon and everything after it.

Link to comment
7 hours ago, DrFeelgood said:

i can see QB using over 200% CPU often. How is that even possible?

Because each core or hyperthread is 0-100% occupied, so the total load is 100% X (number of processor pieces available)

 

You probably were seeing 100% load on 2 cores.

Link to comment
On 6/30/2022 at 3:24 AM, wgstarks said:

I haven't had any problems with Qbit 4.4 but many people have. You might try downgrading to 4.3.9 just to see if that solves your problem. Just paste this into the repository field-

binhex/arch-qbittorrentvpn:4.3.9-2-01

Then click "apply".

To revert back to latest just delete the colon and everything after it.

 

 

Thanks this worked perfectly :) a lot lower CPU Usage, and much more stable download speeds :P

Link to comment

Hello.  Is anyone having a problem where their config file randomly resets?  Ive had to 4-5 times now reload a backup of it and now I've realized all of my backups have the same problem.  I've stuck to the binhex/arch-qbittorrentvpn:4.3.9-1-03 version and am still getting it. 

 

 

Link to comment
Posted (edited)

WebUI (qbittorrent VPN instance) won't open for me despite being connected to my Mullvad server. This is my first time outside a windows environment so you might have to dumb-down some stuff for me. The supervisor logs also states that qbittorent is listening on port 8080.

Screenshot 2022-07-04 223041.png

Screenshot 2022-07-04 224823.png

Edited by Luumi
Link to comment
6 minutes ago, trurl said:

Post your docker run

Thanks for that

 

Here it is:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-qbittorrentvpn' --net='bridge' --privileged=true -e TZ="America/Chicago" -e HOST_OS="Unraid" -e HOST_HOSTNAME="Tower" -e HOST_CONTAINERNAME="binhex-qbittorrentvpn" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='REDACTED' -e 'VPN_PASS'='REDACTED' -e 'VPN_PROV'='custom' -e 'VPN_CLIENT'='openvpn' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='no' -e 'WEBUI_PORT'='8080' -e 'LAN_NETWORK'='192.168.0.0/24' -e 'NAME_SERVERS'='209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1' -e 'VPN_INPUT_PORTS'='' -e 'VPN_OUTPUT_PORTS'='' -e 'DEBUG'='false' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -l net.unraid.docker.managed=dockerman -l net.unraid.docker.webui='http://[IP]:[PORT:8080]/' -l net.unraid.docker.icon='https://raw.githubusercontent.com/binhex/docker-templates/master/binhex/images/qbittorrent-icon.png' -p '6881:6881/tcp' -p '6881:6881/udp' -p '8080:8080/tcp' -p '8118:8118/tcp' -v '/mnt/user/plex/Downloads/':'/downloads':'rw' -v '/mnt/user/plex/Media/Download/':'/porn':'rw' -v '/mnt/user/plex/Media/Eval':'/eval':'rw' -v '/mnt/user/appdata/binhex-qbittorrentvpn':'/config':'rw' --sysctl="net.ipv4.conf.all.src_valid_mark=1" 'binhex/arch-qbittorrentvpn:4.3.9-1-03'

Link to comment

Hi everyone, I'm having an issue getting qbitorrent to connect from devices on the local network.

I've setup the container with several other containers using it for its network connection (Using extra parameters).

 

All of these other containers are working fine and I can connect to them without any issues, however the qbitorrent service itself seems to just time out.

 

Here is the docker run command for the container:
 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-qbittorrentvpn' --net='bridge' --privileged=true -e TZ="Pacific/Auckland" -e HOST_OS="Unraid" -e HOST_HOSTNAME="Zeus" -e HOST_CONTAINERNAME="binhex-qbittorrentvpn" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='$USER' -e 'VPN_PASS'='$PASS' -e 'VPN_PROV'='custom' -e 'VPN_CLIENT'='openvpn' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='no' -e 'WEBUI_PORT'='9514' -e 'LAN_NETWORK'='192.168.50.0/24,10.242.0.0/16,172.0.0.0/8,10.8.0.0/16' -e 'NAME_SERVERS'='84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1' -e 'VPN_INPUT_PORTS'='8989,9696,6789,7878,9514' -e 'VPN_OUTPUT_PORTS'='32400,8096' -e 'DEBUG'='true' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -l net.unraid.docker.managed=dockerman -l net.unraid.docker.webui='http://[IP]:[PORT:8080]/' -l net.unraid.docker.icon='https://raw.githubusercontent.com/binhex/docker-templates/master/binhex/images/qbittorrent-icon.png' -p '6881:6881/tcp' -p '6881:6881/udp' -p '9514:8080/tcp' -p '8118:8118/tcp' -p '8989:8989/tcp' -p '9696:9696/tcp' -p '6789:6789/tcp' -p '7878:7878/tcp' -v '/mnt/user/appdata/data':'/data':'rw' -v '/mnt/user/appdata/binhex-qbittorrentvpn':'/config':'rw' --sysctl="net.ipv4.conf.all.src_valid_mark=1" 'binhex/arch-qbittorrentvpn'

512a9e1237796a72dff020a8c145c86d6a55a215a608edf9608b14864c11d372

 

As you can see I've set the port to a different port since 8080 is in use on the unraid host.
 

The debug logs when starting (Showing that qbittorrent starts and listens on the correct port):

2022-07-07 12:20:31,186 DEBG 'watchdog-script' stdout output:
[info] Attempting to start qBittorrent...

2022-07-07 12:20:31,195 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process started
[info] Waiting for qBittorrent process to start listening on port 9514...

2022-07-07 12:20:31,300 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process listening on port 9514
[debug] VPN IP is 172.21.56.65
[debug] qBittorrent IP is 172.21.56.65

 

Anyone know what I can do to be able to connect to the qbitorrent web UI?

Link to comment
Posted (edited)
2 hours ago, starker3 said:

Hi everyone, I'm having an issue getting qbitorrent to connect from devices on the local network.

I've setup the container with several other containers using it for its network connection (Using extra parameters).

 

All of these other containers are working fine and I can connect to them without any issues, however the qbitorrent service itself seems to just time out.

 

Here is the docker run command for the container:
 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-qbittorrentvpn' --net='bridge' --privileged=true -e TZ="Pacific/Auckland" -e HOST_OS="Unraid" -e HOST_HOSTNAME="Zeus" -e HOST_CONTAINERNAME="binhex-qbittorrentvpn" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='$USER' -e 'VPN_PASS'='$PASS' -e 'VPN_PROV'='custom' -e 'VPN_CLIENT'='openvpn' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='no' -e 'WEBUI_PORT'='9514' -e 'LAN_NETWORK'='192.168.50.0/24,10.242.0.0/16,172.0.0.0/8,10.8.0.0/16' -e 'NAME_SERVERS'='84.200.69.80,37.235.1.174,1.1.1.1,37.235.1.177,84.200.70.40,1.0.0.1' -e 'VPN_INPUT_PORTS'='8989,9696,6789,7878,9514' -e 'VPN_OUTPUT_PORTS'='32400,8096' -e 'DEBUG'='true' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -l net.unraid.docker.managed=dockerman -l net.unraid.docker.webui='http://[IP]:[PORT:8080]/' -l net.unraid.docker.icon='https://raw.githubusercontent.com/binhex/docker-templates/master/binhex/images/qbittorrent-icon.png' -p '6881:6881/tcp' -p '6881:6881/udp' -p '9514:8080/tcp' -p '8118:8118/tcp' -p '8989:8989/tcp' -p '9696:9696/tcp' -p '6789:6789/tcp' -p '7878:7878/tcp' -v '/mnt/user/appdata/data':'/data':'rw' -v '/mnt/user/appdata/binhex-qbittorrentvpn':'/config':'rw' --sysctl="net.ipv4.conf.all.src_valid_mark=1" 'binhex/arch-qbittorrentvpn'

512a9e1237796a72dff020a8c145c86d6a55a215a608edf9608b14864c11d372

 

As you can see I've set the port to a different port since 8080 is in use on the unraid host.
 

The debug logs when starting (Showing that qbittorrent starts and listens on the correct port):

2022-07-07 12:20:31,186 DEBG 'watchdog-script' stdout output:
[info] Attempting to start qBittorrent...

2022-07-07 12:20:31,195 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process started
[info] Waiting for qBittorrent process to start listening on port 9514...

2022-07-07 12:20:31,300 DEBG 'watchdog-script' stdout output:
[info] qBittorrent process listening on port 9514
[debug] VPN IP is 172.21.56.65
[debug] qBittorrent IP is 172.21.56.65

 

Anyone know what I can do to be able to connect to the qbitorrent web UI?

If you change the webui port to a custom port you need to create a new port mapping for that port. For mine I used port 8088 so i created another port mapping shown below-

2137482099_ScreenShot2022-07-06at8_58_19PM.thumb.png.6954cd65c57c3eebdbf61c38e5c5e0d2.png

 

The name is up to you. Just change 8088 to whatever port you're using.

 

Edit: Actually, its been a while since I set this up but IIRC you need to delete the existing 8080:8080 port configuration (you can't edit it) and then create the new port configuration.

Edited by wgstarks
Link to comment
8 hours ago, wgstarks said:

If you change the webui port to a custom port you need to create a new port mapping for that port. For mine I used port 8088 so i created another port mapping shown below-

2137482099_ScreenShot2022-07-06at8_58_19PM.thumb.png.6954cd65c57c3eebdbf61c38e5c5e0d2.png

 

The name is up to you. Just change 8088 to whatever port you're using.

 

Edit: Actually, its been a while since I set this up but IIRC you need to delete the existing 8080:8080 port configuration (you can't edit it) and then create the new port configuration.

Thanks for the tip. I hadn't read your reply earlier when I changed some things around, so I ended up changing the other docker that was using port 8080 to a different port to use the default port for qbittorrent.

 

I was looking at a different template which uses a similar method that mentioned you can't bind a different host port to container port with the VPN setup as it causes a DNS rebinding issue. Using the default ports for the containers works though (And is probably why the others worked as is because none of those have different ports between container and host)

  • Like 1
Link to comment

I am migrating from your Deluge VPN to this qBittorrent VPN docker, and when I do that, I can't get Jackett to use the proxy successfully, all searches result in the indexer reporting all sites are in error. I switch Jackett back to Deluge, and it works.

 

My IP address is in the format 192.168.0.*

 

My LAN_NETWORK for Deluge is 192.168.1.0/24 and I tried this on qBittorrent however this seems wrong, I think it should be 192.168.0.0/24 but neither works for qBittorrent. I am able to successfully use qBittorrent to make downloads, so I know the container works to some degree at least.

 

What info would you like to see here? Or ideas on the issue?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.