[support] Siwat's Docker Repository


449 posts in this topic Last Reply

Recommended Posts

On 12/5/2020 at 2:17 PM, SpaceInvaderOne said:

Yeah i have the same. I havent had time to look into this as yet but a quick fix is roll back to the earlier container.

In the template change repository to add :6.0 on the end so


onlyoffice/documentserver:6.0

 

Thanks @SpaceInvaderOne that worked for me.

 

While we wait for the fix, I found that I lost of lot of time unsuccessfully trying to diagnose what the OnlyOfficeDocumentServer container log was spitting out. Especially the plugin warnings highlighted in yellow and error log path highlighted in red which don't seem to be part of the issue.

It seems like the difference in the output of the container log between 6.2 compared to 6.0 are these messages before "Starting supervisor: supervisord." Does this tell us what's wrong?

 

Creating new PostgreSQL cluster 12/main ...
/usr/lib/postgresql/12/bin/initdb -D /var/lib/postgresql/12/main --auth-local peer --auth-host md5
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale "en_US.UTF-8".
The default database encoding has accordingly been set to "UTF8".
The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/postgresql/12/main ... ok
creating subdirectories ... ok
selecting dynamic shared memory implementation ... posix
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting default time zone ... America/New_York
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok
syncing data to disk ... ok

Success. You can now start the database server using:

pg_ctlcluster 12 main start

Ver Cluster Port Status Owner Data directory Log file
12 main 5432 down postgres /var/lib/postgresql/12/main /var/log/postgresql/postgresql-12-main.log
* Starting PostgreSQL 12 database server
...done.
* Starting RabbitMQ Messaging Server rabbitmq-server
...done.
CREATE DATABASE
CREATE ROLE
GRANT
pgrep: cannot allocate 4611686018427387903 bytes
/etc/init.d/supervisor: 100: [: -eq: unexpected operator
Starting supervisor: supervisord.
* Starting periodic command scheduler cron
...done.
* Starting nginx nginx
...done.
Generating AllFonts.js, please wait...Done
Generating presentation themes, please wait...* * Starting PostgreSQL 12 database server
...done.
* Starting RabbitMQ Messaging Server rabbitmq-server
...done.
pgrep: cannot allocate 4611686018427387903 bytes
/etc/init.d/supervisor: 100: [: -eq: unexpected operator
Starting supervisor: supervisord.
* Starting periodic command scheduler cron
...done.
* Starting nginx nginx
...done.

 

Link to post
  • 5 weeks later...
  • Replies 448
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yeah i have the same. I havent had time to look into this as yet but a quick fix is roll back to the earlier container. In the template change repository to add :6.0 on the end so onlyoffice/

I had quite a bit of trouble getting OnlyOfficeDocumentServer to work with nextcloud and letsencrypt. So I had letsencrypt install for plex etc and got it working with nextcloud. The confusing part of

These instructions should be stickied! THANK YOU!

Posted Images

I tired to update my homebridge docker container the other day and now I just get the following in the docker log file:

 

Get:1 https://deb.nodesource.com/node_12.x bionic InRelease [4584 B]
Ign:2 http://archive.ubuntu.com/ubuntu eoan InRelease
Ign:3 http://security.ubuntu.com/ubuntu eoan-security InRelease
Get:4 https://deb.nodesource.com/node_12.x bionic/main amd64 Packages [767 B]
Ign:5 http://archive.ubuntu.com/ubuntu eoan-updates InRelease
Err:6 http://security.ubuntu.com/ubuntu eoan-security Release
404 Not Found [IP: 91.189.88.142 80]
Ign:7 http://archive.ubuntu.com/ubuntu eoan-backports InRelease
Err:8 http://archive.ubuntu.com/ubuntu eoan Release
404 Not Found [IP: 91.189.88.142 80]
Err:9 http://archive.ubuntu.com/ubuntu eoan-updates Release
404 Not Found [IP: 91.189.88.142 80]
Err:10 http://archive.ubuntu.com/ubuntu eoan-backports Release
404 Not Found [IP: 91.189.88.142 80]
Reading package lists...
E: The repository 'http://security.ubuntu.com/ubuntu eoan-security Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-updates Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-backports Release' no longer has a Release file.
Reading package lists...
E: The repository 'http://security.ubuntu.com/ubuntu eoan-security Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-updates Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-backports Release' no longer has a Release file.

404 Not Found [IP: 91.189.88.152 80]
Get:154 http://archive.ubuntu.com/ubuntu eoan/universe amd64 libaacs0 amd64 0.9.0-2 [50.1 kB]
Get:155 http://archive.ubuntu.com/ubuntu eoan/universe amd64 libbdplus0 amd64 0.1.2-3 [47.3 kB]
Err:156 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgdk-pixbuf2.0-bin amd64 2.40.0+dfsg-1build1
404 Not Found [IP: 91.189.88.152 80]
Err:157 http://archive.ubuntu.com/ubuntu eoan/main amd64 librsvg2-common amd64 2.44.14-1
404 Not Found [IP: 91.189.88.152 80]
Err:158 http://archive.ubuntu.com/ubuntu eoan-updates/universe amd64 mesa-va-drivers amd64 19.2.8-0ubuntu0~19.10.3
404 Not Found [IP: 91.189.88.152 80]
Err:159 http://archive.ubuntu.com/ubuntu eoan-updates/main amd64 mesa-vdpau-drivers amd64 19.2.8-0ubuntu0~19.10.3
404 Not Found [IP: 91.189.88.152 80]
Err:160 http://archive.ubuntu.com/ubuntu eoan/universe amd64 i965-va-driver amd64 2.3.0-0ubuntu2

404 Not Found [IP: 91.189.88.152 80]
Err:161 http://archive.ubuntu.com/ubuntu eoan/universe amd64 va-driver-all amd64 2.5.0-1

404 Not Found [IP: 91.189.88.152 80]
Err:162 http://archive.ubuntu.com/ubuntu eoan/main amd64 vdpau-driver-all amd64 1.2-1ubuntu1

404 Not Found [IP: 91.189.88.152 80]
Fetched 18.4 MB in 7s (2518 kB/s)
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/f/fribidi/libfribidi0_1.0.5-3.1ubuntu0.19.10.1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/x/xkeyboard-config/xkb-data_2.26-2ubuntu2_all.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libd/libdrm/libdrm-common_2.4.99-1ubuntu1_all.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libd/libdrm/libdrm2_2.4.99-1ubuntu1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libp/libpng1.6/libpng16-16_1.6.37-1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libu/libusb-1.0/libusb-1.0-0_1.0.23-1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

Any ideas? Looks like the /etc/apt/sources.list repos need to be updated in the image. 

Edited by Grapes
Link to post
4 hours ago, Grapes said:

I tired to update my homebridge docker container the other day and now I just get the following in the docker log file:

 


Get:1 https://deb.nodesource.com/node_12.x bionic InRelease [4584 B]
Ign:2 http://archive.ubuntu.com/ubuntu eoan InRelease
Ign:3 http://security.ubuntu.com/ubuntu eoan-security InRelease
Get:4 https://deb.nodesource.com/node_12.x bionic/main amd64 Packages [767 B]
Ign:5 http://archive.ubuntu.com/ubuntu eoan-updates InRelease
Err:6 http://security.ubuntu.com/ubuntu eoan-security Release
404 Not Found [IP: 91.189.88.142 80]
Ign:7 http://archive.ubuntu.com/ubuntu eoan-backports InRelease
Err:8 http://archive.ubuntu.com/ubuntu eoan Release
404 Not Found [IP: 91.189.88.142 80]
Err:9 http://archive.ubuntu.com/ubuntu eoan-updates Release
404 Not Found [IP: 91.189.88.142 80]
Err:10 http://archive.ubuntu.com/ubuntu eoan-backports Release
404 Not Found [IP: 91.189.88.142 80]
Reading package lists...
E: The repository 'http://security.ubuntu.com/ubuntu eoan-security Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-updates Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-backports Release' no longer has a Release file.
Reading package lists...
E: The repository 'http://security.ubuntu.com/ubuntu eoan-security Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-updates Release' no longer has a Release file.
E: The repository 'http://archive.ubuntu.com/ubuntu eoan-backports Release' no longer has a Release file.

404 Not Found [IP: 91.189.88.152 80]
Get:154 http://archive.ubuntu.com/ubuntu eoan/universe amd64 libaacs0 amd64 0.9.0-2 [50.1 kB]
Get:155 http://archive.ubuntu.com/ubuntu eoan/universe amd64 libbdplus0 amd64 0.1.2-3 [47.3 kB]
Err:156 http://archive.ubuntu.com/ubuntu eoan/main amd64 libgdk-pixbuf2.0-bin amd64 2.40.0+dfsg-1build1
404 Not Found [IP: 91.189.88.152 80]
Err:157 http://archive.ubuntu.com/ubuntu eoan/main amd64 librsvg2-common amd64 2.44.14-1
404 Not Found [IP: 91.189.88.152 80]
Err:158 http://archive.ubuntu.com/ubuntu eoan-updates/universe amd64 mesa-va-drivers amd64 19.2.8-0ubuntu0~19.10.3
404 Not Found [IP: 91.189.88.152 80]
Err:159 http://archive.ubuntu.com/ubuntu eoan-updates/main amd64 mesa-vdpau-drivers amd64 19.2.8-0ubuntu0~19.10.3
404 Not Found [IP: 91.189.88.152 80]
Err:160 http://archive.ubuntu.com/ubuntu eoan/universe amd64 i965-va-driver amd64 2.3.0-0ubuntu2

404 Not Found [IP: 91.189.88.152 80]
Err:161 http://archive.ubuntu.com/ubuntu eoan/universe amd64 va-driver-all amd64 2.5.0-1

404 Not Found [IP: 91.189.88.152 80]
Err:162 http://archive.ubuntu.com/ubuntu eoan/main amd64 vdpau-driver-all amd64 1.2-1ubuntu1

404 Not Found [IP: 91.189.88.152 80]
Fetched 18.4 MB in 7s (2518 kB/s)
E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/f/fribidi/libfribidi0_1.0.5-3.1ubuntu0.19.10.1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/x/xkeyboard-config/xkb-data_2.26-2ubuntu2_all.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libd/libdrm/libdrm-common_2.4.99-1ubuntu1_all.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libd/libdrm/libdrm2_2.4.99-1ubuntu1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libp/libpng1.6/libpng16-16_1.6.37-1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/libu/libusb-1.0/libusb-1.0-0_1.0.23-1_amd64.deb 404 Not Found [IP: 91.189.88.152 80]

Any ideas? Looks like the /etc/apt/sources.list repos need to be updated in the image. 

Updated! 🙂

Link to post
  • 2 weeks later...
7 hours ago, yogy said:

I'm using OnlyOfficeDocumentServer (from onlyoffice). Since the recent update I don't have onlyoffice icon anymore (? simbol in grey colour). When I check the Icon URL in Dockers Advanced View it says https://pbs.twimg.com/profile_images/801693107125362689/al5MQBQM_normal.jpg. Entering the link to the browser leads to an error. Can someone please post the correct link.

I’ll update it tomorrow 

Link to post

AdGuard-Home Support link brought me here. How hard would it be to implent unbound (recursive resolver) to this docker image as option? I installed it afterwards but don't want to screw around with the entrypoint script to autostart it.

Link to post
  • 2 weeks later...

Hello :)
After I just reinstalled OnlyOffice on Nextcloud (with SWAG), it doens't work. I've follow SpaceInverder One's video on the subject but I get a "Error when trying to connect (Bad healthcheck status)". Does anyone know how to fix this problem? :)

 

Edited by Michelle Bausager
Link to post

I'm getting the following error in my Nextcloud log when trying to open documents via the Nextcloud mobile app on iOS:
 Fatal: Download without jwt

 Fatal: Download without jwt

Anyone know what might be causing this problem?

Edited by xthursdayx
Link to post
19 hours ago, Michelle Bausager said:

Hello :)
After I just reinstalled OnlyOffice on Nextcloud (with SWAG), it doens't work. I've follow SpaceInverder One's video on the subject but I get a "Error when trying to connect (Bad healthcheck status)". Does anyone know how to fix this problem? :)

 

I've been having this exact issue for a couple of months now.
@Siwat2545 could you please advise?
 

These are the instructions here.
It worked for me when I first set it up, then one day just broke.
Error when trying to connect (Client error: `GET https://[mydomain]/healthcheck` resulted in a `400 Bad Request` response: 400 Bad Request 400 Bad Request ngin (truncated...) )

Link to post
2 hours ago, 4554551n said:

I've been having this exact issue for a couple of months now.
@Siwat2545 could you please advise?
 

These are the instructions here.
It worked for me when I first set it up, then one day just broke.
Error when trying to connect (Client error: `GET https://[mydomain]/healthcheck` resulted in a `400 Bad Request` response: 400 Bad Request 400 Bad Request ngin (truncated...) )

Which version of the docker are you on?

Link to post
On 12/5/2020 at 12:17 PM, SpaceInvaderOne said:

Yeah i have the same. I havent had time to look into this as yet but a quick fix is roll back to the earlier container.

In the template change repository to add :6.0 on the end so


onlyoffice/documentserver:6.0

 

 

 

I'm running into an issue with the version 6.0 as well (just as an FYI, they don't have the official container available anymore).  When I got to hit "save" at the last step I get, "Error when trying to connect (Bad healthcheck status)".  I've done a pile of reading and I can't seem to sort out what's going on.

Link to post
6 hours ago, VimyRidge said:

 

 

I'm running into an issue with the version 6.0 as well (just as an FYI, they don't have the official container available anymore).  When I got to hit "save" at the last step I get, "Error when trying to connect (Bad healthcheck status)".  I've done a pile of reading and I can't seem to sort out what's going on.

So that makes at least 3..
@Siwat2545 please help?

Link to post
12 hours ago, Siwat2545 said:

Set your Repository as follow image.thumb.png.7f4dd803c52597d4adbed9462ed204c0.png

I did this, then force updated and restarted the container. I get the same error.
Here is the output of the logs option in unraid for the docker:

I hope this helps. Any more advise would be very welcome, thank you

```


* Starting PostgreSQL 12 database server
...done.
* Starting RabbitMQ Messaging Server rabbitmq-server
...done.
pgrep: cannot allocate 4611686018427387903 bytes
/etc/init.d/supervisor: 100: [: -eq: unexpected operator
Starting supervisor: supervisord.
* Starting periodic command scheduler cron
...done.
* Starting nginx nginx
...done.
Generating AllFonts.js, please wait...Done
Generating presentation themes, please wait...Done
Generating presentation themes, please wait...Done
ds:docservice: stopped
ds:docservice: started
ds:converter: stopped
ds:converter: started
* Reloading nginx configuration nginx
...done.
==> /var/log/onlyoffice/documentserver/converter/err.log <==

==> /var/log/onlyoffice/documentserver/converter/out.log <==
[2021-02-17T03:06:27.232] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:07:08.079] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:07:08.085] [WARN] nodeJS - worker 1063 started.
[2021-02-17T03:07:08.086] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:09:38.832] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:09:38.844] [WARN] nodeJS - worker 952 started.
[2021-02-17T03:09:38.847] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:10:16.126] [WARN] nodeJS - update cluster with 1 workers
[2021-02-17T03:10:16.132] [WARN] nodeJS - worker 1065 started.
[2021-02-17T03:10:16.133] [WARN] nodeJS - update cluster with 1 workers

==> /var/log/onlyoffice/documentserver/docservice/err.log <==

==> /var/log/onlyoffice/documentserver/docservice/out.log <==
[2021-02-17T03:06:29.043] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode
[2021-02-17T03:07:06.597] [WARN] nodeJS - Express server starting...
[2021-02-17T03:07:06.599] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. https://nodejs.org/docs/latest/api/fs.html#fs_availability
[2021-02-17T03:07:06.707] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode
[2021-02-17T03:09:39.258] [WARN] nodeJS - Express server starting...
[2021-02-17T03:09:39.261] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. https://nodejs.org/docs/latest/api/fs.html#fs_availability
[2021-02-17T03:09:40.291] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode
[2021-02-17T03:10:14.647] [WARN] nodeJS - Express server starting...
[2021-02-17T03:10:14.649] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. https://nodejs.org/docs/latest/api/fs.html#fs_availability
[2021-02-17T03:10:14.759] [WARN] nodeJS - Express server listening on port 8000 in production-linux mode

==> /var/log/onlyoffice/documentserver/metrics/err.log <==

==> /var/log/onlyoffice/documentserver/metrics/out.log <==
counter_rates:
{ 'statsd.bad_lines_seen': 0,
'statsd.packets_received': 0,
'statsd.metrics_received': 0 },
sets: {},
pctThreshold: [ 90 ] }
17 Feb 03:06:25 - [889] reading config file: ./config/config.js
17 Feb 03:06:25 - server is up INFO
17 Feb 03:09:38 - [898] reading config file: ./config/config.js
17 Feb 03:09:38 - server is up INFO

==> /var/log/onlyoffice/documentserver/nginx.error.log <==

==> /var/log/onlyoffice/documentserver/spellchecker/err.log <==

==> /var/log/onlyoffice/documentserver/spellchecker/out.log <==
[2021-02-15T09:20:36.538] [WARN] nodeJS - Express server starting...
[2021-02-15T09:20:36.600] [WARN] nodeJS - Express server listening on port 8080 in production-linux mode
[2021-02-17T03:06:25.970] [WARN] nodeJS - start cluster with 1 workers
[2021-02-17T03:06:25.975] [WARN] nodeJS - worker 940 started.
[2021-02-17T03:06:26.962] [WARN] nodeJS - Express server starting...
[2021-02-17T03:06:27.030] [WARN] nodeJS - Express server listening on port 8080 in production-linux mode
[2021-02-17T03:09:38.610] [WARN] nodeJS - start cluster with 1 workers
[2021-02-17T03:09:38.624] [WARN] nodeJS - worker 934 started.
[2021-02-17T03:09:39.103] [WARN] nodeJS - Express server starting...
[2021-02-17T03:09:39.147] [WARN] nodeJS - Express server listening on port 8080 in production-linux mode

```

Link to post

Hi! I'm using the AdGuard Home container but experiecing very slow resolving times compared to just use 1.1.1.1.

 

It seems like AdGuard Home isn't caching my requests and there is something causing these slow resolving times. Anything I should check?

Link to post
6 minutes ago, 4554551n said:

@Siwat2545
Can you please help us out? We would really appreciate it

Can you still  access the web UI, or is the web UI is up and you can’t connect to it using nextcloud

PS. I’m in the middle of a midterm exam RN, sorry for the late reply.

Link to post
20 minutes ago, Siwat2545 said:

Can you still  access the web UI, or is the web UI is up and you can’t connect to it using nextcloud

PS. I’m in the middle of a midterm exam RN, sorry for the late reply.

For me the webui gives me the unraid login page.
But if I go to the URL I set in nextcloud via spaceinvader instructions, instead of getting the document server welcome screen, I get the 400 error

Link to post
5 hours ago, 4554551n said:

For me the webui gives me the unraid login page.
But if I go to the URL I set in nextcloud via spaceinvader instructions, instead of getting the document server welcome screen, I get the 400 error

 

I have just started to look into onlyoffice integration into my nextcloud setup (21.0.0) as well. I was/am following the same guide. I have found that the proxy config file seems to be wrong. This is what is provided:

 

 

# only office doc server

server {
    listen 443 ssl;

    server_name external server name.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;


    location / {
                include /config/nginx/proxy.conf;
                resolver 127.0.0.11 valid=30s;
                set $upstream_docs OnlyOfficeDocumentServer;
                proxy_pass https://$upstream_docs:443;
                proxy_redirect off;
                proxy_set_header Host $host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Forwarded-Host $server_name;
                proxy_set_header X-Forwarded-Proto $scheme;
        }
}

 

 

I would then have the same error 400 page, when trying to connect to the external URL. I found if i changed this file to:

# only office doc server


server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name external server name.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app OnlyOfficeDocumentServer;
        set $upstream_port 443;
        set $upstream_proto https;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

        proxy_max_temp_file_size 2048m;
    }
}

 

 

I can then navigate (only using the external URL) to this page:

 

image.thumb.png.5296839308edc024b17de923565edb46.png

 

(I tried just changing $upstream_docs to $upstream_app but it still failed).

If i try and navigate to the local address i cannot connect. When i try to connect to onlyoffice in nextcloud i get the following:

 

image.png.fbeed531b2ce74f48094eda19f5878be.png

 

I'm gonna keep trying but looks like a few people have the same issue.

 

 

Edited by showstopper
Link to post
16 hours ago, showstopper said:

 

I have just started to look into onlyoffice integration into my nextcloud setup (21.0.0) as well. I was/am following the same guide. I have found that the proxy config file seems to be wrong. This is what is provided:

 

 

# only office doc server


server {
    listen 443 ssl;

    server_name external server name.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;


    location / {
                include /config/nginx/proxy.conf;
                resolver 127.0.0.11 valid=30s;
                set $upstream_docs OnlyOfficeDocumentServer;
                proxy_pass https://$upstream_docs:443;
                proxy_redirect off;
                proxy_set_header Host $host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Forwarded-Host $server_name;
                proxy_set_header X-Forwarded-Proto $scheme;
        }
}

 

 

I would then have the same error 400 page, when trying to connect to the external URL. I found if i changed this file to:


# only office doc server


server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name external server name.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app OnlyOfficeDocumentServer;
        set $upstream_port 443;
        set $upstream_proto https;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

        proxy_max_temp_file_size 2048m;
    }
}

 

 

I can then navigate (only using the external URL) to this page:

 

image.thumb.png.5296839308edc024b17de923565edb46.png

 

(I tried just changing $upstream_docs to $upstream_app but it still failed).

If i try and navigate to the local address i cannot connect. When i try to connect to onlyoffice in nextcloud i get the following:

 

image.png.fbeed531b2ce74f48094eda19f5878be.png

 

I'm gonna keep trying but looks like a few people have the same issue.

 

 

I am not understanding the differences between:

 

 

```
set $upstream_docs OnlyOfficeDocumentServer;
proxy_pass https://$upstream_docs:443;
```
and
```
set $upstream_app OnlyOfficeDocumentServer;
set $upstream_port 443;
set $upstream_proto https;
proxy_pass $upstream_proto://$upstream_app:$upstream_port;
```

Seems like the proxy_pass command would evaluate to the same thing in both documents.
So what are the differences in the two files that are allowing you to make headway?

Is it perhaps one of these lines, that I don't fully understand?

```
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Host $server_name;
proxy_set_header X-Forwarded-Proto $scheme;
```

Link to post
5 hours ago, 4554551n said:

I am not understanding the differences between:

 

 

```
set $upstream_docs OnlyOfficeDocumentServer;
proxy_pass https://$upstream_docs:443;
```
and
```
set $upstream_app OnlyOfficeDocumentServer;
set $upstream_port 443;
set $upstream_proto https;
proxy_pass $upstream_proto://$upstream_app:$upstream_port;
```

Seems like the proxy_pass command would evaluate to the same thing in both documents.
So what are the differences in the two files that are allowing you to make headway?

Is it perhaps one of these lines, that I don't fully understand?

```
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Host $server_name;
proxy_set_header X-Forwarded-Proto $scheme;
```

 

I initially thought it was $upstream_docs and $upstream_app that was the issue. After lots of tinkering yesterday it now all works.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.