SMB Share requires username/password (SOLVED)


Recommended Posts

I'm in the middle of rebuilding my server (v6.6.5) because I accidentally erased my flash drive (🙄) and have run into a snag with an unassigned drive that I have apps/dockers installed on. I can see the network share but windows is asking me for a username/password if I attempt to access it. I can open all my other shares.


I have the following entries in my go file:

mkdir -p /mnt/disk/sdf1
mount -t reiserfs -o noatime,nodiratime /dev/sdf1 /mnt/disk/sdf1


And I have added this to the smb-extra.conf file:

	path = /mnt/disk/sdf1
	read only = no
        valid users = whoever
        write list = whoever 


I've been searching the forum for a while and I cannot figure out what I'm missing. I'm pretty sure its simple but I don't have a clue. Any help would be appreciated.

Link to comment

Unassigned disks should be under /mnt/disks rather than /mnt/disk.


Instead of trying to mount it manually I would suggest you install the Unassigned `Devices plugin and let that handle the mounting.   It will also handle setting it up as a share.   One other advantage of doing that way is it becomes independent of the /dev/sdX type name (which is subject to change between boots).

Link to comment

I knew someone would say "just use the UD plugin" and I looked at it last night but was too tired to figure a new plugin out. I have had my system configured this way for at least 5 years without any problems until now and the problem is that I deleted the smb-extra.conf file. I figured I could either reconfigure all my docker containers or simply edit the smb-extra.conf file so that the mount is shared. At the time fixing my smb-extra.conf seemed simpler. After sleeping on it I re-installed UD, created a new share and switched over all my docker mappings which was actually not bad at all. Problem solved.

Edited by wsume99
Link to comment
  • wsume99 changed the title to SMB Share requires username/password (SOLVED)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.