Disk read errors after server hardware upgrade.


2 posts in this topic Last Reply

Recommended Posts

Over the past week I've slowly been upgrading my system from an old i5 to a Threadripper x1950 in a new Norco 4224 case. 

 

Old server 

i5 3570

16 GB ram 

1x Dell Perc H310 flashed IT mode. 

 

New Server 

Threadripper x1950

Asrock Taichi x399

16 GB ECC Ram

2x Dell Perc H310 flashed in IT mode. 

 

The system was running fine in the new server until today when I started to build a new VM and received disk read errors. One of the disks are disable and it is running a parity check finding 100k in errors so far and it's only 2% complete. 


Attached is my diagnostic

I'm hoping someone has insights into what has happened. 

 

 

tidehunter-diagnostics-20181206-1608.zip

Link to post

Syslog is spammed with bunker warnings, so we can't see what happened, but it looks like one of the LSI HBAs dropped or stopped responding, the one where these disks are connected to:

 

Dec  6 16:08:58 tidehunter kernel: md: disk0 read error, sector=383033168
Dec  6 16:08:58 tidehunter kernel: md: disk1 read error, sector=383033176
Dec  6 16:08:58 tidehunter kernel: md: disk3 read error, sector=383033176
Dec  6 16:08:58 tidehunter kernel: md: disk4 read error, sector=383033176
Dec  6 16:08:58 tidehunter kernel: md: disk6 read error, sector=383033176
Dec  6 16:08:58 tidehunter kernel: md: disk9 read error, sector=383033176

 

Power off, reseat the controller or use another PCIe slot if available, you'll then need to rebuild the disabled disk.

Edited by johnnie.black
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.