Jump to content
Jaster

Can't start any game on VM

8 posts in this topic Last Reply

Recommended Posts

I installed a Win10 VM and trying to start any game (via steam). I tired using RDP or inhome streaming.

I can see the process spawning, but immediatly crashing/exiting. Sometimes the splash/load screen of a game pops up and is gone immediatly.

I tryied passing through both avialable GPU's (RX580, primary) and GTX1060 (secondary).

The CPU is passed thought (not emulated) and I'm using SeaBios.

Whats the next steps to find a solution?

Share this post


Link to post

Fo those who are intrested in the solution: Steam does not like to run games from a mounted network share, or at least most games don't work that way. So move them to a local VM drive.

Share this post


Link to post

@Jaster For me all my Steam Games on a network share are working. Origin had some problems, but never had any issues with steam no matter if I add a steam library entry for the already mounted network share or hard linking the direktory to the local steam folder. I some cases users reported some copy protection mechanisms doesnt like to run from a network drive.

Share this post


Link to post

Thats supprising, as I couldn't get any of them to run.

Do you use some specific settings when mounting a drive on the array?

Share this post


Link to post

@Jaster Just simple mount the SMB share in Win10 with a User that is configured in Unraid to connect and than in the Steam settings > Downloads > click Steam Library Folder and add a new one.

 

769547985_steamsettings.JPG.e9d4877f524e3de7e431cabf47237a0e.JPG

 

389279119_DownloadSettings.JPG.aed1d952468eb4c0c1cf9dfe8ecd2842.JPG

Edited by bastl

Share this post


Link to post

Tried that, but with no luck yet.

Do u have the libraries on ur cache?

 

btw: how did u solve the headless streaming problem?..

Share this post


Link to post

Drive D is a passed through SSD and drive G is the library directly at the array. No caching is involved. I don't use any SteamLink sort of streaming of my games. If i fire up a game, i play it inside the VM directly. 

Share this post


Link to post

I run into all sorts of issues with certain games using SMB shares.  Had me trying all sorts of solutions for different games- once I passed through a drive or attached a vhdx on an SMB share, things worked properly.  It was really hard to troubleshoot since games would fail with different errors and some of them would work, even when others won't.  Tried reinstall of various framework ect, only worked with direct attach storage for me.   

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now