[Support] Djoss - Nginx Proxy Manager


Djoss

Recommended Posts

1 hour ago, Djoss said:

Look at /mnt/user/appdata/NginxProxyManager/log/letsencrypt.log, you should have more details about the failure.

Here's the log file attached

 

Seems to be an issue with how the proxy feature of cloudflare works. Need to disable that to get the LE challenge to complete. Once that's done, re-enabling the cloudflare proxy and all is good. :)

 

 

Edited by itlists
Link to comment
3 minutes ago, mattie112 said:

Fixing the issue you are having :) I would suggest checking cloudflare if you can exclude a directory from being cached so that the letsencrypt verification works.

Disabling the CF proxy defeats the purpose of the service :)

Is there a way to force a renewal? If possible to force a renewal, then I could disable the cloudflare proxy temporarily and push the LE renewal.

Edited by itlists
Link to comment

Yes you can but then you have to do that every ~3 months and that does not seem like a solution to me.

 

docker exec -it NginxProxyManager sh

and then

certbot renew

 

But a quick google shows that in CloudFlare you should be able to exclude an url (yoursite.com/.well-known/*) from being cached and then it should work perfectly.

  • Thanks 1
Link to comment

I'm using the code-server docker and accessing it through code.mydomain.com.  The code-server application has an extension called "live server" that lets you view your html/css/js in a browser that updates live.  By default you can access it from port 5500, if 5500 is not available then it uses 5501 and so on - right now 5502 seems to be the most available so that's what I'm setting up right now but I'll probably set up 5500 through 5509 or something once I get the first one working.  I access the UI for the code-server container through port 8443.  I'm using the "custom : br0" network type because if I used the default Bridge network type I couldn't access the "live server" page but using the bridged IP it does work if I pass the ports through in the container settings.

 

code.mydomain.com works fine and takes me to 192.168.10.38:8443 with no issues, I got the "live server" to be accessible at live02.mydomain.com taking me to 192.168.10.38:5502, but ideally I'd like to be able to access it by going to code.mydomain.com/live02 INSTEAD OF live02.mydomain.com.

 

I tried using the "custom locations" option in my code.mydomain.com proxy host setup but (I also tried /live02/ as the location instead of /live02 - the error page was styled differently which was interesting but it was still the same error).

 

 

image.png.08bec88cd2fd04d0744b4937d54d393b.png

 

 

I've tried to set the custom locations up a time or two in the past but haven't been able to get them working so I'm hoping that I'll finally be able to get my head around how they work here.  Thanks for any ideas or advice.

Link to comment
16 hours ago, romain said:

I'm using the code-server docker and accessing it through code.mydomain.com.  The code-server application has an extension called "live server" that lets you view your html/css/js in a browser that updates live.  By default you can access it from port 5500, if 5500 is not available then it uses 5501 and so on - right now 5502 seems to be the most available so that's what I'm setting up right now but I'll probably set up 5500 through 5509 or something once I get the first one working.  I access the UI for the code-server container through port 8443.  I'm using the "custom : br0" network type because if I used the default Bridge network type I couldn't access the "live server" page but using the bridged IP it does work if I pass the ports through in the container settings.

 

code.mydomain.com works fine and takes me to 192.168.10.38:8443 with no issues, I got the "live server" to be accessible at live02.mydomain.com taking me to 192.168.10.38:5502, but ideally I'd like to be able to access it by going to code.mydomain.com/live02 INSTEAD OF live02.mydomain.com.

 

I tried using the "custom locations" option in my code.mydomain.com proxy host setup but (I also tried /live02/ as the location instead of /live02 - the error page was styled differently which was interesting but it was still the same error).

 

 

image.png.08bec88cd2fd04d0744b4937d54d393b.png

 

 

I've tried to set the custom locations up a time or two in the past but haven't been able to get them working so I'm hoping that I'll finally be able to get my head around how they work here.  Thanks for any ideas or advice.

When you setup a "/live02" custom location, did you try to access it via "code.mydomain.com/live02" or "code.mydomain.com/live02/" (with or without ending slash) ?

Link to comment
8 hours ago, Djoss said:

When you setup a "/live02" custom location, did you try to access it via "code.mydomain.com/live02" or "code.mydomain.com/live02/" (with or without ending slash) ?

I tried both, neither worked.

 

 

When I tried using /live02/ in the settings (as opposed to what was shown in the screen shot) something confusing also happened when trying to go to code.mydomain.com/live02.  Instead of it immediately not working, it sat there and tried to load for 10 - 20 seconds and then the URL changed to be code.mydomain.com:4443/live02/ which is very strange, nothing in my code-server or my Nginx Proxy Manager settings have anything to do with port 4443, so I'm not sure where that's coming from.

Link to comment
On 11/7/2020 at 2:35 AM, InfInIty said:

Anyone had any luck getting guacamole to work through the manager.

 

I am getting 502 error when i go to the url?

 

8 hours ago, Gee1 said:

still waiting for Rocket Chat. With nginx it works

Perhaps show your config? And in case of Gee1 the exact error. Without info there is no way someone can help you...

Link to comment

So I'm having trouble setting up an access list in NPM. I set it up as its supposed to go but when I go to the URL it does not ask for authentication. I have looked in the console and this error code is showing up..

 

Duplicate relation "access_list" in a relation expression. You should use "a.[b, c]" instead of "[a.b, a.c]". This will cause an error in objection 2.0

 

anyone knows how to fix this error?

 

Link to comment
24 minutes ago, lsymfr said:

So I'm having trouble setting up an access list in NPM. I set it up as its supposed to go but when I go to the URL it does not ask for authentication. I have looked in the console and this error code is showing up..

 


Duplicate relation "access_list" in a relation expression. You should use "a.[b, c]" instead of "[a.b, a.c]". This will cause an error in objection 2.0

 

anyone knows how to fix this error?

 

Can you show your config? This is not an error, only a warning (that it will give an error in the next version)

Link to comment
2 hours ago, lsymfr said:

So I'm having trouble setting up an access list in NPM. I set it up as its supposed to go but when I go to the URL it does not ask for authentication. I have looked in the console and this error code is showing up..

 


Duplicate relation "access_list" in a relation expression. You should use "a.[b, c]" instead of "[a.b, a.c]". This will cause an error in objection 2.0

 

anyone knows how to fix this error?

 

What I remember seeing is that once you set up, you need to go back to that proxy host and edit, select the access list you want to use and save/ok.

 

If for some reason you have to modify that access list, you need to go back to each proxy host that uses that access list and just edit the host and save/ok. If I can find the video that I found that solved this for me, I'll post it.

 

Hope that helps.

Link to comment
3 hours ago, mattie112 said:

Can you show your config? This is not an error, only a warning (that it will give an error in the next version)

8gSo8Gn.png

 

I have followed many tutorials and have reinstalled the docker multiple times. Even played around with my router's forwarding settings and nothing

Link to comment
1 hour ago, debit lagos said:

What I remember seeing is that once you set up, you need to go back to that proxy host and edit, select the access list you want to use and save/ok.

 

If for some reason you have to modify that access list, you need to go back to each proxy host that uses that access list and just edit the host and save/ok. If I can find the video that I found that solved this for me, I'll post it.

 

Hope that helps.

I already did this when I originally set it up and it did not work

Link to comment
7 hours ago, mattie112 said:

Did you remove the 'domain names' for the purpose of the screenshot? I don't think it works without a domain name.

Yes only for the screenshot. I just used an erase tool didn't actually remove it. I can access it from outside the local network

Link to comment
2 hours ago, lsymfr said:

Yes only for the screenshot. I just used an erase tool didn't actually remove it. I can access it from outside the local network

And how did you configure the access list ?  Do you have usernames/passwords and/or IP addresses ?  Do tou have "Satisfy Any" enabled ?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.