[Support] Djoss - Nginx Proxy Manager


Djoss

Recommended Posts

7 hours ago, mattie112 said:

Can you access your domain from a remote connection? It seems that it cannot access your domain and then it won't supply a certificate.

 

There's one that is working. For the certs that are failing, I'm getting:
 

Your connection is not private

Attackers might be trying to steal your information from radarr.mydomain.com (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_DATE_INVALID

Edited by damnshaneisthatu
Link to comment
  • 2 weeks later...

Greetings.  I am in need of some help.  I am trying to get a cert through NPM, but I keep getting an internal error.  the log shows the following:

 

[12/3/2021] [4:02:23 PM] [Nginx ] › ℹ info Reloading Nginx
[12/3/2021] [4:02:23 PM] [SSL ] › ℹ info Requesting Let'sEncrypt certificates for Cert #74: csmm.spectralforcesrvers.net
[12/3/2021] [4:02:23 PM] [SSL ] › ℹ info Command: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-74" --agree-tos --authenticator webroot --email "thespectralforce@gmail.com" --preferred-challenges "dns,http" --domains "csmm.spectralforcesrvers.net"
[12/3/2021] [4:02:24 PM] [Nginx ] › ℹ info Reloading Nginx
[12/3/2021] [4:02:24 PM] [Express ] › ⚠ warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-74" --agree-tos --authenticator webroot --email "thespectralforce@gmail.com" --preferred-challenges "dns,http" --domains "csmm.spectralforcesrvers.net"
Another instance of Certbot is already running.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/tmphxj6981l/log or re-run Certbot with -v for more details.

 

I've got no idea why this is happening, any help would be appreciated.  Thank you!

Link to comment
On 12/3/2021 at 3:06 PM, Spectral Force said:

Greetings.  I am in need of some help.  I am trying to get a cert through NPM, but I keep getting an internal error.  the log shows the following:

 

[12/3/2021] [4:02:23 PM] [Nginx ] › ℹ info Reloading Nginx
[12/3/2021] [4:02:23 PM] [SSL ] › ℹ info Requesting Let'sEncrypt certificates for Cert #74: csmm.spectralforcesrvers.net
[12/3/2021] [4:02:23 PM] [SSL ] › ℹ info Command: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-74" --agree-tos --authenticator webroot --email "thespectralforce@gmail.com" --preferred-challenges "dns,http" --domains "csmm.spectralforcesrvers.net"
[12/3/2021] [4:02:24 PM] [Nginx ] › ℹ info Reloading Nginx
[12/3/2021] [4:02:24 PM] [Express ] › ⚠ warning Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-74" --agree-tos --authenticator webroot --email "thespectralforce@gmail.com" --preferred-challenges "dns,http" --domains "csmm.spectralforcesrvers.net"
Another instance of Certbot is already running.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/tmphxj6981l/log or re-run Certbot with -v for more details.

 

I've got no idea why this is happening, any help would be appreciated.  Thank you!

Any update or fix? I'm still struggling with mine. Thinking about moving back over to Let's Encrypt docker.

Link to comment
18 hours ago, alexleohy said:

我最近在用。第一次下载后可以打开管理界面,但是重启后就会出现问题。之后就无法打开管理界面了。请救救我谢谢

image.png.f2517a444ba5963309db8546a2bcbcbe.png

 

18 hours ago, mattie112 said:

您可以尝试为该容器打开一个 shell,然后检查该文件以查看有什么问题。

 

您是否创建了任何自定义配置?或者也许是 IP 地址的白名单?可能是打字错误什么的。

I don’t have this file in my configuration. This is the first time I use it. After I added the certificate, it couldn’t be used. The error I saw from the background

Link to comment
On 12/13/2021 at 8:41 PM, mattie112 said:

image.png.573b257d1406ef5b7a06486f3485fb44.png

Open console

 

Then do:

image.png.86fb91ebd940f47be87efc7931b6014b.png

 

And check if anything is "corrupted" in that file. The first number is the line number (your error lists 300 so look around that).

 

You can also delete and reinstall the container if you have only a single site you can easily reconfigure.

image.png.7768a53a511adfb2d958274125a3e04c.png

Thank you very much, I think I found the problem. The data in line 300 seems to be incorrect. Should I delete the content below line 300?

On the left is docker logs, and on the right is the content of "cat -n /etc/nginx/conf.d/include/ip_ranges.conf".

 

 

I entered docker, deleted the content after 300 lines, nginx worked normally, but whenever I restart nginx, the content of this configuration file will be updated again, and then the above error appears, I think this should be abnormal. I don't know if I should report this problem, it seems that only I encountered it, or I need to write a script to modify the configuration file whenever nginx starts.

Link to comment

Can anyone help me? I've been reading this thread and trying other things I've found online but keep running into errors. I am trying to get my NPM to work but keep getting internal error when I try to use ssl through letsencrypt. I have my domain through godaddy and am using cloudflare. I can reach the url but its just a holding site from godaddy I can't seem my applications any other url that I try gives me an error so it seems to be communicating as the site is there but it won't load the content I am looking for I think it points back to the SSL Internal Error I keep receiving. Any help or suggestions would be greatly appreciated. Thanks guys.

Link to comment
5 hours ago, mattie112 said:

So what is the first part that doesn't work. You have a domain and that shows a site from Godaddy? The something is wrong there (or on cloudflare) as it never gets to your NPM.

 

You can also try a website without SSL just to exclude that from your problems.

When I try to Request a new SSL Certificate on NPM I keep getting "internal error". The Proxy host still gets created but it says HTTP only but when I click on it to open it instead of loading my app it just loads a GoDaddy page instead.

Link to comment

unable to use Custom SSL if you click on SSL Certificates and then choose Custom rather than LetsEncrypt it does absolutely nothing.

app broken on 2 seperate unraid servers. to verify its not on my end and the app backend itself I have done the following:

Restarted.

Uninstalled

Reinstalled

Unsinstalled Again.

Removed the App XML from Flash

Deleted the /appdata installation

Reinstalled 3rd time

Uninstalled

Reinstalled the other guys NGINX PROXY MANAGER by jc21

same thing

pulled out a NUC

created brand new Flash drive.paid another 129 for license

set unraid to use 8008 and 8443. set to Auto, and pulled down LetsEncrypt USB SSL

now that 80/443 not in use, went into router and changed the ip to the new USB.

Rinse and repeat of all the steps above

the Custom was working, and then I did a docker update and it broke.

but different computers, different flash drives, different apps (NGINX REVERSE PROXY MANAGER + NGINX REVERSE PROXY MANAGER OFFICIAL)

I HAVE HSTS ON and set to 1 YEAR for all my domains, meaning I am unable to change back to port 80, and grey the lock out on CFLARE and use LetsEncrypt

I have been using CFLARE with Custom Domain Certs provided from CLFARE using SSL: Full (Strict) until last night

Link to comment
On 12/18/2021 at 2:10 PM, mattie112 said:

Can you try to do it manually? See a couple of posts back, this might give a bit more output. Usually this is somekind of DNS/port forward issue as letsencrypt cannot access your host correctly

image.png.423da609afb1c34430d0db3a55e9dc5e.png

 

Sorry I was trying to get this done before heading out of town for Christmas just got back into town and tried this but this is what I am getting after running the manual route. If I try to curl the page it executes in bash but nothing happens it just loads the next line if I "nc IP" it goes to the next line and asks leaves it open to type another command. Any help would be greatly appreciated, I'm pretty sure its something small and dumb that I am overlooking. Thanks.

 

image.png.b53a05a6a181e942d01e2666310ed2ac.png

Link to comment

Anyone else getting a "Internal Error" when trying to manually renew a cert?

 

My logs show this when trying manually renew.

[12/28/2021] [9:10:34 AM] [SSL ] › ℹ info Renewing Let'sEncrypt certificates for Cert #12: tautulli.xxx.com
[12/28/2021] [9:10:34 AM] [SSL ] › ℹ info Command: certbot renew --force-renewal --config "/etc/letsencrypt.ini" --cert-name "npm-12" --preferred-challenges "dns,http" --no-random-sleep-on-renew --disable-hook-validation
[12/28/2021] [9:10:34 AM] [Express ] › ⚠ warning Command failed: certbot renew --force-renewal --config "/etc/letsencrypt.ini" --cert-name "npm-12" --preferred-challenges "dns,http" --no-random-sleep-on-renew --disable-hook-validation
An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (cryptography 36.0.1 (/usr/lib/python3.8/site-packages), Requirement.parse('cryptography<4,>=2'), {'dns-lexicon'})
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/tmpy2mllf8d/log or re-run Certbot with -v for more details.

 

 

I am using cloudflare and proxy status is set to DNS only.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.