Jump to content
not2sure

Parity Drive Rebuild Fail v6.6.6

7 posts in this topic Last Reply

Recommended Posts

I recently upgraded to V6.6.6 and had it working fine with all of the same server equipment. Wanted to increase the size of the Parity Drive to 8TB (previous was 4tb) so I can start upgrading my data drives to larger drives. I installed a new 8tb drive and started the parity rebuild. If keeps locking up after about 5 to 15 minutes of rebuild time. I lose all connection to the server. I have hard booted it several times to see if it will rebuild to no avail.

I am a real beginner at this as I have lost my builder as he relocated.

I have attached my latest diagnostics file and syslog.

All help will be appreciated.

 

System Log.html

1harleyguy-diagnostics-20181219-1348.zip

Share this post


Link to post

For future reference, Diagnostics zip already includes syslog, SMART for all disks, and many other things, so no need to attach them, just the diagnostics. Please don't attach .html files either. The syslog (if we wanted it, which we usually don't) should just be a plain text file or a zipped plain text file.

 

Diagnostics are immediately after a reboot so not much to go on. SMART for parity looks fine. Possibly a bad connection, maybe with the new drive or maybe you bumped the connection on another drive. Always double check all connections any time you are mucking about inside.

 

Rather than wading through SMART for all of your other drives I will just ask. Are any of them showing a warning indicator on the dashboard?

 

When you say "locking up", exactly what do you mean? Can you do anything with ssh/telnet/console? Have you tried to ping your server?

Share this post


Link to post

Actually, that syslog you attached does have more info than the syslog included in your diagnostics. It does look like a bad connection. Can't quite tell which disk it's on though.

 

Just double check all connections and try again. If you still have problems don't reboot, we may have other ways for you to get us some useful information if the command line still works.

Share this post


Link to post

Check the connections to TOSHIBA DT01ACA200 s/n 13MGREJAS... I think that's the drive/port reporting errors in your System Log.

Share this post


Link to post

I see it now

Dec 19 13:47:43 1HarleyGuy kernel: ata3.00: ATA-8: TOSHIBA DT01ACA200,            13MGREJAS, MX4OABB0, max UDMA/133

 

But what about these lines. Are those really PATA drives? Or does he just need to set AHCI in his BIOS?

Dec 19 13:47:43 1HarleyGuy kernel: ata3: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfa00 irq 14
Dec 19 13:47:43 1HarleyGuy kernel: ata4: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfa08 irq 15
Dec 19 13:47:43 1HarleyGuy kernel: scsi host3: pata_jmicron
Dec 19 13:47:43 1HarleyGuy kernel: ata1: PATA max UDMA/100 cmd 0x9f00 ctl 0x9e00 bmdma 0x9b00 irq 17
Dec 19 13:47:43 1HarleyGuy kernel: ata2: PATA max UDMA/100 cmd 0x9d00 ctl 0x9c00 bmdma 0x9b08 irq 17

 

Share this post


Link to post

2 of the onboard SATA ports are set to IDE, this tends to be very troublesome on these AMD chipsets, set them to AHCI/SATA and likely you're troubles will be over.

 

ATA1 and 2 are from an unused IDE port on the Jmicron controller, so not a problem there.

Share this post


Link to post

Problem solved!

I did all the items suggested thru the responses I received one at a time and still did not get it to build.

After I modified the bios to AHCI and saved the changes, rebooted it still failed. I then tried to get in my bios again to triple check everything but could no longer get into my bios (Gigabyte motherboard).

I did some research and found that someone suggested to pull the CMOS battery out, replace it and see if that helped. It did! I was now able to get into my bios and everything checked out good.

So hard rebooted and started the array and the parity rebuild started again and continued all the way through 24 hours 32 minutes later to SUCCESS!

Really not sure what actually made it work but pulling the battery for the CMOS seemed to be it.

Thank you for all your help and suggestions!

David 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.