Notes about Supermicro X11SCA-F


Recommended Posts

I recently did the upgrade to 1.5 and can report basically the same things @dumurluk had with 1.5.  Lots of CMOS resets that afternoon :( 

 

Over the past few years I've ordered millions of dollars of SM server gear for our company's colos.  I think I'm just going to forward this thread to our rep and tell them to escalate till it's fixed.

Link to comment

Yeah, I spent way too much time on way too many cmos resets. I finally got it to a state where it seems to be stable (after several power cycles). At least now I have ikvm access to bios and can see most of the unraid boot process; and hw transcode works. I guess I can live without console access over ikvm.

Link to comment

I'm not an Unraid user (Use Arch) but with my X11SCA-F (Currently on Bios 1.5) the secret to getting IPMI graphics over VGA / web browser and being able to pass through the Intel IGPU to a VM is to enable "SG" (Split Graphics) in the bios settings. I then disable the Intel Graphics driver modules in the Linux host. I run all UEFI with this configuration, both IPMI and Intel display work in the bios and then the Intel display goes off early in the Linux boot. I'm able to pass through the Intel GPU and its display outputs to my KVM VM even  with GPT (Not Legacy mode) passthrough and the display outputs of the IGPU work within the VM.

 

Just thought this might help some of you.

Edited by Krobar
Link to comment
1 hour ago, Krobar said:

I'm not an Unraid user (Use Arch) but with my X11SCA-F (Currently on Bios 1.5) the secret to getting IPMI graphics over VGA / web browser and being able to pass through the Intel IGPU to a VM is to enable "SG" (Split Graphics) in the bios settings. I then disable the Intel Graphics driver modules in the Linux host. I run all UEFI with this configuration, both IPMI and Intel display work in the bios and then the Intel display goes off early in the Linux boot. I'm able to pass through the Intel GPU and its display outputs to my KVM VM even  with GPT (Not Legacy mode) passthrough and the display outputs of the IGPU work within the VM.

 

Just thought this might help some of you.

Thankyou for info, 

 

So users would need to change this value from Auto to SG?

 

image.png.17f3641c82ba90c1a514c6de7a5993a4.png

Link to comment

I'm on BIOS 1.5 and this still works to me (with ESXI):

 

I installed it and did following:

- Remove Quadro P2000 (plug out GPU)

- Reset BIOS to default

- Primary Display : PCI
- Internal Graphics: Enable

- Switch off

- Build in Quadro P2000 again (Plug in, into PCIe Slot)

- Start

- IPMI & Quadro P2000 works

Link to comment
1 hour ago, SimonF said:

Thankyou for info, 

 

So users would need to change this value from Auto to SG?

 

image.png.17f3641c82ba90c1a514c6de7a5993a4.png

 

Yes, thats right. I also force all roms and options to UEFI in the bios and VT-d/IOMMU is enabled.

 

I'm using a Windows VM with GVT-d / UPT passthrough so within the VM the emulated video card is enabled as well as the Intel GPU, you just install the OS and then the Intel driver and then you can disable the emulated Standard VGA Controller in device manager afterwards if you want to (Leaving it enabled could also allow native VNC access whilst using the IGPU for transcode for example). To get HDMI or Analogue sound you can passthrough the Audio controller in the usual way. I think this config will work with new Linux kernels within a VM too. Arch tends to be running newer kernel and versions than Unraid so could be different but happy to try to help if people have questions.

Edited by Krobar
  • Thanks 1
Link to comment
18 hours ago, SimonF said:

@dumurluk Have you tried setting SG for Primary display?

No, I did not. At this point I don't have it in me to deal with more cmos resets. I've also been dealing with another issue that affects this board on unraid (kernel panics and lock ups every 12 hours or so).

 

This board and unraid have been a bad combo so far.

Link to comment
  • 5 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.