[Support] fithwum - teamspeak/alpine


Recommended Posts

Support for teamspeak/alpinedocker

 

Application: TeamSpeak

Application Site: https://www.teamspeak.com/

Docker Hub: https://hub.docker.com/r/fithwum/teamspeak-alpine/

Github: https://github.com/fithwum/teamspeak-alpine

 

This docker was set up to use an external database but you can edit the ts3server.ini file to use default teamspeak database or another of your choice.

 

Please post any questions/issues relating to this docker you have in this thread.

Edited by fithwum
Link to comment
  • 3 weeks later...
5 minutes ago, ich777 said:

want to change the ports but thats not possible in Unraid if i set the network to Host.

In Host mode you can't change the ports anyways.  Set it to bridge if you want to change the ports.  (Or give the app its own IP so as to not conflict with any other app's port settings)

Link to comment
  • 2 years later...

Hi guys,

I have a ts3 server running just fine for more than a year, but today nobody is able to connect.

 

I see this error in the log: 

2021-05-14 19:27:46.106891|INFO |DatabaseQuery | |checking database integrity (may take a while)
2021-05-14 19:27:46.164650|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2021-05-14 19:27:46.165018|INFO |Accounting | |Licensing Information
2021-05-14 19:27:46.165061|INFO |Accounting | |licensed to : Anonymous
2021-05-14 19:27:46.165104|INFO |Accounting | |type : No License
2021-05-14 19:27:46.165154|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020

 

I am able to join the server on the local ip address, but not from the outside.

The server is up to date running TeamSpeak 3 Server 3.13.3 (2020-12-16 14:17:05).

 

Any ideas on how to get the server online for remote access again?

 

/regards

thomas

Link to comment

Seems that the "WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality" always has been there, so that's not the problem.

I have other things running on the server, and no problem accessing it from the outside.

 

Any ideas?

Link to comment
  • 1 month later...
9 minutes ago, OctopusVPS said:

After auto update my icon for docker was lost and set default ;/ You can fix this ?

Edit the appropropriate file within /config/plugins/dockerMan/templates-user and delete the line that says <TemplateURL>someURL</TemplateURL>

 

Then when you re-edit the container, update the Icon with the appropriate entry and it'll never update it again.  

Link to comment
  • 1 month later...

Hey Ich,

 

I been having an issue with teamspeak. Multiple dockers actually not just yours distro. Just like yours better :D

For some reason, the timestamps in the logs are 2 hours behind, and i keep having disconnect issues with the server.

I'm thinking it is about the timestamps.

 

I am in GMT +2 but it seems to be taking UTC. The teamspeak dockers all have this, the other dockers do not.

Have you, or any1 else, got any clue why the time is set to UTC and if this could cause constant disconnects with random intervals?

 

Error message in logs: INFO |PktHandler |1 |Dropping client 2 because of ping timeout 19 0 0

Link to comment

update: i don't know why, but when using the host option with teamspeak dockers, i keep getting time outs on the clients. Didn't have this before. From the point i assigned it a dedicated ip, it has been stable for 24 hours now . . .

Any idea why this is @ich777? ( i assume its an unraid thing, but can't be sure)

Link to comment
15 minutes ago, Caennanu said:

update: i don't know why, but when using the host option with teamspeak dockers, i keep getting time outs on the clients. Didn't have this before. From the point i assigned it a dedicated ip, it has been stable for 24 hours now . . .

Any idea why this is @ich777? ( i assume its an unraid thing, but can't be sure)

Are you using my container or that one from @fithwum?

If you are using my container that is the wrong thread...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.