[Support] Josh5 - Unmanic - Library Optimiser


1050 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi everyone! Over the past few months i've put together a "how-to" playlist for the different functions of Unmanic. For anyone that hasn't seen it, you can find that playlist here.

 

More to my point: to wrap up the playlist, I thought it would be neat to visit with @Josh.5 for a few minutes over Zoom and he kindly obliged. If you'd like to see our short conversation, you can check that out here. Hope you enjoy

Edited by Cpt. Chaz
Link to post
  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: UNMANIC - Library Optimiser Application Site: https://github.com/Unmanic/unmanic/ Docker Hub: https://hub.docker.com/r/josh5/unmanic/ Github: https://github.com/Unmani

@Ashe @trekkiedj @itimpi   Please see update first post also for an example of how I have it setup. I have also added a temporary solution to adding multiple library locations if anyone need

There should be a new update available. This has quite a number of changes to how ffmpeg is executed. It should resolve some issues with inotify and library scanning. For those people who created

Posted Images

53 minutes ago, Cpt. Chaz said:

Hi everyone! Over the past few months i've put together a "how-to" playlist for the different functions of Unmanic. For anyone that hasn't seen it, you can find that playlist here.

 

More to my point: to wrap up the playlist, I thought it would be neat to visit with @Josh.5 for a few minutes over Zoom and he kindly obliged. If you'd like to see our short conversation, you can check that out here. Hope you enjoy

Awesome!

 

I want to say that I really appreciate these videos that you have made. I know that they will be helpful to a lot of users of Unmanic.

Thanks!

Link to post
On 5/5/2021 at 1:26 AM, Sebastiaan99 said:

My Unmanic keeps crashing since the last time I boot my server, I tried to restart multiple times. Also reinstalled multiple times. But nothing work. It works after a reinstall until it get the first jobs. I attached my logs, I hope somebody can help me

logs.zip 103.64 kB · 3 downloads

Are you able to get the docker logs also? I had a quick look and it looks like Unmanic has encountered some exception that it could not handle. I'll take a closer look tonight since you sent me the DB also, I may be able to reproduce the issue...

Link to post
1 hour ago, Josh.5 said:

Are you able to get the docker logs also? I had a quick look and it looks like Unmanic has encountered some exception that it could not handle. I'll take a closer look tonight since you sent me the DB also, I may be able to reproduce the issue...

Hey ofcourse! thanks a lot you want to look at my issue. I love your app, it helps a lot on my unraid server.

Logs Docker.zip

Link to post
On 4/25/2021 at 1:21 AM, melagodo said:

 

That's the problem, log just says "LOG:", I've copied and pasted all the info that I'm seeing.

You've already given a lot to the community with this wonderful docker and I'll surely become a Patreon for help with this specific issue (as I've stated, unmanic worked without any problem with all my tv library except this serie).

 

Thanks again for you're wonderful work :)

2021-04-24 15_20_31-History _ Unmanic – Mozilla Firefox.png

Could you send me some docker logs or anything like that?

Link to post

@Sebastiaan99 In your log I see it is failing on the first video. I cannot see what is causing the whole application to crash.. Could you still please send the Docker logs for that. However I have just pushed a fix to the "staging" branch to fix a bug shown in your files FFMPEG logs in the database that you sent me. After you have those Docker logs for me, could you please switch over to the "staging" branch and test it again? Let me know how you get on.


image.png.4539bbb3dc94eb5f9d09cb5e2439de90.png

Link to post
On 5/5/2021 at 2:10 AM, Eddie Seelke said:

I had the same exact issue and after several weeks of trying to get it working I came across Tdarr. It's not as easy to setup, but hasn't crashed my system once.

 

Not trying to knock Unmanic. Just saying there are other options.

Great to hear you have found a solution!

 

I believe it is possibly a permissions issue that was causing Unmanic to not start. Unfortunately, without logs to accompany your other posts, I cannot say for sure.

 

All the best 🖖

Link to post
On 5/5/2021 at 2:08 AM, bclinton said:

Unmanic has ran great until the last few days. I keep getting can't reach page then it will pop up and load and then give me can't reach page again. I renamed the settings.json and the unmanic.db file and started back up with no change. Any suggestion of what I can try next? I am running Version - 0.0.4+d103d6c

 

Some additional info. I noticed that my space used in the container seems very high. My docker img file is set to 50gigs and the unmanic container seems to be hitting that mark. I have some very large mkv movies files pending to encode. Is that causing my issue? I have my tmp folder set to use another folder on the cache drive which is a 2TB ssd. In the docker screen I can see the space used go up to a point and then start over again. It repeats this so I assume it is hitting a space limit. 

 

/config/mnt/cache/appdata/unmanic
/library/movies/mnt/user/data/media/movies/
/library/tv/mnt/user/data/media/tv/
/tmp/unmanic/mnt/cache/system/tmp/8.41%
40.51GiB / 46.93GiB        <-------------------- filling up my docker img allocated space? I have the mapping setup correctly but it doesnt look like unmanic used the space correctly for the tmp folder /tmp/unmanic------>/mnt/plex_data/tmp/

 

On a side note....I see folks saying the changed the build version of unmanic. Where do I do that at in unraid? 

Could you please provide some screenshots of your setup? Specifically the docker template config and the settings in the Unmanic webui.

 

Thanks

Link to post
Posted (edited)
6 hours ago, Josh.5 said:

Could you please provide some screenshots of your setup? Specifically the docker template config and the settings in the Unmanic webui.

 

Thanks

 

Here are my settings. I was unable to bring up the WEBUI but just changed to the staging branch and it comes up now. It started encoding a file and got to about 3-4% and gave the error (could not update table.... - shown below) I am thinking at this point I could try blowing away the container and starting over with the staging branch......what do you think? The only thing that changed from working great to having these issues was me adding about 25 videos to my movie share and some of them were quite large (25 gigs). 

 

 

 

3.thumb.JPG.09dcd8f16b2bd5354f09b3b2b4d6a3bb.JPG2.thumb.JPG.a68d7bf0364cf4e810a7cd5ac16ee818.JPG1.thumb.JPG.94d12ccd2f6eab15a8d87d54aa306003.JPG4.thumb.JPG.3c0065f853e4437b20ee55a56a9f2de0.JPG3.thumb.JPG.09dcd8f16b2bd5354f09b3b2b4d6a3bb.JPG2.thumb.JPG.a68d7bf0364cf4e810a7cd5ac16ee818.JPG1.thumb.JPG.94d12ccd2f6eab15a8d87d54aa306003.JPGCapture.thumb.JPG.5432c0e9a16e0964ff433899b0d1f932.JPG3.thumb.JPG.09dcd8f16b2bd5354f09b3b2b4d6a3bb.JPG2.thumb.JPG.a68d7bf0364cf4e810a7cd5ac16ee818.JPG1.thumb.JPG.94d12ccd2f6eab15a8d87d54aa306003.JPG2.thumb.JPG.a68d7bf0364cf4e810a7cd5ac16ee818.JPG3.thumb.JPG.09dcd8f16b2bd5354f09b3b2b4d6a3bb.JPG4.thumb.JPG.3c0065f853e4437b20ee55a56a9f2de0.JPG6.JPG.f393fb8537af4814563d29197d0f1f1e.JPGCapture.thumb.JPG.5432c0e9a16e0964ff433899b0d1f932.JPG

5.JPG

Edited by bclinton
Link to post
8 hours ago, Josh.5 said:

@Sebastiaan99 In your log I see it is failing on the first video. I cannot see what is causing the whole application to crash.. Could you still please send the Docker logs for that. However I have just pushed a fix to the "staging" branch to fix a bug shown in your files FFMPEG logs in the database that you sent me. After you have those Docker logs for me, could you please switch over to the "staging" branch and test it again? Let me know how you get on.


image.png.4539bbb3dc94eb5f9d09cb5e2439de90.png

Super stupid I forgot to add the logs, 0.0.1 works staging sadly does not. Here the logs. Thanks for the support @Josh.5

32a6a9eba4ccae16abef38ba88b7d6eea5a6f34ddd690a164093b0aeb029873e-json.log 93d5bb3354597cf60889e568e78b98d00b610437ec82d89c411e954504004a7e-json.log 468d568514c86e90f9be990ee945c6592c871f0b8729798f92fc5753127a3050-json.log 28746d57b6f001d76a80194be2cbaf4bc2983876da27556ef890ee5bc83ccd45-json.log 28817bb82bb9f8685e04674024347cc29f43913236c74d01c809e2e46d5091f2-json.log b9e86e810403951505cd61f73627027cca905c2724c8eaa42efc25844ce065b0-json.log e59e3c32252ca913a0476c88c8ac69b45ceee309416d444d53d0fca438c35576-json.log fb52703e95a4c3b2a286596c149c3c2583b5fb3b08823967ff77c94f492d7cb8-json.log fd26c5086b4f76b23fc4a419f82cb2db94380792a3ab47394c2cf3df0ee91f0e-json.log

Link to post

Just downloaded the application, and it is working great! My main use for unmanic is in combination with the Plex DVR.

 

Is there any way to have unmanic ignore/exclude the .grab folder while a show is still recording?

Link to post
Just downloaded the application, and it is working great! My main use for unmanic is in combination with the Plex DVR.
 
Is there any way to have unmanic ignore/exclude the .grab folder while a show is still recording?
Not at the moment. But the next item on my to-do list is to create a "blacklist" tab where you could do this
Link to post
8 hours ago, Josh.5 said:

Not at the moment. But the next item on my to-do list is to create a "blacklist" tab where you could do this

 

I'll be looking forward to it. Thanks for the response!

Link to post
On 5/5/2021 at 2:08 AM, bclinton said:

I have my tmp folder set to use another folder on the cache drive which is a 2TB ssd. In the docker screen I can see the space used go up to a point and then start over again. It repeats this so I assume it is hitting a space limit. 

 

Could you please explain this part further?

Are you using a symlink to connect 2 "tmp" directories?

Link to post
45 minutes ago, Josh.5 said:

Could you please explain this part further?

Are you using a symlink to connect 2 "tmp" directories?

No, I have the unmanic tmp path pointing to a tmp folder in the system share. It did not look to me like unmanic was using the tmp folder that I assigned as it was queing up videos to transcode. It was filling up the 50 gig docker file instead of using the tmp folder that I assigned and once it hit that limit it froze and I was unable to open the Web UI. 

 

 

Capture.JPG

Link to post
Posted (edited)

Hey, I know you mentioned before that this feature will be coming in a future update.  I'm in no way trying to rush you or pester you about... merely curious how far down it is on your priority list.

Feature:  Adjust the quality, bit depth, CRF, etc of the transcode.  Handbrake really gives me a lot of in depth options in regards to video transcode settings. 

On that note, if I have HDR x264 10 bit movies... will unmanic leave it as HDR and 10 bit, but simply transcode it to my container (in this case it's mkv) and make it x265... leaving the rest as is... IE HDR x264 10 Bit mkv file turns into HDR x265 10 bit mkv file?  How does unmanic like Dolby Vision, HDR10, HDR10+ content?

Edited by Meller
Link to post
12 hours ago, Josh.5 said:

Could you please explain this part further?

Are you using a symlink to connect 2 "tmp" directories?

 

Not trying to bug you to death but figured the updates might help.....I updates the docker container this morning (staging) and now am unable to get to the webui......looking at the container in unraid advanced mode it once again is filling up the docker img space and starting over - it does this over and over and in the meantime I am unable to load the webui......I assume it is queing up the videos it finds in the initial scan and that is causing the docker img file to max out (it is set to 50 gigs)

Link to post
On 5/8/2021 at 1:53 AM, Alderson216 said:

 

I'll be looking forward to it. Thanks for the response!

So I got thinking today. There is not really any point in creating a whole new screen just to handle blacklisting paths when the current plugin system can handle it with 10-20 mins of development time.

So with that in mind I created a plugin for you to do this. I also then thought it may be worth creating another video to show how simple it is to create a plugin for Unmanic. Feel free not to watch it as it's pretty dry and long.

 

But you should now be able to download the new "Path Ignore" plugin.

Link to post
1 hour ago, bclinton said:

 

Not trying to bug you to death but figured the updates might help.....I updates the docker container this morning (staging) and now am unable to get to the webui......looking at the container in unraid advanced mode it once again is filling up the docker img space and starting over - it does this over and over and in the meantime I am unable to load the webui......I assume it is queing up the videos it finds in the initial scan and that is causing the docker img file to max out (it is set to 50 gigs)

Can you try setting the docker config of the tmp/unmanic volume to another location on your array. Just so we can test if it does the same thing.

Link to post
18 hours ago, Josh.5 said:

Can't see any issue in the unmanic log. Could you please pull the latest "staging" docker image and test it again.

If it still does not work, could you also try deleting your appdata/unmanic/.unmanic directory and trying again.

 

 

I tried, also with cleaning everything, even a new docker image. Only thing that works is cleaning everything and use 0.0.1 :(

Link to post
I tried, also with cleaning everything, even a new docker image. Only thing that works is cleaning everything and use 0.0.1
Unfortunately I think I will not be able to solve this through forum posts.
I'm happy to help out over a chat on discord. Join the discord server and message me.
Link to post
Posted (edited)
6 hours ago, Josh.5 said:

Can you try setting the docker config of the tmp/unmanic volume to another location on your array. Just so we can test if it does the same thing.

 

I configured it to the tmp path on a totally different nmve drive. Same results. I am going to attach a mp4 file to show what is happening. On a side note....if I am the only one that this is happening to I have no problem blowing away my config and starting fresh. The video was too large to upload. 

Edited by bclinton
Link to post
 
I configured it to the tmp path on a totally different nmve drive. Same results. I am going to attach a mp4 file to show what is happening. On a side note....if I am the only one that this is happening to I have no problem blowing away my config and starting fresh. The video was too large to upload. 
Yea. I think it's worth making a backup of your Unmanic config folder and start fresh to see if that helps.
If you like, I can give you more help over a chat on Discord. We could probably solve the issue there in a short voice call.
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.