[Support] Josh5 - Unmanic - Library Optimiser


Recommended Posts

I get this error repeatedly when I try to process a large library:

 

2021-10-10T14:16:46:WARNING:Unmanic.Foreman - [FORMATTED] - Postprocessor queue is over 4. Halting feeding workers until it drops.

 

When this happens I have to restart unmanic and then it will pickup and start processing files again. 

 

I have 4 workers all sitting idle, nothing processing, no scans or anything. I have plenty of disk space available for use.

 

 

Link to comment
I get this error repeatedly when I try to process a large library:
 
2021-10-10T14:16:46:WARNING:Unmanic.Foreman - [FORMATTED] - Postprocessor queue is over 4. Halting feeding workers until it drops.
 
When this happens I have to restart unmanic and then it will pickup and start processing files again. 
 
I have 4 workers all sitting idle, nothing processing, no scans or anything. I have plenty of disk space available for use.
 
 
I'll need all the logs. There are items in your Post-Processor queue that are either taking a long time or are throwing exceptions and staying in cache.
Link to comment
13 hours ago, Josh.5 said:
18 hours ago, CyrixDX4 said:
I get this error repeatedly when I try to process a large library:
 
2021-10-10T14:16:46:WARNING:Unmanic.Foreman - [FORMATTED] - Postprocessor queue is over 4. Halting feeding workers until it drops.
 
When this happens I have to restart unmanic and then it will pickup and start processing files again. 
 
I have 4 workers all sitting idle, nothing processing, no scans or anything. I have plenty of disk space available for use.
 
 

I'll need all the logs. There are items in your Post-Processor queue that are either taking a long time or are throwing exceptions and staying in cache.

 

I no longer have the logs as I switched back to 0.0.9.  I missed the simplicity of the earlier version with less fiddly bits and it was incredibly stable. 

 

I appreciate your hard work in bringing enhancements to unmanic.  I'll follow along and see what other upgrades come along and try again later.

 

 

For those folks that want to roll back to 0.0.9 (I know it's no longer supported) you can add the following to the docker template under "repository":
josh5/unmanic:0.0.9

 

 

 

 

  • Like 1
Link to comment

@Josh.5  I just stumbled across this and I'm looking forward to trying it out.  I'm running the latest Unraid with an Nvidia RTX.  Do I need to use the --runtime=nvidia and GPU UUID or not?  Your note under deprecated seems to suggest not, but I see it referenced almost everywhere else so it's been confusing to me.  TIA.

Link to comment
15 minutes ago, BurntOC said:

@Josh.5  I just stumbled across this and I'm looking forward to trying it out.  I'm running the latest Unraid with an Nvidia RTX.  Do I need to use the --runtime=nvidia and GPU UUID or not?  Your note under deprecated seems to suggest not, but I see it referenced almost everywhere else so it's been confusing to me.  TIA.

You are quite right. I should update the instructions removing that warning as I highly doubt anyone is still running the older version of Unraid and so there is no need to keep those instructions.

 

Just follow the instructions in the template adding the --runtime=nvidia option and the other things that it says to.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.