[Support] Josh5 - Unmanic - Library Optimiser


Recommended Posts

So install worked but I'm looking for the filebot plugin? Anyone got that to work?
 
Also; which plugins do you use and why?
 
Cheers!
Look for the exec custom Post-Processor script plugin. There is an example on how to setup for filebot in the description after you install it.
Link to comment

I have had the same thing as many others have had. I am running mover2 to move optimised content to my plex server. i have added folders to allow mover to move to a different folder area. my version is the latest, and my unraid version is 6.9.2

 

here's the log;

 

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
**** (permissions_config) Setting run user uid=100(abc) gid=99(abc) ****
usermod: no changes
**** (permissions_config) Setting permissions ****
**** (permissions_config) Adding run user to video group ****
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-patch-nvidia: executing...
[cont-init.d] 30-patch-nvidia: exited 0.
[cont-init.d] 60-custom-setup-script: executing...
[cont-init.d] 60-custom-setup-script: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
2021-11-18T00:47:38:INFO:Unmanic.UnmanicLogger - Debug logging disabled
2021-11-18T00:47:38:INFO:Unmanic.UnmanicLogger - Initialising file logger. All further logs should output to the 'unmanic.log' file
Exception in thread PostProcessor:
Traceback (most recent call last):
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3160, in execute_sql
cursor.execute(sql, params or ())
sqlite3.OperationalError: database is locked

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/lib/python3.8/threading.py", line 932, in _bootstrap_inner
self.run()
File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/postprocessor.py", line 107, in run
self.current_task.delete()
File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/task.py", line 293, in delete
self.task.delete_instance()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 6652, in delete_instance
return type(self).delete().where(self._pk_expr()).execute()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 1911, in inner
return method(self, database, *args, **kwargs)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 1982, in execute
return self._execute(database)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 2479, in _execute
cursor = database.execute(self)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3173, in execute
return self.execute_sql(sql, params, commit=commit)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3167, in execute_sql
self.commit()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 2933, in __exit__
reraise(new_type, new_type(exc_value, *exc_args), traceback)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 191, in reraise
raise value.with_traceback(tb)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3160, in execute_sql
cursor.execute(sql, params or ())
peewee.OperationalError: database is locked

Link to comment
I have had the same thing as many others have had. I am running mover2 to move optimised content to my plex server. i have added folders to allow mover to move to a different folder area. my version is the latest, and my unraid version is 6.9.2
 
here's the log;
 
[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
**** (permissions_config) Setting run user uid=100(abc) gid=99(abc) ****
usermod: no changes
**** (permissions_config) Setting permissions ****
**** (permissions_config) Adding run user to video group ****
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-patch-nvidia: executing...
[cont-init.d] 30-patch-nvidia: exited 0.
[cont-init.d] 60-custom-setup-script: executing...
[cont-init.d] 60-custom-setup-script: exited 0.
[cont-init.d] 90-custom-folders: executing...
[cont-init.d] 90-custom-folders: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
2021-11-18T00:47:38:INFO:Unmanic.UnmanicLogger - Debug logging disabled
2021-11-18T00:47:38:INFO:Unmanic.UnmanicLogger - Initialising file logger. All further logs should output to the 'unmanic.log' file
Exception in thread PostProcessor:
Traceback (most recent call last):
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3160, in execute_sql
cursor.execute(sql, params or ())
sqlite3.OperationalError: database is locked

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/lib/python3.8/threading.py", line 932, in _bootstrap_inner
self.run()
File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/postprocessor.py", line 107, in run
self.current_task.delete()
File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/task.py", line 293, in delete
self.task.delete_instance()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 6652, in delete_instance
return type(self).delete().where(self._pk_expr()).execute()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 1911, in inner
return method(self, database, *args, **kwargs)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 1982, in execute
return self._execute(database)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 2479, in _execute
cursor = database.execute(self)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3173, in execute
return self.execute_sql(sql, params, commit=commit)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3167, in execute_sql
self.commit()
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 2933, in __exit__
reraise(new_type, new_type(exc_value, *exc_args), traceback)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 191, in reraise
raise value.with_traceback(tb)
File "/usr/local/lib/python3.8/dist-packages/peewee.py", line 3160, in execute_sql
cursor.execute(sql, params or ())
peewee.OperationalError: database is locked
Are all your plugins up-to-date?

You can clear the write lock by deleting the unmanic.db-shm and unmanic.db-wal files in the config directory
Link to comment

Hello, I have been enjoying your program lately but I seem to have an issue with the Data Panels section. When I navigate to this page it is blank after using the Video Encoder H265/HEVC - libx265 (CPU) on a batch of files. Is this a bug or am I doing something incorrectly? Thanks

Link to comment
Hello, I have been enjoying your program lately but I seem to have an issue with the Data Panels section. When I navigate to this page it is blank after using the Video Encoder H265/HEVC - libx265 (CPU) on a batch of files. Is this a bug or am I doing something incorrectly? Thanks
Do you have a data panel plugin installed?
Link to comment
8 hours ago, Josh.5 said:

Are all your plugins up-to-date?

You can clear the write lock by deleting the unmanic.db-shm and unmanic.db-wal files in the config directory

when trying to update (they show as current) it comes up with an error trying to find updates for plugins.

 

"Unmanic has stopped processing tasks as it has detected an incompatible Plugin - Mover v2"


unmanic.log;

 

2021-11-18T19:40:23:ERROR:Unmanic.PluginsHandler - [FORMATTED] - Exception while fetching plugin info for mover2: - Expecting value: line 1 column 1 (char 0)
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/plugins.py", line 783, in get_incompatible_enabled_plugins
    plugin_info = self.get_plugin_info(record.get('plugin_id'))
  File "/usr/local/lib/python3.8/dist-packages/unmanic/libs/plugins.py", line 208, in get_plugin_info
    plugin_info = json.load(json_file)
  File "/usr/lib/python3.8/json/__init__.py", line 293, in load
    return loads(fp.read(),
  File "/usr/lib/python3.8/json/__init__.py", line 357, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.8/json/decoder.py", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.8/json/decoder.py", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
2021-11-18T19:40:25:INFO:Unmanic.PluginsHandler - [FORMATTED] - Installed plugin 'mover2'

Link to comment

I just recently got around to setting unmanic up again after the big update. It's working very well for the most part, but for some reason it's no longer using my GPU. I checked, and I still have --runtime=nvidia in the extra parameters and my GPU UUID in the more settings.

 

Am I missing something about configuring the docker to use a GPU? That's all I saw in the template instructions. Thanks in advance!

Link to comment
20 hours ago, Josh.5 said:
On 11/17/2021 at 8:39 PM, Omish said:
Hello, I have been enjoying your program lately but I seem to have an issue with the Data Panels section. When I navigate to this page it is blank after using the Video Encoder H265/HEVC - libx265 (CPU) on a batch of files. Is this a bug or am I doing something incorrectly? Thanks

Do you have a data panel plugin installed?

 

Well that was a simple fix. Doh. 

 

Thank you!

Link to comment
On 11/16/2021 at 1:16 AM, Josh.5 said:

Not all h265 encoders are equal. You will also need to specify bitrate etc. I personally do not believe that you will get the results you are looking for.

But if you are keen to do as you say, I suggest you fork the h265 plugin from the official repo and modify it to force the encode when the file is already in h265

Ok, thanks for the feedback.  Yeah if it doesn't work then C'est la vie . . . it's not that hard for me to periodically run a file scan via rsync to gather files, and then encode them via Handbrake.

But if I get some time I may experiment with a fork . . . (learning curve though on how to install plugin manually, etc.).  Wish it was something that was configurable.

Link to comment
18 hours ago, jbridgma said:

I just recently got around to setting unmanic up again after the big update. It's working very well for the most part, but for some reason it's no longer using my GPU. I checked, and I still have --runtime=nvidia in the extra parameters and my GPU UUID in the more settings.

 

Am I missing something about configuring the docker to use a GPU? That's all I saw in the template instructions. Thanks in advance!

Do you have the Video Encoder H265/HEVC - hevc_nvenc (NVIDIA GPU) plug in installed? Go to three lines icon in the upper left> Settings> Plugins> Add New+ > Then find the above plug in and install it. Once that is done make sure to enable it on the main plug in screen then reenable your workers. It should start using your GPU at that point. 

Link to comment

Great program.. Im having a hard time setting up Filebot currently. Is the container supposed to be named "filebot"? also, do directories need to be the same in both containers?

TIA. I just cant get the command to trigger on my filebot...

 

Command: "filebot"  <---- I think this is the problem...

Arguments: "--format "{n.replace('h264', 'h265')}"

Link to comment

I've been working with @GonjaT today to help them setup the FileBot configuration as well as document a bit about how it is done. I've added a section to the Unmanic Docs page called "Guides". Please feel free to write up and submit any setup guides that you think other members of the community may find useful as I have done here. It helps us all out and is a great way for you to show your appreciation towards the project.

 

Link: https://docs.unmanic.app/docs/
image.png.af2d9ceb2522a84d6ebaed797ead125e.png

  • Like 1
Link to comment

Hi all - couple questions from a newbie that just got unmanic running

  1. where do the encoded files live? 
    1. I ask, because my unmanic has encoded (successfully, I assume based on the completed tasks tab) 10 movies, but when I check the library, they do not appear to have been edited (not even one byte difference) or even accessed. Which lead me to believe maybe they're stored somewhere else and I have to manually replace the original?
  2. there is no information on the Data Panel
    1. is there something I have missed in the settings that enables this?
Link to comment
12 hours ago, CouchPawTayTow said:

Hi all - couple questions from a newbie that just got unmanic running

  1. where do the encoded files live? 
    1. I ask, because my unmanic has encoded (successfully, I assume based on the completed tasks tab) 10 movies, but when I check the library, they do not appear to have been edited (not even one byte difference) or even accessed. Which lead me to believe maybe they're stored somewhere else and I have to manually replace the original?
  2. there is no information on the Data Panel
    1. is there something I have missed in the settings that enables this?

 

Quote

where do the encoded files live?

By default they end up back in the same directory as the source.

Quote

there is no information on the Data Panel

Have you installed a data panel plugin? (This has been asked a number of times now. I am working on adding a notice to this page to suggest installing a plugin if the page is empty)

 

Link to comment
4 hours ago, Josh.5 said:

By default they end up back in the same directory as the source.

OK, but in that case why would the original files be unchanged? I have it just doing the 265 CPU encode, AAC, and changing the wrapper to MP4, but all the files it reports as being successfully processed have not changed (size is same and wrappers are mixed).

 

4 hours ago, Josh.5 said:

Have you installed a data panel plugin? (This has been asked a number of times now. I am working on adding a notice to this page to suggest installing a plugin if the page is empty)

Yeah, I found that out searching through the thread. I have a feeling this is still user error re: the way I setup the container. Think I will rebuild and if still not working will report back.

Edited by CouchPawTayTow
Link to comment

I saw a utube video with ibracorp and he shows how to setup unmanic and install the 265 transcoder plugin. So I tried it on several 264 movie files I intended to shrink my whole library down. I realize that I will have to transcode everything I play after the conversion but when I tested the app on those movie files they all went from 1.8 GB to 25 GB. Is there a reason that its making the files bigger instead of smaller? I intended to save space, not because I'm running short of space or anything but because I thought i could shrink everything 50 percent and be able to stock up my media library with double the titles. Is there a better alternative to 265? should I just stay at 264 for less hp needed to play the files? Why would it make them so much bigger? I don't understand why they are all coming out 25 GB did I configure it wrong or is that the wrong plugin to use? I used the nvidia 265 transcoder plugin. I had to delete all the files and re download the torrents because the 3 I did were taking up to much space.

 

The files that converted converted to 25GB 

Most of the other files i tried to convert had this error:

LOG:

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/library/movies/Mission impossible collection/Mission Impossible - Fallout (2018) [BluRay] [1080p] [YTS.AM]/Mission.Impossible.-.Fallout.2018.1080p.BluRay.x264-[YTS.AM].mp4':

   Metadata:

     major_brand : isom

     minor_version : 512

     compatible_brands: isomiso2avc1mp41

     encoder : Lavf58.19.100

   Duration: 02:27:24.96, start: 0.000000, bitrate: 2308 kb/s

     Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x800 [SAR 1:1 DAR 12:5], 2150 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)

     Metadata:

       handler_name : VideoHandler

     Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 152 kb/s (default)

     Metadata:

       handler_name : SoundHandler

Stream mapping:

   Stream #0:0 -> #0:0 (h264 (native) -> hevc (hevc_nvenc))

   Stream #0:1 -> #0:1 (copy)

Press [q] to stop, [?] for help

[hevc_nvenc @ 0x560f631861c0] OpenEncodeSessionEx failed: out of memory (10): (no details)

[hevc_nvenc @ 0x560f631861c0] No capable devices found

Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

Conversion failed!

Edited by RYZEN5000
Link to comment
I saw a utube video with ibracorp and he shows how to setup unmanic and install the 265 transcoder plugin. So I tried it on several 264 movie files I intended to shrink my whole library down. I realize that I will have to transcode everything I play after the conversion but when I tested the app on those movie files they all went from 1.8 GB to 25 GB. Is there a reason that its making the files bigger instead of smaller? I intended to save space, not because I'm running short of space or anything but because I thought i could shrink everything 50 percent and be able to stock up my media library with double the titles. Is there a better alternative to 265? should I just stay at 264 for less hp needed to play the files? Why would it make them so much bigger? I don't understand why they are all coming out 25 GB did I configure it wrong or is that the wrong plugin to use? I used the nvidia 265 transcoder plugin. I had to delete all the files and re download the torrents because the 3 I did were taking up to much space.
 
The files that converted converted to 25GB 
Most of the other files i tried to convert had this error:
LOG:
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/library/movies/Mission impossible collection/Mission Impossible - Fallout (2018) [bluRay] [1080p] [YTS.AM]/Mission.Impossible.-.Fallout.2018.1080p.BluRay.x264-[YTS.AM].mp4':
   Metadata:
     major_brand : isom
     minor_version : 512
     compatible_brands: isomiso2avc1mp41
     encoder : Lavf58.19.100
   Duration: 02:27:24.96, start: 0.000000, bitrate: 2308 kb/s
     Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x800 [sAR 1:1 DAR 12:5], 2150 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
     Metadata:
       handler_name : VideoHandler
     Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 152 kb/s (default)
     Metadata:
       handler_name : SoundHandler
Stream mapping:
   Stream #0:0 -> #0:0 (h264 (native) -> hevc (hevc_nvenc))
   Stream #0:1 -> #0:1 (copy)
Press [q] to stop, [?] for help
[hevc_nvenc @ 0x560f631861c0] OpenEncodeSessionEx failed: out of memory (10): (no details)
[hevc_nvenc @ 0x560f631861c0] No capable devices found
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
Conversion failed!
Well the reason for the error in the log is because you are running too many transcodes at a time. What GPU do you have?

As for the 25GB files... I don't think anyone can help you on hearsay. Without logs being posted, your on your own.
Link to comment
On 11/21/2021 at 6:02 AM, Josh.5 said:

 

By default they end up back in the same directory as the source.

OK, so in my testing, is seems that it may be a permissions issue?

I've run unmanic on a remote server (it's all mapped correctly etc.), and unmanic will pick up the file, spend a few hours transcoding it and then stick it in the completed tasks list as successful, but the original file in unchanged. And coincidentally, nothing registers on the data plugin.

However, if I run unmanic on the same server as the media files i.e. locally, it all works. So the only think I can think of is permissions? like it can't write back when it's done?

 

Here's the log for one that was done on the remote machine - but I can't really see anything that suggest a permission/write error?

 

 

RUNNER:
Audio Encoder AAC [Pass #1]
Executing plugin runner... Please wait
Runner did not request to execute a command
RUNNER:
File Size Metrics Data Panel [Pass #1]
Executing plugin runner... Please wait
Runner did not request to execute a command
RUNNER:
Video Encoder H265/HEVC - libx265 (CPU) [Pass #1]
Executing plugin runner... Please wait
Plugin runner requested for a command to be executed by Unmanic
COMMAND:
ffmpeg -hide_banner -loglevel info -i /library/unmanicTest/ubuntu/Blackhat - 2015.mp4 -strict -2 -max_muxing_queue_size 2048 -map 0:v:0 -map 0:a:0 -c:v:0 libx265 -preset medium -crf 28 -c:a:0 copy -y /tmp/unmanic/unmanic_file_conversion-1637808415.3074853/Blackhat - 2015-1637808415.3074453-WORKING-3.mp4
LOG:
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/library/unmanicTest/ubuntu/Blackhat - 2015.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
creation_time : 2015-06-06T06:27:22.000000Z
Duration: 02:13:34.12, start: 0.000000, bitrate: 2092 kb/s
Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/unknown), 1920x800, 1994 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
Metadata:
creation_time : 2015-06-06T06:27:22.000000Z
handler_name : video.264#trackID=1:fps=23.976 - Imported with GPAC 0.5.0-rev
Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 93 kb/s (default)
Metadata:
creation_time : 2015-06-06T06:27:33.000000Z
handler_name : GPAC ISO Audio Handler
Stream mapping:
Stream #0:0 -> #0:0 (h264 (native) -> hevc (libx265))
Stream #0:1 -> #0:1 (copy)
Press [q] to stop, [?] for help
x265 [info]: HEVC encoder version 3.2.1+1-b5c86a64bbbe
x265 [info]: build info [Linux][GCC 9.3.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT
x265 [info]: Main profile, Level-4 (Main tier)
x265 [info]: Thread pool created using 6 threads
x265 [info]: Slices : 1
x265 [info]: frame threads / pool features : 2 / wpp(13 rows)
set_mempolicy: Operation not permitted
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge : hex / 57 / 2 / 3
x265 [info]: Keyframe min / max / scenecut / bias: 23 / 250 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt : 20 / 4 / 2
x265 [info]: b-pyramid / weightp / weightb : 1 / 1 / 0
x265 [info]: References / ref-limit cu / depth : 3 / off / on
x265 [info]: AQ: mode / str / qg-size / cu-tree : 2 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress : CRF-28.0 / 0.60
x265 [info]: tools: rd=3 psy-rd=2.00 early-skip rskip signhide tmvp b-intra
x265 [info]: tools: strong-intra-smoothing lslices=5 deblock sao
Output #0, mp4, to '/tmp/unmanic/unmanic_file_conversion-1637808415.3074853/Blackhat - 2015-1637808415.3074453-WORKING-3.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
encoder : Lavf58.45.100
Stream #0:0(und): Video: hevc (libx265) (hev1 / 0x31766568), yuv420p, 1920x800, q=-1--1, 23.98 fps, 24k tbn, 23.98 tbc (default)
Metadata:
creation_time : 2015-06-06T06:27:22.000000Z
handler_name : video.264#trackID=1:fps=23.976 - Imported with GPAC 0.5.0-rev
encoder : Lavc58.91.100 libx265
Side data:
cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: N/A
Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 93 kb/s (default)
Metadata:
creation_time : 2015-06-06T06:27:33.000000Z
handler_name : GPAC ISO Audio Handler
frame= 28 fps=0.0 q=0.0 size= 0kB time=00:00:01.00 bitrate= 0.4kbits/s dup=2 drop=0 speed=1.97x
[A TON OF TRANSCODING OMITTED]
frame=192146 fps=3.3 q=35.8 Lsize= 639259kB time=02:13:34.10 bitrate= 653.4kbits/s dup=2 drop=0 speed=0.137x
video:542057kB audio:91636kB subtitle:0kB other streams:0kB global headers:2kB muxing overhead: 0.878290%
x265 [info]: frame I: 1950, Avg QP:26.12 kb/s: 4194.43
x265 [info]: frame P: 57939, Avg QP:28.38 kb/s: 1165.98
x265 [info]: frame B: 132257, Avg QP:33.79 kb/s: 231.25
x265 [info]: Weighted P-Frames: Y:1.2% UV:0.7%
x265 [info]: consecutive B-frames: 12.4% 8.9% 29.6% 43.6% 5.5%
encoded 192146 frames in 58477.39s (3.29 fps), 553.32 kb/s, Avg QP:32.08

 

Link to comment

Hi all, I have now a day tried my video files with a H264 + vaapi to decode type. I can not get it to work. There is already a plugin for 265 and that works without problems. But I want the 264 codec and I can't get it to work with hardware support. I only have an iGPU from my processor.  Can someone help me?

Link to comment

Hello, I just installed Unmanic to replace handbrake (the thing I don't like about handbrake is that force converts srt to ass).

 

So far going great, but a couple questions:

 

1.- I get "Unable to connect to Unmanic backend. Please check that it is running." in the webUI.  Despite that message conversion works so I don't know what the backend is or what I am missing.

 

2.- The mover v2 plugin does a copy of the file to another location (and still replaces the original with the new transcode) Is this how it supposed to work? I think the logical behavior to need this plug-in is leave original file in original location alone and put the new transcode in the specified location (great to compare both).

 

3.- Unmanic is using x265 3.2.1+1-b5c86a64bbbe, is there a reason to use this version and not a recent one?

 

4.- Why the media info of the transcoded file wrongly states the bitrate of the original file under the video stream?

 

Edited by arturovf
typos
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.