Jump to content
avlec

GPU Passthrough Black Screen SOLVED

2 posts in this topic Last Reply

Recommended Posts

I'm trying to get GPU passthrough working on Windows 10The VNC connection was used to setup the virtual machine, which worked fine (installed the virtio display driver). When switching the VM to display through the video card, after the setup through VNC, the UNRAID login command line interface disappears and the screen turns black. Nothing happens after that.

 

What's interesting is that when I use the GPU passthrough with a Ubuntu 18.10 server VM, the command line appears for that VM on the screen.

 

Heard trying to switch from QEMU to SeaBIOS could work. However, the option to switch the BIOS is greyed out.

 

Solved: Turns out that the VirtIO driver hates the GPU, so rolling back the driver to the windows basic display driver through the VNC connection fixed the problem.

Edited by avlec

Share this post


Link to post

Sounds like you need to watch some videos from Space Invader, they helped me a lot...

 

He has some other updated videos after this one if it doesn't fully solve your issue...

 

Some key points though, change you VM machine type from the default that UnRaid gives (i440fx) and change it to Q35...  If you can reinstall the VM with that, that is best, but if you have to keep your current VM than make sure to do some backups, then create a new VM but point it at the old image file (Don't skip the backups)...  If you have an nVidia card that you are trying to passthrough, you will also need a video BIOS file for/from your card...  The videos will help with that...

 

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now