Jump to content

Ryzen 2200G Vega 8 iGPU passthrough [Solved]

6 posts in this topic Last Reply

Recommended Posts



I'm new to Unraid , so far it's the nuts. Though now I've got myself stuck. 


I built a Windows 10 VM using i440fx-3.0 OVMF. On the host , its just running a terrible GT 620 and on the VM I'm set the graphics card to the Vega iGPU.


I get no output on the monitor, and all I can find is 

Jan 11 14:52:47 Tower kernel: iommu ivhd0: IOTLB_INV_TIMEOUT device=38:00.0 address=0x000000022e8502a0]
Jan 11 14:52:48 Tower kernel: AMD-Vi: Completion-Wait loop timed out
Jan 11 14:52:49 Tower kernel: AMD-Vi: Completion-Wait loop timed out


Can anyone point me in the right direction what to do next?


I know it seems pointless as its just an iGPU but that's all I have for now!




Purchased a a 1060 and managed to pass it through

Edited by TypeDan

Share this post

Link to post

Not super familiar with Ryzen, but I have Intel/nVidia gaming VM, recently found out that even though it is recommended for the Windows VM by default to use the i440fx, as far as I can tell, the i440fx should not be used for anything anymore except retro OS's or something... Saw a decent performance bump when I flipped the VM to use Q35 instead, and as far as I can tell, there is no longer any reason not to use it for most people...  It does affect GPU passthrough as well, since i440fx can't do PCIe, and changes the bus to be PCI (doesn't change the bus speed, but adds translation overhead to everything...)


If you can, reinstall the VM if it is new... If you need to keep it, make backups and just create a new VM and point it to the old image file...  Usually Windows will just boot and reinstall all the drivers for the system (Takes quite a while, but usually works)...

Share this post

Link to post

Thanks for getting back to me , appreciate it. 

Ive tried with a Q35, no joy :(, then I switched back. 


Ill bin this i440fx VM and soon up another with Q35 anyway. 

Atleast then I’m at a good place to start



Share this post

Link to post

Still no joy, found an option on the motherboard to enable iommu, which I did . I have no idea what next to try. 


Edited by TypeDan

Share this post

Link to post
3 hours ago, TypeDan said:

This can be closed

Edit the first post in the thread and add [Solved] to the subject line.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now