Jump to content
Micaiah12

Having GPU/Driver issues - Windows 10 - AMD

4 posts in this topic Last Reply

Recommended Posts

Hey guys,

I am having some issues with passing through an AMD GPU. It's strange, because I was able to pass through this same GPU about 6 months ago to a Windows 10 VM. Basically what is happening is that I will setup a Windows 10 VM with VNC as the main GPU and the RX480 as my secondary. I will go through the windows setup and get to the desktop. I will then install all the missing drivers and then install the GPU driver. Once the driver is installed for the GPU my entire VNC session goes black. I try to RDP into the VM and I get to the desktop, but everything is black and I can only see the cursor. If I force stop the VM and start it back up it freezes on the loading bar and then it goes into windows recovery mode. I have tried these attempts, but without any change.

  • Switched Machine from i440fx-3.0 to Q35-3.0
  • Turned Hyper-v Off
  • Tried install with different CPU cores selected
  • Tried not installing redhat display driver and just installing AMD Driver in device manager
  • Tried VM install with just VNC as GPU and setup Windows and then shut the Windows 10 VM down and passed through the AMD GPU and it still shows a black screen

I am trying an install right at this moment as a SeaBIOS, I will update this thread if that is successful. I've been at this all week, I have followed a bunch of other different guides (spaceinvaders) and still no luck. I have attached logs to this thread as well. Any ideas would be super helpful.

 

Thanks!

Capture.JPG

tower-diagnostics-20190113-1056.zip

Share this post


Link to post

SeaBios should be avoided at this point, Legacy OS's only, and causes issues with GPU passthrough...  Don't have an AMD myself so can't help further, looks like you have done everything I would have tried...

Share this post


Link to post

I just tried SeaBIOS and it didn't work neither did bumping down i440fx-3.0 to i440fx-2.11 which I know for sure was what I was running on when I did this pass through successfully last time.

Share this post


Link to post

Just an update. I was able to finally get this to work. The workaround was to setup the VM as normal and exclude the GPU and use VNC. Once Windows was installed, I DID NOT install any drivers from the virtual CD-ROM. Instead, enabled RDP, shutdown the VM, edited the config to remove VNC and replace it with AMD GPU. I then started the VM and used remote desktop to get into Windows. After remoting in, I installed the AMD driver and everything went smoothly. So far about 24 hours or so. The VM is stable and working, however I can't use the UNRAID VNC to access the VM, if I assign it and move the AMD GPU to #2 slot. The VM crashes. Is there an explanation at all for this? I have never had this issue before, I was always able to use the VNC and the GPU options together with my Windows VM. Did this change in an update?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now