Jump to content
srandolph

System notifications are disabled

7 posts in this topic Last Reply

Recommended Posts

supermicro X10SL7-F w/ 32 GB Memory, Unraid Plus @ 6.6.6 & 3 x 4 TB HD

 

"System notifications are disabled. Click here to change notification settings." message continues to show on banner.  I go to Notification Setting, Enable, Apply and it returns to the Disabled state.  I have tried configuring it just like I have done on a second similar machine,  but this one alway return to the disabled state.  Attached is bodle-diagnostics-20190113-2328.zip

 

Thanks

Scott

Edited by srandolph

Share this post


Link to post

Forgive me for repleting this issue but I got no responses from first post and I am totally stumped.  I have a warning banner on my browser interface "System notifications are disabled. Click here to change notification settings."  Clicking on here gets me to /Settings/Notifications and indeed System notifications is Disabled.  I  will select enabled and just for fun change Array status notification to Send once a day.  When I do this the Apply button will unghost, so I will select Apply and the screen resort back to the Disabled state.

 

I have reformatted my flash, loaded a new copy of 6.6.6 on it and reapplied by \config folder but still have this problem.  I am at a loss on what to do to change the  this situation.  I would hate to have to rebuild the flash from the ground up.  I have two machine of similar specs and at the same level of unRaid and my brother also has two similar servers.  We have consulted about this issue but with no solutions.  This problem only happens on this one machine. 

 

Wishing I had more skills in evaluating the diagnostics and knowing what to look for.

 

Thanks

Scott

Supermicro X10SL7-F w/ 32 GB Memory & 3 x 4 TB HD, Unraid Plus @v 6.6.6

bodle-diagnostics-20190118-1439.zip

Edited by srandolph

Share this post


Link to post

I merged your threads. Sorry you got no response initially. Instead of starting a new thread the proper way to try to draw attention to your question if you haven't received a response after a reasonable wait is to "bump" the thread. Just make another post in that same thread. Often people will do that with just the word "bump" in the new post. That has the effect of making the thread show up near the top again when people are browsing the forum.

 

Your description sounds like a possible web browser issue. Do you have any adblockers? Have you tried clearing the browser cache? Have you tried another browser?

 

Also, you really need to configure Notifications so it will send you any alerts and warnings by email or other agent. You want to know as soon as possible if Unraid detects a problem so you don't let things deteriorate to data loss.

Share this post


Link to post

Just now looked at your syslog in the diagnostics. It is full of "wrong csrf token" entries. This is caused by having multiple browsers open to your server. That might even be the cause of your problem. Close all other browsers including mobile apps if you have one accessing your Unraid server. It is always best to manage your server from a single browser session so you don't get things out-of-sync.

Share this post


Link to post

Constructor

Thanks for the feedback, I will try the simple bump method next. 

I did go down stairs and turn of the other computer and stopped the flood of "wrong csrf token" errors.  I rebooted this computer and cleared cache in both Chrome and Firefox.  Every time I try to enable notifications I get this message in syslog.  It come as a simple text message and I did kill the tab in Firefox before logging in with Chrome. 

 

Does this give you (or anyone else) a clue?  Like I tried to say, I can execute a notifications enable/disable on my other unRaid server from either one of these browsers without any issues

 

Jan 18 16:58:51 Bodle ool www[24970]: /usr/local/emhttp/plugins/dynamix/scripts/notify 'cron-init'

Jan 18 17:00:02 Bodle ool www[24970]: /usr/local/emhttp/plugins/dynamix/scripts/notify 'cron-init'

Jan 18 17:02:22 Bodle ool www[24953]: /usr/local/emhttp/plugins/dynamix/scripts/notify 'cron-init'

Jan 18 17:03:12 Bodle ool www[1827]: /usr/local/emhttp/plugins/dynamix/scripts/notify 'cron-init'

 

Appreciate,

Scott

Share this post


Link to post

Since I do not have the skills to evaluate the diagnostics and resolve this issue and I was not getting a lot of useful advise from the Form, I went with plan 'B'.

I am sure there was a simpler solution but I was not seeing it and it was time to get beyond this issue and get on with living.  FYI, I have included the steps I used to a successful resolution. The one thing I can say about this approach is it speaks to the resiliency of the unRAID system, the Holy Grail of any NAS, no data lost.

1-      From local desktop browser unRAID console went to Main -> Flash -> Flash Backup and created backup to local desktop hard drive

2-      Carefully going to screens on console cutting vital information, e.g. serial number of drives assigned to which disk, name of shares and other setting, to paste into a text editor.

3-      Shutdown unRAID, remove flash and place in desktop machine.

4-      Copy /config/Plus1.key from flash to desktop machine

5-      Using Unraid.USB.Creator.Win32-1.5.exe reload current unRAID version (6.6.6)

a.       Selected Customize and added my server name

b.      Selected static and provided my IP address & Allow UEFI Boot

6-      Copied Plus1.key file from desktop back to /config folder in on newly re-imaged flash drive

7-      After completion, ejected flash drive, inserted in server and restarted Unraid server

8-      Back at unRAID console at Main screen, reassigned to Disk positions.

9-      Stared Array and the system went into Parity-Check.

10-   I was now able to go to /Settings/Notifications and Enable the subsystem.

11-   Since I could see that all of my previous User Shares and VMs were recognized, I went to bed and slept well.

12-   Today I will reload and reconfigure my Dockers and other Plugins with text copy of previous information.

 

Not sure how to mark this issue resolved but it is.

Share this post


Link to post

Sometimes starting "fresh" isn't a bad thing to do.

You have a clean system to work on :) 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now