Jump to content
caillou

Mount unRAID disk in Linux

7 posts in this topic Last Reply

Recommended Posts

Given the following situation, due to user error:

 

* A single data disk of an array has survived. The others have been formated.

* The unRAID USB disk has been formated.

 

I would like to mount the remaining disk and save the data.

 

Here is what I have tried from the Terminal in Linux:

$ sudo mount -t xfs /dev/sdb /mnt/unraid-disk

mount: /mnt/unraid-disk: wrong fs type, bad option, bad superblock on /dev/sdb,
missing codepage or hepler program, or other error.

I am pretty sure I did not format or write to this disk in any way. How can I mont this disk in Linux? Is this even possible? And if not,  is there a procedure to save the data on that disk?

Share this post


Link to post

You need to specify the partition /dev/sdb1

 

Do you not intend to have an Unraid system? If you do, then you can work with it in Unraid just as well as you can in another linux.

Share this post


Link to post

@trurl Thanks for your quick response. If I specify the partition, I get the following error:

$ sudo mount -t xfs /dev/sdb1 /mnt/unraid-disk
mount: /mnt/unraid-disk: special device /dev/sdb1 does not exist.

`fdisk` returns the following information:

$ sudo fdisk -l

Disk /dev/sdb: 746,5 GiB, 801569726464 bytes, 1565565872 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start        End    Sectors Size Id Type
/dev/sdb1           1 4294967295 4294967295   2T ee GPT

Interestingly this is a 3TB disk.

 

So you have a suggestion as to what I could try next?

Edited by caillou
fixed typo

Share this post


Link to post

@trurl I installed unRAID and unraid tells me the disk is 802 GB (instead of 3000 GB), and it says "Unmountable: Unsupported partition layout".

 

Is there any chance I can save this data?

Share this post


Link to post

What controller is this disk connected to?   It sounds like you might be using a controller that cannot handle disks greater than 2TB in size?

  • Like 1

Share this post


Link to post

@itimpi That was exactly it! The data is back!

 

I used an old SATA-to-USB controller. Tried it with another one from the office, and the disk mounted.

 

Can I ask you, what tipped you off?

Share this post


Link to post
9 minutes ago, caillou said:

Can I ask you, what tipped you off?

 

3 hours ago, caillou said:

Disk /dev/sdb: 746,5 GiB,

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now