Jump to content
dee31797

intel-gpu-tools

20 posts in this topic Last Reply

Recommended Posts

discussion moved here

 

Docker container for viewing the utilization of an Intel GPU.

  

Dockerhub URL:

https://hub.docker.com/r/djaydev/intel-gpu-tools

  

If you would like to use an Unraid template, download and place the following xml file in your flash drive's config/plugins/dockerMan/templates-user folder.  Then from the unraid UI click add container and select intel-gpu-tools in the template drop down.

unraid template link:

https://raw.githubusercontent.com/djaydev/docker-intel-gpu-tools/master/unraid/template/intel-gpu-tools.xml

Untitled.png

Edited by dee31797

Share this post


Link to post
1 hour ago, daves said:

Will you be adding this to CA?

It's in CA now, let me know if you have any issues.

Share this post


Link to post

Just installed.  Works great!  Is there anyway to disable the webserver/VNC server?  I really only need to run this from the command line.

Share this post


Link to post
17 hours ago, daves said:

Just installed.  Works great!  Is there anyway to disable the webserver/VNC server?  I really only need to run this from the command line.

There's no way to disable the webserver/VNC server but with so little resources it uses there's really no reason to do so.  If you're worried about outside access the best bet is to not assign any ports to the container, you can just delete those entries from the container config in the WebGUI.

 

If you're still set on not running the webserver/VNC servers, I recommend not bothering with prebuilt containers and just building your own locally.

Save the following text to a file called "Dockerfile"

FROM debian

RUN apt-get update && \
	apt-get install intel-gpu-tools bash -y && \
	rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/*

Change directory to where the Dockerfile is saved and run the cli command:

docker build -t myfavdockerimage .

That will create your customized docker image.  Replace "myfavdockerimage" with whatever you want the name to be.

Now whenever you want to run your image from CLI:

docker run --rm -ti --privileged=true --device /dev/dri:/dev/dri myfavdockerimage intel_gpu_tools

 

Edited by dee31797

Share this post


Link to post
Quote

 If you're worried about outside access the best bet is to not assign any ports to the container, you can just delete those entries from the container config in the WebGUI.

Done!  Works for me!

Share this post


Link to post

Hi there, I tried to get this tool/docker working but unfortunately iam failing everytime

 

Iam getting a black screen with these logs:

 

 

[app] starting intel-gpu-tools...

[app] starting intel-gpu-tools...
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

 

Share this post


Link to post
9 minutes ago, Toobie said:

Hi there, I tried to get this tool/docker working but unfortunately iam failing everytime

 

Iam getting a black screen with these logs:

 

 

[app] starting intel-gpu-tools...


[app] starting intel-gpu-tools...
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

 

 

That error usually shows up when the container can't access the intel iGPU.  You have to ensure the iGPU shows up in /dev/dri/

ls /dev/dri/

Might want to try https://www.reddit.com/r/unRAID/comments/9eyt8u/unraid_intel_quick_sync_setup_for_plex/

 

 

Share this post


Link to post

I just ran headlong into this and realized that I had at some point replaced my go and syslinux.cfg without adding back the i915 modifications that were required.

 

This thread was more useful to me at this point in time than the reddit thread (looks like some stuff was deleted from it): https://forums.unraid.net/topic/62525-solved-igpu-transcoding-i915-driver-present-but-devdri-not-available/?do=findComment&comment=703961

Share this post


Link to post
3 minutes ago, cherrybullet said:

I'm getting that error too, but I can see `/dev/dri` and plex is using hw transcode.

can you please post the complete docker settings you're using?

Share this post


Link to post
Just now, cherrybullet said:

 

You have the /dev/dri mapped twice.  Please remove one and retry, let me know if the error goes away or not

Share this post


Link to post
12 minutes ago, dee31797 said:

You have the /dev/dri mapped twice.  Please remove one and retry, let me know if the error goes away or not

I removed it from extra params and got the same error :/

 

Not sure if this helps but, I don't know if USER_ID=99 is correct for me. That's just a setting I saw on someone else's setup. Without it, it gives me an error saying it needs USER_ID.

Share this post


Link to post
7 minutes ago, cherrybullet said:

I removed it from extra params and got the same error :/

 

Not sure if this helps but, I don't know if USER_ID=99 is correct for me. That's just a setting I saw on someone else's setup. Without it, it gives me an error saying it needs USER_ID.

'USER_ID'='0'

Share this post


Link to post
4 minutes ago, dee31797 said:

'USER_ID'='0'

getting the SESSION_MANAGER error again

 

[services.d] starting app...
[app] starting intel-gpu-tools...
[services.d] done.
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

 

Share this post


Link to post
Posted (edited)

The default template I pulled from CA had /dev/dri twice. I changed it to /dev/dri and it still didn't launch. Showing advanced settings displayed the USER_ID variable, which had no value. I added 0 and everything started working. Thanks for the container! It was interesting spying on my Plex hw transcodes.

Edited by Dase
Typo

Share this post


Link to post
57 minutes ago, Dase said:

The default template I pulled from CA had /dev/dri twice. I changed it to /dev/dri and it still didn't launch. Showing advanced settings displayed the USER_ID variable, which had no value. I added 0 and everything started working. Thanks for the container! It was interesting spying on my Plex hw transcodes.

if you're talking about "/dev/dri: /dev/dri" vs " /dev/dri" thats fine either one works.  The other user had it mapped twice, "--device  /dev/dri: /dev/dri" and another  "--device  /dev/dri: /dev/dri".

Share this post


Link to post
1 hour ago, cherrybullet said:

getting the SESSION_MANAGER error again

 


[services.d] starting app...
[app] starting intel-gpu-tools...
[services.d] done.
Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined

 

cherrybullet,

Please update to the latest image and let me know if it works for you.  Docker tab -> advanced view -> force update intel-gpu-tools is my prefer method.

 

long version

For some reason this error has started occurring with the latest base image update and xfce terminal, I found that if I opened a webbrowser to the webui of the docker container and set the docker container to auto-restart on failure, it would then work on the next restart.  Obviously this shouldn't happen, but I didn't care to investigate it further so I just switched terminals.  Seems to work well on my test machine, please let me know if you still have issues.

Share this post


Link to post
33 minutes ago, dee31797 said:

cherrybullet,

Please update to the latest image and let me know if it works for you.  Docker tab -> advanced view -> force update intel-gpu-tools is my prefer method.

 

long version

For some reason this error has started occurring with the latest base image update and xfce terminal, I found that if I opened a webbrowser to the webui of the docker container and set the docker container to auto-restart on failure, it would then work on the next restart.  Obviously this shouldn't happen, but I didn't care to investigate it further so I just switched terminals.  Seems to work well on my test machine, please let me know if you still have issues.

That did it! Thank you for your help and taking the time to debug this :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.