[6.6.6] VM Missing After CPU Pinning Error


4 posts in this topic Last Reply

Recommended Posts

In order to use 3cores for a macOS VM I removed the topology XML: <topology sockets='1' cores=...

 

Everything ran fine. Shut it down, tried to use CPU Pinning under Settings to change cores, and received a "Missing Sockets Attribute..." error. No problem, I'll add it back to the XML.

 

Unfortunately the VM has disappeared. Doesn't show up in VMs, doesn't show up in CPU Pinning. How do I get this VM back?

Link to post

Create a new VM and use manual "Primary vDisk Location", and select your existing vdisk image.

Other items you'll need to configure as before.

 

Ps. Removing the topology item will invalidate the XML configuration (don't do that)

 

Edited by bonienl
Link to post

Much appreciated - copied the backup XML to a new VM template and it worked no problem. I'll admit I was holding my breath at boot.

 

Previously tried something similar with a Win10 VM, and encountered all sorts of issues. I did a before and after comparison on the XML and I noticed the UUID changed. Everything seemed to fall apart from there.

 

Removing the topology is the common suggestion for allowing 'odd' core configurations in the MacOS VM threads. Is there a better way? Simply using the CPU Pinning GUI or template manager will add cores, but then the VM won't boot.

Link to post
1 hour ago, positronicP said:

Simply using the CPU Pinning GUI or template manager will add cores, but then the VM won't boot.

Strange, because that should work.

Both methods recalculate and update the topology based on the number of cores selected. Libvirt requires a matching topology together with the number of cores

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.