[PLUGIN] Disk Location


olehj

Recommended Posts

On 3/1/2021 at 11:32 PM, cyruspy said:

Hello!, is it possible to manually set tray layouts positions?. Have 3 5in3 boxes, and a an 4in1 boxes. Each of them defined as a different group.

 

I would like to have in the representation this view (top to down):

 

4x2.5"-in-1 box (box0)

5x3.5"-in-3 box (box1)

5x3.5"-in-3 box (box2)

5x3.5"-in-3 box (box3)

 

Just like I see it in the tower.

Rather create a common group for the 5*3.5" boxes. 5 columns and 3 rows and own group for the 2.5", guess that's the best you can do for now. 

Link to comment
On 3/3/2021 at 8:44 AM, olehj said:

Update 2021.03.03

  • Commit #161 - FEATURE: Formatting of the comment field has been added, read "Help" for more information under the "Tray Allocations" tab. @shEiD
  • Commit #158 - BUG: NVME drives not detected with Unraid 6.9 because of changes in the output of lsscsi. From now on only Unraid 6.9 and above is supported. Older releases has to use the developer build without nvme support or previous Disk Location version. @Woutch @lovingHDTV

is 6.9 released or is it still beta?  I can't update because it was restricted to 6.9?

I try not to upgrade until the next unraid version is stable for a while...  I guess supporting something in the beta version breaks the current released version?

 

Jim

Link to comment

Ha..  I had to refresh my browser to see there was an OS update!  When I wrote the first message the update OS thing only showed 6.8.3

I still prefer to wait to a while before upgrading.  So I guess I don't update this plugin until I switch.  Oh Well...  Thanks for the great plugin though!

 

Jim

Link to comment
1 hour ago, jbuszkie said:

Ha..  I had to refresh my browser to see there was an OS update!  When I wrote the first message the update OS thing only showed 6.8.3

I still prefer to wait to a while before upgrading.  So I guess I don't update this plugin until I switch.  Oh Well...  Thanks for the great plugin though!

 

Jim

That's entirely up to you, but Unraid is rather a continuous beta where versions doesn't really matter :P

Link to comment
19 minutes ago, CrazySane said:

I'm running UNRAID 6.9.0-rc2 and the plugin complains that I'm running <6.9.0 and won't upgrade.

Because the minimum the plugin supports is 6.9.0  Upgrade the OS, then upgrade the plugin

  • Thanks 1
Link to comment
3 minutes ago, Squid said:

Because the minimum the plugin supports is 6.9.0  Upgrade the OS, then upgrade the plugin

🤦‍♂️ More coffee is required. My answer was right there in my question. I don't know what I was thinking. Cheers.

  • Haha 1
Link to comment
  • 2 weeks later...

Getting an error when trying to run DiskLocation after installing(below) I tried removing and re-adding the plugin, same error.

Any help would be greatly appreciated!

 

 

 

Quote

Warning: SQLite3::exec(): table settings has no column named grid_count in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 465
table settings has no column named grid_count
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 498
cannot start a transaction within a transaction
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 550
cannot start a transaction within a transaction
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 652
cannot start a transaction within a transaction
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 682
cannot start a transaction within a transaction
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 715
cannot start a transaction within a transaction
Warning: SQLite3::exec(): cannot start a transaction within a transaction in /usr/local/emhttp/plugins/disklocation/pages/sqlite_tables.php on line 744
cannot start a transaction within a transaction
Warning: SQLite3::query(): Unable to prepare statement: 1, no such table: settings_group in /usr/local/emhttp/plugins/disklocation/pages/system.php on line 1279

Fatal error: Uncaught Error: Call to a member function fetchArray() on bool in /usr/local/emhttp/plugins/disklocation/pages/system.php:1281 Stack trace: #0 /usr/local/emhttp/plugins/dynamix/include/DefaultPageLayout.php(1009) : eval()'d code(2): require_once() #1 /usr/local/emhttp/plugins/dynamix/include/DefaultPageLayout.php(1009): eval() #2 /usr/local/emhttp/plugins/dynamix/template.php(71): require_once('/usr/local/emht...') #3 {main} thrown in /usr/local/emhttp/plugins/disklocation/pages/system.php on line 1281

 

Link to comment
2 hours ago, SteveNeedsPizza said:

Getting an error when trying to run DiskLocation after installing(below) I tried removing and re-adding the plugin, same error.

Any help would be greatly appreciated!

 

Try to delete the database file, and then reinstall the plugin. Make sure to wait until the plugin installation is done, it might take some time.

Link to comment
3 hours ago, olehj said:

 

Try to delete the database file, and then reinstall the plugin. Make sure to wait until the plugin installation is done, it might take some time.

 

no luck :( also weirdly enough, right after installing the plugin my Unraid webgui broke (just said file not found). Had to reboot to get the webgui back, but still the same error for DiskLocation

Link to comment
On 3/14/2021 at 11:43 PM, SteveNeedsPizza said:

 

no luck :( also weirdly enough, right after installing the plugin my Unraid webgui broke (just said file not found). Had to reboot to get the webgui back, but still the same error for DiskLocation

Sorry I don't have so much time for support atm. but create a diagnostic file and attach it here after installing the plugin.

 

Make sure you are using Unraid 6.9.0 or above and not the developer edition (which is not supported at all).

Link to comment
  • 4 weeks later...

How do I create a drive configuration for the back of a 45 bay CSE-847?  I can only create one that has the 3 missing bays on the bottom right.  I need them on the top left.  It looks like this:CSE-847.thumb.jpg.8d4c3c55e16bd0fd0e6bb39df6ae7bfc.jpg

Capture.PNG

Edited by my.name.jeff
Picture didn't work
Link to comment

I'm not sure if anybody has noticed, but I was getting constant writes to my USB and then I checked and realized that this plugin was updating or something every minute so I was seeing this is my log.

/usr/local/emhttp/plugins/dynamix.unraid.net/include/UpdateFlashBackup.php update

So there was several of them so I was constantly sending updates via unraid.net plugin 

 

Used find -cmin -5 in my /boot directory and it pointed right at this plugin

 

World ending problem? No, Just was wondering why my log kept showing my USB getting backed up constantly when I know I hadn't made any changes to my settings. Lol

Link to comment
2 hours ago, Squid said:

IIRC there was a setting introduced in this plugin months ago that addressed this, where it did it's constant writes to RAM and only on stopping the array did it then save to the flash.

 

Ok, I'll check this later when I get home. I honestly haven't used this Plugin a lot so I didn't really spend a lot of time drilling into the settings. More or less I installed it, thought it was kinda neat and thought I'll play with this later. 

Link to comment
  • 1 month later...
  • 4 weeks later...
On 6/14/2021 at 5:06 AM, Zonediver said:

Is it possible to update this plugin for unraid 6.10?

On 6/15/2021 at 10:45 AM, Zonediver said:

...on my server... Thats why the request...

On 1/22/2019 at 2:58 PM, olehj said:

The plugin is only developed for the current stable Unraid branch and might lag a bit behind for new releases with new functions.

 

It's probably a bit much to ask for an update for a plugin to fix any issues on a very limited availability pre-release version of the OS.  

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.