[SOLVED] Cannot access dockers using custom:br0


gacpac

Recommended Posts

So I'm having this problem, Unraid can't ping any of the docker containers that are getting an IP from the router on br0, and stopping the docker engine applying, disabling Host access to custom networks and applying, then re-enabling Host access to custom networks applying and then starting the docker engine. But it still doesn't work unraid just gets Destination host Unreachable. this also doesn't seem like a very good solution because it would just break any time you need to reboot the host.
Has no one found a real solution?

Link to comment
  • 3 weeks later...

Please do realize that the thread is "solved" since its by docker design.

Docker will not allow the host to talk to containers that are bridged using macvlan (default)

I think 6.10rc1 allows ipvlan - which might work, so you should see if it solves the issue.

As for the issue with Docker host access shim failing, well, it should be discussed on a different thread as this one was just asking about access to containers on br0

 

Link to comment
  • 1 month later...

I have two Unraid instances. One is at home and I use a few docker containers over br0 with IP Addresses from my local network (pi-hole, unifi-controller etc). And also one that I manage remotely for a friend. 

Both have the same settings as far as I can tell and both are on v6.9.2, but on his I cannot use any container on br0 what so ever.

The interesting part is that I have Host access to custom networks: Disabled and it still works.

On the other one I've tried Enabled or Disabled with no success.

Edited by andreidelait
Link to comment
  • 2 months later...
On 10/30/2021 at 4:13 PM, ken-ji said:

Please do realize that the thread is "solved" since its by docker design.

How is this "solved" if it works when I enable this feature manually after startup?

It only doesn't work after a reboot when this option was enabled already because for whatever reason.

 

It's a feature implemented by Limetech for a reason and it works only in half of the cases.

 

How can this be submitted as a bug?

 

Running 9.10rc2

Edited by neuer_unraider
Added version
Link to comment
22 minutes ago, neuer_unraider said:

How is this "solved" if it works when I enable this feature manually after startup?

It only doesn't work after a reboot when this option was enabled already because for whatever reason.

 

It's a feature implemented by Limetech for a reason and it works only in half of the cases.

 

How can this be submitted as a bug?

 

Running 9.10rc2

I think when the thread was marked solved, we didn't have the host access setting yet. hence my comment.

I think the issue with the host access failing is due to a race condition that fails on certain cases (containers starting up before networking is ready?) @bonienl would have a better idea.

 

I do think enabling ipvlan on the latest versions would solve the issue with access over the same network interface. As for bug reports, just file one with the server diagnostics in both cases - working during startup and not to compare with.

 

Link to comment
  • 2 months later...

I'm also still randomly encountering this problem. This issue doesn't seem to be finally solved...

I have "Allow access to host networks" checked/active.

My Home Assistant Docker (host network) sometimes looses connection to some other docker containers on different vlans (e.g. ispyagentdvr on custom br0.6 network, motioneye on custom br0.5 network, frigate on custom br1.15 network).

Stopping and starting the docker service always solves this issue. A reboot of unraid sometimes solves this issue, sometimes it's raising this issue. I have two NICs and four VLANs.

Link to comment
  • 3 weeks later...
  • 2 weeks later...

This question was solved?
But I checked "allow access to host networks" enable

It's still can't ping unraid to docker:

192.168.10.11      unraid

192.168.10.15     docker (br0)

 

"allow access to host networks" No use at all

 

图像 1.png

Edited by wdnaser
Link to comment
  • 5 months later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.