Jump to content
binhex

[Support] binhex - Jellyfin

62 posts in this topic Last Reply

Recommended Posts

Overview: Support for Docker image arch-jellyfin in the binhex repo.

Application: Jellyfin - https://github.com/jellyfin/jellyfin

Docker Hub: https://hub.docker.com/r/binhex/arch-jellyfin/

GitHub: https://github.com/binhex/arch-jellyfin

 

If you appreciate my work, then please consider buying me a beer 😁

 

btn_donate_SM.gif&key=57f6b617e37a194c35

 

For other Docker support threads and requests, news and Docker template support for the binhex repository please use the "General" thread here

Share this post


Link to post

Hi binhex, great container!

Does it have the ability to use vaapi for hardware transcoding?  I mapped the --device and such as I do in Emby but it would never play or it falls back to software transcoding.  Probably something I'm doing wrong but wanted to check with you.

Share this post


Link to post
Hi binhex, great container!
Does it have the ability to use vaapi for hardware transcoding?  I mapped the --device and such as I do in Emby but it would never play or it falls back to software transcoding.  Probably something I'm doing wrong but wanted to check with you.
Sorry I have no idea when it comes to hardware transcoding as I don't have a discrete gpu.

Sent from my EML-L29 using Tapatalk

Share this post


Link to post
1 minute ago, binhex said:

Sorry I have no idea when it comes to hardware transcoding as I don't have a discrete gpu.

Sent from my EML-L29 using Tapatalk
 

No worries!  Looks like you already have a ffmpeg build that supports vaapi.  Just needed intel drivers so I submitted a pull request.  Tested on Unraid server with intel 655 iGPU.

Share this post


Link to post

Hi, I just installed it and let it run. My docker image is now 100% and I can't find a way to change the cache/thumbnails settings.

 

Is there a place I can change that to go to my cache drive instead of the docker image? (I'm assuming that's it as it slowly filled up after an hour or two of it being installed).

 

It is, just checked:

Name Container Writable Log --------------------------------------------------------------------- binhex-jellyfin 8.32 GB 6.17 GB 46.9 MB

Edited by RonUSMC

Share this post


Link to post

this is great thanks.  

by default jellyfin settings and metadata is not being saved after container restarts.  cant find the settings in jellyfin to remap the directories to /config .  

Share this post


Link to post
7 hours ago, greyv said:

this is great thanks.  

by default jellyfin settings and metadata is not being saved after container restarts.  cant find the settings in jellyfin to remap the directories to /config .  

 

That doesn't sound correct. A restart doesn't delete anything. You should post your docker run command.

Share this post


Link to post

It seems that jellyfin saves files in a /tmp directory not /config. So changing that parameter in the docker file should fix it

Share this post


Link to post

@binhex I'm seeing the same issue mentioned above:

 

Jellyfin appdata template

image.png.60594dc52e417a3b871a4f643d0d73cc.png

 

Jellyfin appdata

image.png.44bd24e17d411d7e858650885aca1ad8.png

 

For comparisons sake, here is Emby appdata

image.png.c595b1a38deac2f5ee5089a4e3ec6315.png

 

Run command (formatted)

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d 
--name='binhex-jellyfin' 
--net='br0' 
--ip='192.168.1.212' 
-e TZ="Australia/Perth" 
-e HOST_OS="Unraid" 
-e 'TCP_PORT_8096'='8096' 
-e 'UMASK'='000' 
-e 'PUID'='99' 
-e 'PGID'='100' 
-v '/mnt/disks/downloads/_temp/emby-test/media/':'/media':'rw' 
-v '/mnt/disks/downloads/_temp/emby-test/tv/':'/media-tv':'rw,slave' 
-v '/mnt/disks/downloads/_temp/emby-test/movies/':'/media-movies':'rw,slave' 
-v '/mnt/disks/downloads/_temp/emby-test/music/':'/media-music':'rw,slave' 
-v '/mnt/user/appdata/binhex-jellyfin':'/config':'rw' 
'binhex/arch-jellyfin' 
c727eb966e562c0f8c20a88bbdc36eada63cd79edbdf53b9d29303c9c9602138

 

Share this post


Link to post
52 minutes ago, greyv said:

It seems that jellyfin saves files in a /tmp directory not /config. So changing that parameter in the docker file should fix it

sorry guys my screw up, forgot to change path for jellyfin data env var, its fixed now and is building a new image, sadly this will of course mean that when you pull the new image down it will re-create the container and thus you will looose any config (as its currently incorrectly located in the container).

  • Like 1
  • Upvote 4

Share this post


Link to post

No worries. This is what Day 1 software is all about. :) Will the new image be available shortly?

Share this post


Link to post
No worries. This is what Day 1 software is all about.  Will the new image be available shortly?
Yes I would guess within the hour (currently building)

Sent from my EML-L29 using Tapatalk

Share this post


Link to post

New image seems to be working as intended and can see appdata folder being populated as expected, thanks!

Share this post


Link to post

Thanks for this very excellent template! Under Settings > Dashboard > Server > Transcoding the ffmpeg path is blank, should I be concerned about that or is it not a big deal anyway?

Share this post


Link to post
29 minutes ago, Trunkton said:

Thanks for this very excellent template! Under Settings > Dashboard > Server > Transcoding the ffmpeg path is blank, should I be concerned about that or is it not a big deal anyway?

tbh i dont know, but i can assure you that ffmpeg is included and is on the path (located in /usr/bin/) so should be picked up by jellyfin, if it isnt then feel free to set that to /usr/bin/ffmpeg

Share this post


Link to post

Anyone have working solution for letsencrypt subfolder config?

I have tried modify default emdy config but I have no luck.

Share this post


Link to post
On 2/5/2019 at 6:04 AM, binhex said:

tbh i dont know, but i can assure you that ffmpeg is included and is on the path (located in /usr/bin/) so should be picked up by jellyfin, if it isnt then feel free to set that to /usr/bin/ffmpeg

I don't know if I am just a complete idiot (which is probably the case here) but I browsed the contents of /usr/bin/ and I don't have a ffmpeg directory in there at all.  

 

I also looked in the jellyfin appdata, there is a ffmpeg folder in there but its blank.  I went and pulled down a build of ffmpeg and mapped the container to that directory, tried pointing the transcode directory to the new folder and I got an error message stating that the folder doesn't contain ffprobe (which it certainly does)

 

So not sure what the issue is....

Share this post


Link to post
46 minutes ago, CoZ said:

but I browsed the contents of /usr/bin/ and I don't have a ffmpeg directory in there at all.  

its not a directory, its a file, and its located in /usr/bin/ in the container, output from my a running jellyfin container:-

 

sh-5.0# cd /usr/bin
sh-5.0# ls -al ff*
-rwxr-xr-x 1 root root 260000 Nov  6 18:27 ffmpeg
-rwxr-xr-x 1 root root 133048 Nov  6 18:27 ffplay
-rwxr-xr-x 1 root root 157608 Nov  6 18:27 ffprobe
sh-5.0# ffmpeg
ffmpeg version n4.1 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 8.2.1 (GCC) 20180831
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-nvdec --enable-nvenc --enable-omx --enable-shared --enable-version3
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
sh-5.0#

 

 

Edited by binhex

Share this post


Link to post
On 2/11/2019 at 11:43 AM, CoZ said:

I don't know if I am just a complete idiot (which is probably the case here) but I browsed the contents of /usr/bin/ and I don't have a ffmpeg directory in there at all.  

 

I also looked in the jellyfin appdata, there is a ffmpeg folder in there but its blank.  I went and pulled down a build of ffmpeg and mapped the container to that directory, tried pointing the transcode directory to the new folder and I got an error message stating that the folder doesn't contain ffprobe (which it certainly does)

 

So not sure what the issue is....

For what it's worth, I noticed the same thing (the path was not populated by default) but it does exist in my container.  

Share this post


Link to post

So apparently the "This setting can not be blank" on the JellyFin transcode settings page is a bug.  Confirmed from the Github Jellyfin page.  It's supposed to be fixed soon.  My apologies to @binhex for doubting you.  I just searched everywhere for the ffmpeg and couldn't find it on my system.  Even pulling down a new ffmpeg build and mapping the container to the new directory of the ffmpeg installed still resulted in an error.  So, it's on Jellyfin's "end" where the issue lies.

Share this post


Link to post
3 hours ago, CoZ said:

I just searched everywhere for the ffmpeg and couldn't find it on my system. 

you wont find it on your 'system' because its not available on the host, its installed and running in the container, if you are unsure what that really means (and you would like to find out) then i would encourage you to do some googling around docker basics and get up to speed with how docker works, otherwise take my word for it, t is installed and it is available to jellyfin :-).

Share this post


Link to post
4 hours ago, binhex said:

you wont find it on your 'system' because its not available on the host, its installed and running in the container, if you are unsure what that really means (and you would like to find out) then i would encourage you to do some googling around docker basics and get up to speed with how docker works, otherwise take my word for it, t is installed and it is available to jellyfin :-).

 

Yea, you're correct, I've already apologized.  I was under the assumption it would be installed onto that actual UnRaid OS.  So, that is where I went searching initially.  When I couldn't find the ffmpeg file and then the error message from Jellyfin GUI saying that there was no FFMPEG installed, I thought something was 'missing'.

Share this post


Link to post
 
Yea, you're correct, I've already apologized.  I was under the assumption it would be installed onto that actual UnRaid OS.  So, that is where I went searching initially.  When I couldn't find the ffmpeg file and then the error message from Jellyfin GUI saying that there was no FFMPEG installed, I thought something was 'missing'.
Honestly no apology required, I wonder if you would be so kind as to link to the bug (issue)

Sent from my EML-L29 using Tapatalk

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.