Jump to content
linuxserver.io

[Plugin] Linuxserver.io - Unraid Nvidia

1664 posts in this topic Last Reply

Recommended Posts

If one wanted to donate to show appreciation for the work the Dev's have done to make the Nvidia patch possible, where could one do that?

 

I just started using the Nvidia patch of unraid with the 6.8.0 build and I couldn't tell you enough how awesome it is. I'd like to show my appreciation to the developers.

Share this post


Link to post
11 minutes ago, zepheris said:

If one wanted to donate to show appreciation for the work the Dev's have done to make the Nvidia patch possible, where could one do that?

 

I just started using the Nvidia patch of unraid with the 6.8.0 build and I couldn't tell you enough how awesome it is. I'd like to show my appreciation to the developers.

https://www.linuxserver.io/donate

Share this post


Link to post
Out of interest how much work does it take to create a new version? Is there much to it? How many man hours?  

 

Keep Smiling 

 

 

 

A lot of time is put into it.@CHBMB put up a post when 6.8.0 was released on the whole process and why there was such a long delay between LT6.8.0 and LSIO6.8.0, take a look at it. Think he said it was several days to weeks of work in reverse engineering and fixing, modification, updates between versions, etc. He does a lot for this.

 

Edit: Post 1474 is the short and sweet version. Post 2 is the background on how the process was achieved.

 

Sent from my iPhone using Tapatalk

 

Share this post


Link to post

For those of us that upgraded without first considering we would lose transcoding, all you have to do is downgrade back to 6.8.0.  Literally takes 30 seconds and a reboot.  Just go to Tools/UpdateOS and go from there.

 

Worked for me.

Share this post


Link to post

I only upgraded because of Firefox. I saw several news articles about Firefox needing to be updated for security. So I'll deal with CPU trans-coding for now and patiently wait for our hero's to update the nvidia drivers at their own time. I can still watch my media and I went with out GPU trans-coding for the longest time, until I had a spare graphics card to toss into a 
 

Quote

mozilla-firefox: version 72.0.1 (CVE-2019-17026, CVE-2019-17015, CVE-2019-17016, CVE-2019-17017, CVE-2019-17018, CVE-2019-17019, * CVE-2019-17020, CVE-2019-17021, CVE-2019-17022, CVE-2019-17023, CVE-2019-17024, CVE-2019-17025)

 

Edited by seidler82

Share this post


Link to post
2 minutes ago, seidler82 said:

I saw several news articles about Firefox needing to be updated for security.

Fair enough, but IMO if booting into unRaid's GUI, then should be only using the built-in browser for accessing the GUI itself, and not for random web surfing.  It's there only for that reason.

Share this post


Link to post
31 minutes ago, danktankk said:

For those of us that upgraded without first considering we would lose transcoding, all you have to do is downgrade back to 6.8.0.  Literally takes 30 seconds and a reboot.  Just go to Tools/UpdateOS and go from there.

 

Worked for me.

i couldn't get it to downgrade at all. 

Share this post


Link to post
36 minutes ago, kingpin said:

i couldn't get it to downgrade at all. 

Maybe ask around about that as it was literally one click and a reboot.  Then I did have to go back in and reconfigure Plex to place nice with my Nvidia quadro.

Share this post


Link to post
48 minutes ago, seidler82 said:

I only upgraded because of Firefox. I saw several news articles about Firefox needing to be updated for security. So I'll deal with CPU trans-coding for now and patiently wait for our hero's to update the nvidia drivers at their own time. I can still watch my media and I went with out GPU trans-coding for the longest time, until I had a spare graphics card to toss into a 
 

 

I don't use Firefox at all unless I use the built-in Firefox in unraid gui.  But for day to day use, I just boot up to the cli login and VPN to it.

 

At any rate, it was just a suggestion that I found worked for me and wanted to share.  Whatever works for you is good too! :)

Share this post


Link to post

I'll try and take a look at this tomorrow.  Main issue at the moment is I need to sort out the Wireguard OOT drivers.

 

Any new OOT driver is a PITA

  • Like 5
  • Thanks 4

Share this post


Link to post
6 hours ago, leeknight1981 said:

Out of interest how much work does it take to create a new version? Is there much to it? How many man hours? 


Keep Smiling 

Go back a few pages, there was a detailed overview

Share this post


Link to post
On 1/14/2020 at 6:26 PM, CHBMB said:

I'll try and take a look at this tomorrow.  Main issue at the moment is I need to sort out the Wireguard OOT drivers.

 

Any new OOT driver is a PITA

Thanks for your work.  It breathed new life into my server.  Feel like LimeTech should have these drivers built into their releases tbh.

Share this post


Link to post

Really appreciate all of your hard work on this! Its an essential part of my setup and works great.

Share this post


Link to post

Remember, the team has their own lives, they have day jobs, families and friends heck some are not even in Development or IT in their professional lives.

We're all pretty much hobbiest here, and this is being worked on by the goodness of their hearts. I'm OCD when it comes to updating things but you can't just expect everyone to drop everything when a new release hits to be patched.

It will be ready when it's done.

Thank you guys for all the hard work you put into this project

Sent from my SM-G975U using Tapatalk

Share this post


Link to post
2 minutes ago, AnnabellaRenee87 said:

Remember, the team has their own lives, they have day jobs, families and friends heck some are not even in Development or IT in their professional lives.

We're all pretty much hobbiest here, and this is being worked on by the goodness of their hearts. I'm OCD when it comes to updating things but you can't just expect everyone to drop everything when a new release hits to be patched.

It will be ready when it's done.

Thank you guys for all the hard work you put into this project emoji3590.png

Sent from my SM-G975U using Tapatalk
 

Very well said.  If people are in such a rush, do the research and figure out how to do it yourself. I truly appreciate all the work that goes into this and the time these individuals take away from "life" to do this.

 

Instead of complaining, try thanking them for this.

Share this post


Link to post
Very well said.  If people are in such a rush, do the research and figure out how to do it yourself. I truly appreciate all the work that goes into this and the time these individuals take away from "life" to do this.
 
Instead of complaining, try thanking them for this.



You both really just encapsulated what I was trying to say a few days ago. Thank you to all who work on this project.


Sent from my iPhone using Tapatalk

Share this post


Link to post
On 12/31/2019 at 4:38 PM, Timmy said:

Hey Guys. im trying to get my P2000 working for plex transcoding. i just installed the Unraid Nvidia plugin and it gets stuck on the Updating available builds screen.  any ideas?

 

im running 6.8.0 image.thumb.png.c6bd2ebc15d82d8930a886453094ced3.png

EXACT same issue and it's annoying. Did you find a fix?

edit: Nevermind, it wasn't working for like 3 months but it magically fixed itsself? 

Edited by Hikakiller

Share this post


Link to post

@Hikakiller

 

This works well for 6.8.0 with no issues at all for the p2000.  I know this because I own one and had to downgrade from 6.8.1 due to me thinking unraid nvidia would be done as quickly as the release.  No worries at all and im all set at 6.8.0 (again).  Hopefully, this will just be included in future releases of UNRAID to save future hassles...  I cant think of any reason why it wouldn't be.

 

Maybe then some other good work can be done to accomplish other things like maybe trying to fix tables for those stubborn nvme drives that dont pass through worth a crap for VM barebone usage....  Doubtful, but just saying....

 

If you are using 6.8.1 you will not get it to work until it is released for that version of unraid.  downgrade to 6.8.0

 

Edit:  i see you fixed this.  Good deal.

Edited by danktankk

Share this post


Link to post
5 hours ago, CHBMB said:

v6.8.1 being uploaded.

Thank you. Donated $10 for your beer! Keep up the good work! It is greatly appreciated.


Cheers!

Share this post


Link to post

Is it possible there was a regression for the RTL8125 driver in the Unraid Nvidia 6.8.1 build? I am running into the identical issue I had on the 8.8.0-rc5 build. Reverting to Unraid Nvidia 6.8.0 has my NIC working correctly again.

 

Thanks again for all the work put into this project.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.