Jump to content
a24425311

[Solved] Enquiry on unRaid Rsync Server (Syno Hyperbackup Client)

8 posts in this topic Last Reply

Recommended Posts

Hi All,

 


Deleted and Redo, problems solved.

ūüė¨

-------

unRaid Version: 6.6.6

HP Microserver n54l

5 HDD 4 + 1 Parity 3TB X 5 Build (No Cache)

 

I have recently set up a Rsync server on unRaid, it worked like an 1 hour until I moved some files on the destination folder, I don't know why and how this affects the server but now terminal couldn't read rsyncd.conf, it returns
cat: /etc/rsyncdÔĽŅ.conf: No such file or directory¬†

 

rsyncd.conf is already placed, the client side couldn't communicate unRaid neither.

image.png.f73514007a853ae60a1430d2ea24d973.png

 

image.png.1bbcb4b9549e73f2836342da3ca547ba.png

 

The guideline I followed
https://forums.unraid.net/…/24282-solved-problem-with-sync…/

 

Any thoughts?

 

Thanks

 

 

 

unraid-diagnostics-20190210-2235.zip

unraid-syslog-20190210-2235.zip

Edited by a24425311

Share this post


Link to post

No need to attach syslog since it is already included in diagnostics zip.

 

Your link is broken. Can you find that guideline again?

 

Your go file seems similar to something I had (still have) setup from back on Unraid v4.7. I don't know where to find the guideline I used then either. I think it was written by one of the moderators we seldom see anymore.

 

I haven't tested it in a while, but it is still in place and my /etc/rsyncd.conf isn't empty. I don't know if it matters but it looks like your go file has that extra rsync stuff on the same line as the emhttp stuff. You might put a line break between them (after the &).

 

I can't tell from your diagnostics what might be in your /boot/custom folder or if you even have one.

 

 

 

 

 

 

 

 

Share this post


Link to post
9 minutes ago, trurl said:

Was this it? I think that is the one I used.

 

https://forums.unraid.net/topic/2100-rsync/

 

I followed the guide above.

 

OP was followed your link though.

 

Let me check my GO file first (but does it matter? since the resync conf file couldn't read by terminal in the first place?)

 

Thanks.

 

Edited by a24425311

Share this post


Link to post

The reason for putting the script in go is so it will get executed at boot and put the conf file in /etc.

 

/etc is in RAM so any change made there must be reapplied at boot.

 

Share this post


Link to post

Here are screen caps from MC.

 

Rsyncd.conf

image.thumb.png.f992e9a060e4d94e44ca2c2f25cfb651.png

 

S20-init.rsyncd

image.thumb.png.e30fe79b45579af38eb1571b158d9522.png

 

GO

image.thumb.png.d004a6af939fbc419522568848fcf1d6.png

 

Folder Path

image.png.681bf7be9af9a456f601de8e94d64a85.png

Edited by a24425311

Share this post


Link to post

The last line in S20-init.rsyncd is where it gets put in /etc obviously, but I can't think of any reason why it would have been removed later. I'm a little out of my depth with some of this, since I was just following the guide myself.

Share this post


Link to post

I have resolved the problem by simply delete everything I have created and redo the whole process, done!

 

Cheers

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now