[Support] binhex - PrivoxyVPN


binhex

395 posts in this topic Last Reply

Recommended Posts

  • Replies 394
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@binhex, this absolutely works on your container. I am currently using this setup successfully with no major issues. I wanted a VPN "gateway" for specific other containers, where all their traffic cou

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I don't know of a way to use a proxy with Plex either, but you can do what I have done with some of my containers and run *all* of the Plex traffic through a VPN container. Since you won't be doing re

Posted Images

40 minutes ago, kbbeer said:

Supervisord.log

 

AUTH: Received control message: AUTH_FAILED,LICENSE: Access Server license failure: maximum concurrent_connections exceeded (2)

this is not a privoxy error, this is a openvpn server message caused by reaching the concurrent licence limit for the openvpn server you are connecting to.

Link to post

Hi !

I recently noticed that the Unraid main Docker page showed that "apply update" link was "unavailable" for the binhex-privoxyvpn Docker container (under the "version" column).

If anyone is interested in how to fix it:

  • click on the container icon, select "edit"
  • on the "update container" page, activate the "advanced view"
  • under "Docker Hub URL" field, change "https://registry.hub.docker.com/u/binhex/arch-privoxyvpn/" to "https://registry.hub.docker.com/r/binhex/arch-privoxyvpn/" (note the "/r" instead of the "/u")
  • click apply
  • on the main Unraid Docker page, enable the "advanced view" (once again) and refresh the page
  • click on "force update"
  • once finished, click on the "check for updates" button at the bottom of the Unraid main Docker page (the "unavailable" alert should be gone)

I hope this helps.

Best

OP

Link to post
  • 1 month later...

Hey all,

 

I installed privoxyvpn and also played arround with delugevpn and qbittorrentvpn, all ofc binhex.

I put the files in the openvpn folder, vpn works. Now i want to pass it trough to another container. Spaceinvaderone has a video about it, I enabled privoxy and entered the proxy information in the webinterface of the container. I also tried another method;

I also tried to add the port of the container I want to pass trough to the binhexvpn container. In the container I want to pass tough, put the network to none and put "--net=container:binhex-privoxyvpn" to the extra parameters. I think it works, "curl ifconfig.io" in the console and I get the vpn ip.

 

So, here is the thing; I also have pihole running and set as dns on the router, so I can see the domains which get requested. Lets say I want to passtrough jackett (this is a good one to test, because it pings websites I otherwise dont use, so easy to spot). So both methodes mentioned before, when I open the webinterface of the passed trough container (jackett), I can see every domain it want to access in pihole. In my logic this shouldn't happen because of the vpn connection, am I misconfiguring or misunderstanding something?

 

Thanks,

 

Edit: I tried entering the proxy information in my browser, and check what my ip is. When I enter the infomation of PrivoxyVPN it doesn't work. When I try the same for delugevpn it does work. (server ip and port 8118)

 

Edit: removed and deleted everything. Tried it again, and it works.

Edit: it worked for a while and started leaking everything again, trying the update now.

 

Edited by ZekerPixels
Link to post
1 hour ago, binhex said:

IMPORTANT:- As part of the tightening up if you run multiple containers through a single vpn container then please ensure you define all web ui ports (if more than 1 port then use comma to separate) for all routed containers in 'ADDITIONAL_PORTS' env var for the vpn container.

 

Hi, thanks for the update but I cannot find anywhere that says ADDITIONAL_PORTS ?  This is how I have things setup currently.

image.thumb.png.d9a4c68b3df358a9242fb34508ce1e62.png

 

 

Link to post
5 minutes ago, mbc0 said:

Hi, thanks for the update but I cannot find anywhere that says ADDITIONAL_PORTS ?  This is how I have things setup currently.

looks like your template is out of date, sadly changes to the template do not automatically get pushed out, so you will need to add in the env var, give it a key name of 'ADDITIONAL_PORTS' and value of the ports you want accessible.

Link to post
On 2/26/2021 at 2:22 AM, binhex said:

looks like your template is out of date, sadly changes to the template do not automatically get pushed out, so you will need to add in the env var, give it a key name of 'ADDITIONAL_PORTS' and value of the ports you want accessible.

How do we do this ?

Link to post
On 4/12/2020 at 7:58 PM, Jorgen said:

For what it’s worth, I just set up binhex jackett using the network of binhex delugevpn following spaceinvader’s video. Can access jacket UI without problems and have confirmed it is using the VPN tunnel.

 

And I left the port mappings in place for jackett.

2nd this,

 

I've never been able to access SAB's webui though wieguard remote tunnel access, but just read this and swapped from binhex deluge vpn to binhex privoxy. Entered the exact same settings and it works flawlessly :) 

Link to post
20 hours ago, Philby1975 said:

How do we do this ?

image.png.4cbf05a29cd95aeb226b3d98f27d043b.png

 

The template is updated for me, but if it still isn't for you, you click on "Add another path, variable, etc" at the bottom of the docker page. Select variable, the name you want the variable to have on the docker page, the key, and the ports. I just use it for Jackett so I think the one port is done correctly.

Link to post
On 2/25/2021 at 4:22 PM, binhex said:

looks like your template is out of date, sadly changes to the template do not automatically get pushed out, so you will need to add in the env var, give it a key name of 'ADDITIONAL_PORTS' and value of the ports you want accessible.

Thanks, I will try this

Link to post

@binhex Sorry to tag you, but I don't get it. Yes, I have added the ADDITIONAL_PORTS and it works, but I'm questioning if the pass trough really uses the vpn.

Incidentally you mentioned an update, so I forced the update because it maybe solved the issue I had, but unfortunately it didn't make a difference. I have pihole set as a dns in the router and I can hide everything from it using the vpn e.g. with the provided vpn app. But pihole keeps showing domains comming from the passed through container, e.g. opening the webUI of binhex-jackett gets me a whole list of domains in pihole, I my mind it shouldn't do that. right? If I do thesame for eg a firefox docker, nothing showes up in pihole, as expected. when opening the jackett console and ping a website, it also doesnt show up. I dont understand why this would differ openinging the webui of jackett and maybe others.

 

I have also tried it with your other vpn dockers, which leads to the same result. (I understand it uses the same code, so that wouldn't be a surprise) I'm only talking about the pass trough, everything to do with torrents is hidden by the vpn. Just to be sure I didn't mess something up, I removed everything, the images, appdata and started from scratch. Basically I'm following along with SpaceinvaderOne, doing this; https://www.youtube.com/watch?v=znSu_FuKFW0 and in addition adding to the ADDITIONAL_PORTS. as also described in your VPN FAQ A24.

 

- I get the vpn setup, credentials and openvpn files. "curl ifconfig.io", shows the vpn ip.

- added the port to ADDITIONAL_PORTS and pass trough like also showed by mbc0 a couple of posts back, because otherwise it doesnt know what to with it.

- checking the passed trough container e.g. "binhex-jackett" with network set as "--net=container:binhex-privoxyvpn" with "curl ifconfig.io", also shows the vpn ip.

- When I access the passed trough container, pihole directly shows all the domains it accesses.

 

Edited by ZekerPixels
Link to post
54 minutes ago, ZekerPixels said:

@binhex Sorry to tag you, but I don't get it. Yes, I have added the ADDITIONAL_PORTS and it works, but I'm questioning if the pass trough really uses the vpn.

Incidentally you mentioned an update, so I forced the update because it maybe solved the issue I had, but unfortunately it didn't make a difference. I tried different things and everything passed trough keeps showing up in pihole, like previously mentioned. I have pihole set as a dns in the router and I can hide everything from it using the vpn e.g. with the provided vpn app. But pihole keeps showing all domains, the passed trough container accesses. e.g. binhex-jackett gets me a whole list of domains in pihole, I my mind it shouldn't do that. right? Or am I viewing it the wrong way and not understand how it works.

 

I have also tried it with your other vpn dockers, which leads to the same result. (I understand it uses the same code, so that wouldn't be a surprise) I'm only talking about the pass trough, everything to do with torrents is hidden by the vpn. Just to be sure I didn't mess something up, I removed everything, the images, appdata and started from scratch. Basically I'm following along with SpaceinvaderOne, doing this; https://www.youtube.com/watch?v=znSu_FuKFW0 and in addition adding to the ADDITIONAL_PORTS. also described in your VPN FAQ A24.

 

- I get the vpn setup, credentials and openvpn files. "curl ifconfig.io", shows the vpn ip.

- added the port to ADDITIONAL_PORTS and pass trough like also showed by mbc0 a couple of posts back, because otherwise it doesnt know what to with it.

- checking the passed trough container e.g. "binhex-jackett" with network set as "--net=container:binhex-privoxyvpn" with "curl ifconfig.io", also shows the vpn ip.

- When I access the passed trough container, pihole directly shows all the domains it accesses.

 

ok lets start with some screenshots of the settings screens, please attach 'edit' screens for privoxyvpn and jackett, a quesiton for you, do you have jackett set to use a socks proxy or http proxy by any chance?.

Link to post
40 minutes ago, binhex said:

ok lets start with some screenshots of the settings screens, please attach 'edit' screens for privoxyvpn and jackett, a quesiton for you, do you have jackett set to use a socks proxy or http proxy by any chance?.

 

I didn't want to post a huge picture collection here, so i uploaded them to https://imgur.com/a/qGysAeM.

In jackett the proxy is set to disabled, so it should take the network from unraid which point to the privoxy container.

To be sure it started up the right way, I rebooted the server, started privoxyvpn and waited till it said listening to port before starting jackett.

Edited by ZekerPixels
Link to post
9 minutes ago, ZekerPixels said:

 

I didn't want to post huge pictures here, so i uploaded them to https://imgur.com/a/qGysAeM.

the config looks ok, can you try removing in jackett the entry for the proxy URL and proxy port, then restart the jackett container and monitor again. i know its set to disabled but i just want to ensure its set to NOT use proxy

Link to post
1 hour ago, binhex said:

the config looks ok, can you try removing in jackett the entry for the proxy URL and proxy port, then restart the jackett container and monitor again. i know its set to disabled but i just want to ensure its set to NOT use proxy

 

I removed the privoxy container by accident, also removed the jackett container and also deleted the folders in appdata. reinstalled both using thesame settings in the template as previous and put the openvpn files back. When installed, let it run for a bit and restarted, stopped both containers and made sure privoxyvpn is started first. A quick check in the console returns the vpn ip. I did not change any other settings. (buy default proxy is det to disabled in jackett)

 

Now on my pc using the firefox browser, I go to ip:9117 and check pihole and doesnt show any of the indexers now. so, now i click on add indexer, where you get the big list of indexers. I dont do anything else and check pihole, pihole now lists every domain 0 to z from jackett. If a indexer is added, and i access the web ui, pihole just list the added indexer.

 

Edited by ZekerPixels
Link to post

Should the Additional Ports Variable be instead of the settings below or as well as? my emby docker can no longer communicate with xteve and I am wondering if this is why?

 

Thank you

 

image.png.6d5b344a21f46647e9816d5fc607ad32.png

Link to post

Thanks  @binhex I have read that and as I understand it I must make sure the web/ui ports are in the additional_ports variable which they are.

 

Jackett - 9117

Deemix - 6595

Deluge - 8112

 

the only other explanation was the localhost but I am not connecting to the dockers from within the privoxy network so that doesn't apply.

 

I was able to connect before so it is due to the new ADDITIONAL_PORT variable, if I remove it I can access them again.

Link to post
3 minutes ago, mbc0 said:

I was able to connect before so it is due to the new ADDITIONAL_PORT variable, if I remove it I can access them again.

that makes no sense to me, creating that variable means that additional allow iptable rules are created, very bizare!. are you sure you dont have any proxy settings in place here?, if so remove them.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.