Jump to content
linuxserver.io

[Support] Linuxserver.io - Unifi-Controller

624 posts in this topic Last Reply

Recommended Posts

12 minutes ago, RodWorks said:

So, just wondering if anyone has experienced this kind of issue or if anyone has any idea what I'm doing wrong?  Why would the initial setup work but then lose connection days later with the AP's?

The adoption loops usually happen when the device loses contact with the inform host.  The device continues to function, you just lose the connection between it and the controller. 

 

I have always been able to fix it (only happened a couple of times) by connecting to the devices via SSH and setting the inform host from the CLI but you said you could not SSH into the APs for some reason. 

 

set-inform http://ip-of-controller:8080/inform

 

Also, do you have the 'Overide inform host with controller hostname/IP' checkbox selected in the Controller Settings?  This is pretty much mandatory with this container.

 

 

Share this post


Link to post
27 minutes ago, Hoopster said:

 

Also, do you have the 'Overide inform host with controller hostname/IP' checkbox selected in the Controller Settings?  This is pretty much mandatory with this container.

 

 

No I did not, so I need to put in the ip address of my server:8443 above that?

Share this post


Link to post
Just now, RodWorks said:

No I did not, so I need to put in the ip address of my server:8443 above that?

No, you need to go into the controller webUI and select that override option in the controller settings.

Share this post


Link to post
20 minutes ago, Hoopster said:

No, you need to go into the controller webUI and select that override option in the controller settings.

Ok, but it gives me a warning saying I need to make sure that host name is correct or I won't be able to connect.

 

By default it has unifi.yourdomain.com  . Do I need to change that or just check the box and leave the default address?

Screen Shot 2019-11-12 at 5.03.42 PM.png

Share this post


Link to post
2 minutes ago, RodWorks said:

Ok, but it gives me a warning saying I need to make sure that host name is correct or I won't be able to connect.

 

By default it has unifi.yourdomain.com  . Do I need to change that or just check the box and leave the default address?

Screen Shot 2019-11-12 at 5.03.42 PM.png

Well, you certainly don't want to override it with unifi.yourdomain.com :)

 

The Controller Hostname/IP should contain the IP address of your unRAID server if you are running the container in bridge mode on the host server (some find they need to run it in host networking mode initially to even do adoption).  If you have the container assigned its own IP address on a VLAN or custom network, you should enter that IP address.

 

Mine is in bridge mode on the host unRAID server so I have the unRAID IP address as the Controller host.

 

image.png.1d7570d34e6a866bb1768844982b74e8.png

Share this post


Link to post
Well, you certainly don't want to override it with unifi.yourdomain.com
 
The Controller Hostname/IP should contain the IP address of your unRAID server if you are running the container in bridge mode on the host server (some find they need to run it in host networking mode initially to even do adoption).  If you have the container assigned its own IP address on a VLAN or custom network, you should enter that IP address.
 
Mine is in bridge mode on the host unRAID server so I have the unRAID IP address as the Controller host.
 
image.png.1d7570d34e6a866bb1768844982b74e8.png

I haven’t been having any issues but if this is “standard practice” should I go ahead and consider doing it for good measure?

I googled the set inform hosts just looking into what it done... as mentioned a few posts above mentioned SSH into each AP. Is setting the inform host via SSH on each AP the same as setting the inform host in the actually controller settings

Share this post


Link to post
2 minutes ago, blaine07 said:

I haven’t been having any issues but if this is “standard practice” should I go ahead and consider doing it for good measure?

When first switching to this container from the prior LSIO UniFi container, many of us found that adoption loops could be avoided by selecting the override option.  Perhaps in your network it is not required, but, it doesn't hurt anything either if things are properly configured.

 

4 minutes ago, blaine07 said:

I googled the set inform hosts just looking into what it done... as mentioned a few posts above mentioned SSH into each AP. Is setting the inform host via SSH on each AP the same as setting the inform host in the actually controller settings emoji848.png

You do not have to SSH into each device and set the inform host if everything is working properly.  The override function is basically doing the same thing.  If there is an inform host set on the device, it will override it with the Controller hostname/IP so, in essence it is setting the inform host.

 

When I set up my system initially, I did SSH in and set the inform host manually and I DID NOT have the override option selected.  However, when I moved to this container, I found the override option selection to be a necessity as I was experiencing adoption loops  YMMV.

Share this post


Link to post
1 hour ago, Hoopster said:

Well, you certainly don't want to override it with unifi.yourdomain.com :)

 

The Controller Hostname/IP should contain the IP address of your unRAID server if you are running the container in bridge mode on the host server (some find they need to run it in host networking mode initially to even do adoption).  If you have the container assigned its own IP address on a VLAN or custom network, you should enter that IP address.

 

Mine is in bridge mode on the host unRAID server so I have the unRAID IP address as the Controller host.

 

image.png.1d7570d34e6a866bb1768844982b74e8.png

Got it. Thanks

 

Hopefully this solves my issue.

Edited by RodWorks

Share this post


Link to post
You do not have to SSH into each device and set the inform host if everything is working properly.  The override function is basically doing the same thing.  If there is an inform host set on the device, it will override it with the Controller hostname/IP so, in essence it is setting the inform host.

 

When I set up my system initially, I did SSH in and set the inform host manually and I DID NOT have the override option selected.  However, when I moved to this container, I found the override option selection to be a necessity as I was experiencing adoption loops  YMMV.

 

Yeah maybe I haven’t ran into problems because controller and APs are in same subnet/VLAN. Ever since I’ve had it all setup I haven’t ever had to re-adopt. Will go ahead and set it sometime when I get sometime. Thanks a ton for the insight!

Share this post


Link to post
On 11/12/2019 at 3:53 PM, Hoopster said:

No, you need to go into the controller webUI and select that override option in the controller settings.

Thank you for this! I just got this up and running today and was in the adoption/disconnect loop. This resolved the problem immediately.

Share this post


Link to post
On 11/8/2019 at 2:30 PM, wgstarks said:

 

It looks like the deb package is available, unless I misunderstood. The container doesn't update to 5.12.x with the "Latest" tag
https://dl.ui.com/unifi/5.12.22/unifi_sysvinit_all.deb

Share this post


Link to post
1 hour ago, RatherDash said:

 

It looks like the deb package is available, unless I misunderstood. The container doesn't update to 5.12.x with the "Latest" tag
https://dl.ui.com/unifi/5.12.22/unifi_sysvinit_all.deb

The debian package may be available for 5.12.22 via direct download, but, the Stable UniFi for Debian Link from which LSIO pulls the "latest" UniFi  version still contains 5.11.50.  Until Ubiquiti updates that, 5.11.50 is considered the latest stable release.

Share this post


Link to post
2 minutes ago, RodWorks said:

Is there a way to change from running the Latest version to LTS?

The github and docker hub links in the first post show info for versions supported (LTS is one of them) and how to apply them.

Share this post


Link to post
On 11/19/2019 at 8:28 PM, wgstarks said:

The github and docker hub links in the first post show info for versions supported (LTS is one of them) and how to apply them.

Thanks, I see where they explain the differences between the versions, but don't see how to apply them or change them in an existing setup.

Share this post


Link to post
46 minutes ago, RodWorks said:

Thanks, I see where they explain the differences between the versions, but don't see how to apply them or change them in an existing setup.

The reason is that we don't supply distribution specific setup instruction.

Check the docker faq for information about setting up containers on unraid.

The tag goes in the repository field with a : between the existing text and the tag.

Share this post


Link to post

Not sure anybody is experiencing the similar issue as me, after I upgraded to the latest release - 5.11.50, the memory load this unifi container keeps increasing, looks like some memory leak issue. Initially, after setup, the load is just about  800MB, after 3 days, increased to 1.5GB. Previously, with the same version, same configuration, that memory load reached more than 4.5GB.

unifi container memory.PNG

Share this post


Link to post

im on 5.12.35 now via the docker upgrade, is 5.11.50 the latests one you can go to? 

Either way, 5.12.35 seems OK

Share this post


Link to post
52 minutes ago, joace said:

Not sure anybody is experiencing the similar issue as me

The latest is 5.12.35. I updated this container to that version a couple of days ago and in those two days the container is now using 1.76 GB.  Frankly, I do not know if that is "normal" as I have not been checking memory usage on docker containers frequently.  It is much, much more than any other active docker container is using (the next largest are CrashPlan at 803 MB and Plex at 534 MB), but, I don't know what is "normal" for UniFi.

 

image.thumb.png.e81f11beb2d74f7430568249224829f8.png

Edited by Hoopster

Share this post


Link to post
7 minutes ago, Hoopster said:

The latest is 5.12.35. I updated this container to that version a couple of days ago and in those two days the container is now using 1.76 GB.  Frankly, I do not know if that is "normal" as I have not been checking memory usage on docker containers frequently.  It is much, much more than any other active docker container is using (the next largest are CrashPlan at 803 MB and Plex at 534 MB), but, I don't know what is "normal" for UniFi.

 

image.thumb.png.e81f11beb2d74f7430568249224829f8.png

Thanks for sharing your data! I will give it a try to upgrade and report back some times later. I neither have an idea what's the normal memory load for unifi controller, but keeps increasing to 4.5GB and more seems not so normal.

Share this post


Link to post

Hey guys I had to setup a new controller and I used my backup and im trying to adopt my aps but my problem is with port 8080 I had to change it to 8082:8080 because my kodi-headless container is using 8080. I tried set-inform http://192.168.0.50:8082 and I also added the override inform host in settings but no luck what could I be missing?

Edited by mkono87

Share this post


Link to post

I'm having the same memory leak issue with my UniFi docker container. When I first start the container, it uses about 700MB then after about 3-4 days its all the way up to 6.5+GB. Eventually, if I don't do anything about it, the entire server will lock up and a hard reset is the only option. However, if I see that my ram is at 95% or so and I simply restart the container, it drops to about 43%. It's pretty ridiculous. My last resort to fix the issue was to backup the Unifi controller using the web interface, completely uninstall the docker container, delete everything in appdata and reinstall. I then restored my backup using the unifi controller interface again. This didn't help. I've also tried to set a max memory usage on the docker container to 3--4GB. After it reaches the limit, the container becomes unresponsive, but at least it doesn't take down the whole server. Apparently this issue has been around for a long time. Is there any solution?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.