Jump to content
linuxserver.io

[Support] Linuxserver.io - Unifi-Controller

547 posts in this topic Last Reply

Recommended Posts

Posted (edited)
21 hours ago, jang430 said:


Finally got this solved by deleting the container 5.9 and downloading latest. Still adopting persists. But I read on first page switch to host, and it adopted without issues. When I switched back to bridge mode, it went back to adopting. Finally had to leave it at host for the moment.

What's the difference between the two?


Sent from my iPhone using Tapatalk

I've read up a bit on Host Vs. Bridge.  Bridge seems to be safer.  I'd like to go to bridge.  Do you think my firewall played a role why APs can't be adopted?

 

 

 

[Solved]  I just want to update everyone that I keep on deleting, downloading adopting to no avail.  In the meantime, I did my own troubleshooting continuously.  I was able to get it working, in Bridge Mode, without changes to firewall.  

 

First, after much frustration, I deleted my 5.9 version, and downloaded latest once again, this time, set it into bridge mode.  Changes port 8080 to 8085 because sabnzbd was using 8080 (this is not part of the solution, already did this on past few trials).  So went into Unifi controller, forgot the AP, ssh into the AP, issued 'sudo syswrapper.sh restore-default', and waited for it to restart, issued 'set-inform http://ip-of-controller:8080/inform,'  saw pending adoption, selected adopt.  Showed adopting, but this time, I think the key lines in the instructions here, I have to issue set-inform http://ip-of-controller:8080/inform for a second time.  After which, it adopted properly.  Finally got it to work on the 2nd day.  I repeated the same steps on the 2nd AP, with the same results.  

Edited by jang430

Share this post


Link to post

Presently to access this controller via the browser within the LAN, i must explicit call out port 8443. I'd like to be able to simply enter the IP or hostname (192.168.1.10 or unifi.lan) to do so. I tried changing the port in the container from 8443 to 80 but no go. Is this possible and how can i do so?

 

many thanks!

 

Share this post


Link to post
42 minutes ago, pimogo said:

Presently to access this controller via the browser within the LAN, i must explicit call out port 8443. I'd like to be able to simply enter the IP or hostname (192.168.1.10 or unifi.lan) to do so. I tried changing the port in the container from 8443 to 80 but no go. Is this possible and how can i do so?

 

many thanks!

 

Bookmark?

Share this post


Link to post
1 hour ago, saarg said:

Bookmark?

🤣

 

sure - i suppose i could just do that.. just wanted to understand if there was way to redirect 80 - > 8443 so i wouldn't have to call it out in the event i was on a computer w/o said bookmark. 

 

Share this post


Link to post
6 hours ago, pimogo said:

🤣

 

sure - i suppose i could just do that.. just wanted to understand if there was way to redirect 80 - > 8443 so i wouldn't have to call it out in the event i was on a computer w/o said bookmark. 

 

It's probably possible somehow, but I don't know how.

Share this post


Link to post

Hey Guys.

 

I am not new to Unifi / Ubiquiti products.  Currently I have a system controlled by my main PC, and now I want to switch to me new server I just built.

 

I downloaded the controller to UnRaid, but now when I start the setup it does not find any of my devises.  Do I have to reset all of them to default and begin the setup again?

Share this post


Link to post
On 2/19/2019 at 11:39 PM, Meller said:

So, I'm new to this docker.  I've been using the controller through a Windows 10 VM... but I love the idea of having it as a docker instead.  

As someone else suggested, the only way I could get the controller to adopt my AP's (they were in the adopting/disconnecting loop) was to switch it from bridge to host... which then adopted them immediately, then put it back in bridge mode (the docker that is).

What's the biggest differences between bridge and host?  What harm would it cause if I left it in host mode?

Also, and perhaps it has nothing to do with the docker, but figured I'd ask anyways.  I'm having issues with just this docker's web gui being accessible when using a subdomain with port forwarding on my router.  

If I type in my static ip:randomport (I've assigned this port on my router to forward to the unraid server's ip:unifi web gui port... it loads the web gui no issue, but when I set up a sub domain on godaddy (with https) to forward to my static ip:randomport... it says it can not connect.  What would cause it to be accessible when typing in my static IP, but when I use a sub domain to forward to it, it's no longer accessible?

I have a lot of subdomains being forwarded to different dockers on my unraid server, and they have no issue.  I only have an issue when I try to access unifi via my sub domain forwarding.

Same problem, switched from bridge to host saved my life thanks. 

Share this post


Link to post
On 3/28/2020 at 8:30 PM, jang430 said:

I've read up a bit on Host Vs. Bridge.  Bridge seems to be safer.  I'd like to go to bridge.  Do you think my firewall played a role why APs can't be adopted?

 

 

 

[Solved]  I just want to update everyone that I keep on deleting, downloading adopting to no avail.  In the meantime, I did my own troubleshooting continuously.  I was able to get it working, in Bridge Mode, without changes to firewall.  

 

First, after much frustration, I deleted my 5.9 version, and downloaded latest once again, this time, set it into bridge mode.  Changes port 8080 to 8085 because sabnzbd was using 8080 (this is not part of the solution, already did this on past few trials).  So went into Unifi controller, forgot the AP, ssh into the AP, issued 'sudo syswrapper.sh restore-default', and waited for it to restart, issued 'set-inform http://ip-of-controller:8080/inform,'  saw pending adoption, selected adopt.  Showed adopting, but this time, I think the key lines in the instructions here, I have to issue set-inform http://ip-of-controller:8080/inform for a second time.  After which, it adopted properly.  Finally got it to work on the 2nd day.  I repeated the same steps on the 2nd AP, with the same results.  

This also was the fix for me as my AP was stuck on adopting then disconnected, rinse/repeat. Thanks so much for posting your resolution!

Share this post


Link to post

Hi all, I have an issue with this container that I can't solve.

 

I use appdata backup to save a weekly version of my containers.

 

Everytime container is rebooted devices are "lost" and I need to manually ssh login into them and do the set-inform command.

 

I'm the only one facing this?

 

Thanks

Share this post


Link to post
Posted (edited)

So I have port 8080 used by other docker and had to change default when setting unifi docker.

I have changed ports in docker as follows:

hhu.thumb.png.4a40a9968f99e9e233c0fd62b3430b39.png

and then I have forwarded the following ports in edgerouter:

hh.thumb.png.f9992cb654e491212252bb3524b3c749.png

 

I have highlighted change from 8080 to 7070, as this is essentially the only change from default ports I have made. Can someone check if the above is correct?

if the above is correct then the next stop would be to ssh to an AP and send inform command as such:

set-inform http://my.public.ip:7070/inform

Right?

I need ports open to outside as I have a couple of friends' APs which I manage on my controller and want to set it right before I start to move them to the container.

 

Thanks

 

 

EDIT: it worked perfectly with exactly the settings as above, first I exported sites and imported into new docker container. The local aps moved at the same time as a part of this process. 

Then I was lucky as on the remote sites I had also team viewer connection, I shhd into one of the ap and sent new set-inform command - withing a second it was adopting on the docker controller. I could send the inform command straight from the old controller but wans't sure if the above configuration is valid so wanted to be extra cautious and take one at a time. Anyway, all worked fine. At the end of the process I deleted all sites and removed them from unifi cloud account. Running since then on docker without any issues.

Edited by Januszmirek
Uodate

Share this post


Link to post
6 hours ago, Jokerigno said:

Hi all, I have an issue with this container that I can't solve.

 

I use appdata backup to save a weekly version of my containers.

 

Everytime container is rebooted devices are "lost" and I need to manually ssh login into them and do the set-inform command.

 

I'm the only one facing this?

 

Thanks

No - I've faced the same issue - but changing the container from bridged to host fixed it for me.

Share this post


Link to post
2 hours ago, Radix999 said:

No - I've faced the same issue - but changing the container from bridged to host fixed it for me.

Thank you!

 

I switched to host and reboot. Devices are still there.

Share this post


Link to post

Hi Everyone.

 

I'm trying to make the switch over to this docker. Thanks so much for providing it. 

 

I have a moderate amount of unifi / ub knowledge and growing set of skill with unraid.

 

Everything has gone fairly well in my moving over to the docker from a cloudkey. I simply restored the backup into the docker and things seemed to move along nicely. However the exception is that I seem to have an AP thats in Adoption limbo. In that it wont complete adoption despite my trying set-informs and reseting the AP to factory defaults(via SSH). The rest of my environment which has additional APs and Switches all adopted in and are functioning well.

 

I have set the controller override settings to the IP of the docker (and I've had that in bridge and host mode). I've even added option 43 to my pfsense dhcp options.

 

I think I found a related support article which describes my issue and a logical process to remove it from the controller db. https://community.ui.com/questions/AP-stuck-in-purgatory/ce5d63b4-c882-415c-bbcc-d00a0089fb8a

 

However I tried these commands from the docker console and they dont seem to work. Can someone point me in the right direction on how to achieve removal of an AP from the controller db in the docker? Or if anyone know what else I should try. Appreciate any help 🙂

Share this post


Link to post

if you can still SSH into the AP, try default settings it and then send manual firmware update command. I saw a few post where folks had various adoption issues due to outdated fw on an AP.

Share this post


Link to post

I just updated this docker container by reinstalling it.  I am running the LTS version.  However, when reinstalling the container, my firewall intercepted the container trying to reach zg-0312c-421.stretchoid.com

 

Anyone know what this is?

Share this post


Link to post
12 hours ago, Januszmirek said:

if you can still SSH into the AP, try default settings it and then send manual firmware update command. I saw a few post where folks had various adoption issues due to outdated fw on an AP.

Running 5.8.11569 FW on the AP. So dont think it would be that.

Share this post


Link to post
16 hours ago, vfast said:

Hi Everyone.

 

I'm trying to make the switch over to this docker. Thanks so much for providing it. 

 

I have a moderate amount of unifi / ub knowledge and growing set of skill with unraid.

 

Everything has gone fairly well in my moving over to the docker from a cloudkey. I simply restored the backup into the docker and things seemed to move along nicely. However the exception is that I seem to have an AP thats in Adoption limbo. In that it wont complete adoption despite my trying set-informs and reseting the AP to factory defaults(via SSH). The rest of my environment which has additional APs and Switches all adopted in and are functioning well.

 

I have set the controller override settings to the IP of the docker (and I've had that in bridge and host mode). I've even added option 43 to my pfsense dhcp options.

 

I think I found a related support article which describes my issue and a logical process to remove it from the controller db. https://community.ui.com/questions/AP-stuck-in-purgatory/ce5d63b4-c882-415c-bbcc-d00a0089fb8a

 

However I tried these commands from the docker console and they dont seem to work. Can someone point me in the right direction on how to achieve removal of an AP from the controller db in the docker? Or if anyone know what else I should try. Appreciate any help 🙂

 

Hi All

 

I was able to resolve my issue and the above article was right. I had to revert back to my cloudkey, perform the DB removal of the AP. Readopt it and then take a new backup across to the docker. I'd still like to know how to perform mongo / DB commands in the docker correctly if someone knows... thanks

Share this post


Link to post
Posted (edited)

Hi,  I'm currently using the Unifi docker by pducharme to manage my APs.  I want to change over to this docker.  I currently autobackup the configuration of my controller from within the Unifi controller application itself.  If I do switch, will I be able to restore the working config from my previous docker to this one using the .unf file I download from the controller? The version of Unifi I run is 5.6.37.

Edited by rbm

Share this post


Link to post
4 hours ago, rbm said:

Hi,  I'm currently using the Unifi docker by pducharme to manage my APs.  I want to change over to this docker.  I currently autobackup the configuration of my controller from within the Unifi controller application itself.  If I do switch, will I be able to restore the working config from my previous docker to this one using the .unf file I download from the controller? The version of Unifi I run is 5.6.37.

If you can set up new container before deleting old one, the easiest way would be to use export/import location option.

Share this post


Link to post

I'm setting up my first UniFi AP and Controller. I grabbed the LTS (latest stable) version. Used Bridge mode. Default IP's. I run pfSense as my router/firewall. Anything special I need to do?

 

I'm stuck on adopting the AP. I ssh'd into the AP and reset it, but I can't seem to get it adopt.

 

Any recommendations?

Share this post


Link to post
Posted (edited)
3 hours ago, teamhood said:

I'm setting up my first UniFi AP and Controller. I grabbed the LTS (latest stable) version. Used Bridge mode. Default IP's. I run pfSense as my router/firewall. Anything special I need to do?

 

I'm stuck on adopting the AP. I ssh'd into the AP and reset it, but I can't seem to get it adopt.

For many (myself included), changing the container to host mode was required for initial adoption. It can be changed back to bridge after adoption is complete.

 

Also, search this forum for 'override inform host.'  There are lots of posts about it and you may need to do that.

Edited by Hoopster

Share this post


Link to post
3 hours ago, teamhood said:

I'm setting up my first UniFi AP and Controller. I grabbed the LTS (latest stable) version. Used Bridge mode. Default IP's. I run pfSense as my router/firewall. Anything special I need to do?

 

I'm stuck on adopting the AP. I ssh'd into the AP and reset it, but I can't seem to get it adopt.

 

Any recommendations?

Mine is working fine in bridge mode, but I have 7 different port mappings, and set inform override is configured to my FQDN with 6 of those mapped ports exposed on my WAN. I have many access points being managed at several different physical sites.

 

The list of ports that need to be used is easy to find, first google hit on unifi wan ports

Share this post


Link to post
2 hours ago, Hoopster said:

For many (myself included), changing the container to host mode was required for initial adoption. It can be changed back to bridge after adoption is complete.

 

Also, search this forum for 'override inform host.'  There are lots of posts about it and you may need to do that.

I, as with it seems many here, have the same adopt loop issue. I’ve manually set the inform via ssh and it only seems to work for a few days. I’ve now set this docker to host and everything so far seems fine. However I only fire up my server when required, what are the negatives to running it always in host mode?

Share this post


Link to post
16 minutes ago, johnieutah said:

However I only fire up my server when required, what are the negatives to running it always in host mode?

This thread contains a good explanation of host vs. bridge mode.

 

Setting inform host via SSH doesn't stick sometimes, that why the override setting with either the FQDN or IP address of the server is often required.

 

image.png.ec623aa90834e9b5ee7a2efc3cff362d.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.