[Support] Linuxserver.io - Unifi-Controller


810 posts in this topic Last Reply

Recommended Posts

  • Replies 809
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Which may or may not mean it's a good idea to push that version to a production environment. "Stable" unifi software has caused major headaches in the past, I'd much rather wait until it's been runnin

I was having adoption issues when i changed to this docker and then i remembered i had the same problem before after an upgrade and i had to change the docker to "host" from "bridge".   Rest

Success, so far, I'm running 5.14.23-ls76 now.   So, to summarize, to those who wish to move from LTS (5.6.42) to 5.14.23-ls76, you must first use 5.10.24-ls21 to upgrade the database.

Posted Images

On 10/24/2020 at 3:30 PM, saarg said:

You don't change the port inside the container, you change the host side. That is what port mapping is about.

 

Please supply the docker run command.

It's funny you say this.  The docker run command is correct, all configured properly, but it doesn't make it into the container, I promise. (IP and path redacted)

 

docker run -d --name='unifi-controller' --net='br0' --ip='1.1.1.13' -e TZ="America/Denver" -e HOST_OS="Unraid" -e 'UDP_PORT_3478'='3478' -e 'TCP_PORT_8080'='6759' -e 'TCP_PORT_8443'='6760' -e 'TCP_PORT_8880'='6761' -e 'TCP_PORT_8843'='6762' -e 'UDP_PORT_10001'='10001' -e 'PUID'='99' -e 'PGID'='100' -v '/REMOVED/unifi-controller':'/config':'rw' 'linuxserver/unifi-controller'

 

But, what I was able to end up doing, is put the docker in a location that is easily accessible via SMB share, manually change the permissions of the system.properties file so I could edit it easily, save the file and restart the docker.  Bingo, it's listening on all the custom ports I wanted it to be listening on.

 

debug.device=warn
debug.mgmt=warn
debug.sdn=warn
debug.system=warn
is_configured_and_restarted=true
is_default=false
portal.http.port=6761
portal.https.port=6762
unifi.http.port=6759
unifi.https.port=6760

 

Link to post

Hey everyone,

 

Im hoping to revisit something earlier in the thread. I have some devices offsite for family members that are pointing to my FQDN for set-inform. My controller is running in docker with a custom bridge as the network. I can set the controller hostname override to my FQDN and get everything to provision except my USG onsite here. If I set it to my local IP then the USG provisions but I lose the offsite devices. Anyone have a fix for this?127674016_ScreenShot2020-10-26at9_36_29PM.thumb.png.985d8cba8f111490031206a62cb5575b.png

Link to post
2 hours ago, jzawacki said:

It's funny you say this.  The docker run command is correct, all configured properly, but it doesn't make it into the container, I promise. (IP and path redacted)

 


docker run -d --name='unifi-controller' --net='br0' --ip='1.1.1.13' -e TZ="America/Denver" -e HOST_OS="Unraid" -e 'UDP_PORT_3478'='3478' -e 'TCP_PORT_8080'='6759' -e 'TCP_PORT_8443'='6760' -e 'TCP_PORT_8880'='6761' -e 'TCP_PORT_8843'='6762' -e 'UDP_PORT_10001'='10001' -e 'PUID'='99' -e 'PGID'='100' -v '/REMOVED/unifi-controller':'/config':'rw' 'linuxserver/unifi-controller'

 

But, what I was able to end up doing, is put the docker in a location that is easily accessible via SMB share, manually change the permissions of the system.properties file so I could edit it easily, save the file and restart the docker.  Bingo, it's listening on all the custom ports I wanted it to be listening on.

 


debug.device=warn
debug.mgmt=warn
debug.sdn=warn
debug.system=warn
is_configured_and_restarted=true
is_default=false
portal.http.port=6761
portal.https.port=6762
unifi.http.port=6759
unifi.https.port=6760

 

You have given it its own IP. That is the same as running in host mode. Port mapping doesn't work in host mode.

Why are you even trying to change the ports when you don't have to do it since the container has its own IP?

Link to post
7 hours ago, Elembemedia said:

I can set the controller hostname override to my FQDN and get everything to provision except my USG onsite here. If I set it to my local IP then the USG provisions but I lose the offsite devices. Anyone have a fix for this?

Enable nat loopback, hairpinning, reflection or whatever your router calls it. Nothing you do to this container or unraid will fix it, you must get your router to cooperate.

Link to post
On 10/27/2020 at 12:38 AM, Elembemedia said:

Hey everyone,

 

Im hoping to revisit something earlier in the thread. I have some devices offsite for family members that are pointing to my FQDN for set-inform. My controller is running in docker with a custom bridge as the network. I can set the controller hostname override to my FQDN and get everything to provision except my USG onsite here. If I set it to my local IP then the USG provisions but I lose the offsite devices. Anyone have a fix for this?127674016_ScreenShot2020-10-26at9_36_29PM.thumb.png.985d8cba8f111490031206a62cb5575b.png

In this setup it can also be resolved by ensuring you have a local DNS server with the A record for unifi.exxx.xxx.com set to the internal address of the USG, while external DNS servers will continue to resolve that DNS address to the public IP of the USG. This is known as split DNS and can be used to resolve this kind of problem. The USG dns should be set to the internal locally controlled DNS server in this setup type.

 

eg: internal DNS server could be pihole.

in pihole add local dns record for controller - eg: 192.168.0.2

ensure dns on usg is set to pihole and it can see pihole server locally so it can resolve hostnames.

internally unifi.exxx.xxx.com will return ip of what is set on pihole server for the controller (eg: 192.168.0.2 if unifi controller was .0.2 for example)

external clients who use external or other DNS servers will continue to receive public IP for unifi.exxx.xxx.com address.

Now both internal and external clients can see a different but correct result for this unifi.exxx.xxx.com address, result that is valid depending if on inside or outside of network.

 

P

 

 

Edited by PeteAsking
Link to post

6 is starting to look more stable so I have changed my tag to :

linuxserver/unifi-controller:version-6.0.28

 

And updated my APs to the latest firmware available (4.3.21.11325).

 

Will update how this goes in a couple weeks. I have noticed some options are missing in the new GUI so if your require every advanced feature possible, I would not yet update. The more general settings are there and most likely the advanced ones will make it in over the next few revisions.

 

P

Link to post

Every time my USG is rebooted, it fails to be adopted by the controller. The only solution is to factory reset the USG, then go to 192.168.1.1 and enter the controller url http://<unraid-ip>:8080/inform and then re-adopt it.

 

It's really really annoying, especially as we're having lots of electrical work done here at the moment, and the're turning off the power every few days.

 

Does anyone else have this issue?

 

Quote

UI 5.14.23.0

Backend 5.14.23

Build atag_5.14.23_13880

 

Link to post

I can't say that I have this issue, and I have a USG as well, but I ALWAYS have my networking equipment connected to a UPS.  The USG only draws a few watts so a decent sized UPS would power it for days, even if you also plug in a modem, switch, etc.  If you have a POE switch powering your WAPs then your wifi will even stay up when your house power is off.

 

You might want to post in the Unifi forums as this issue isn't really an unRAID docker issue.

Link to post
On 11/6/2020 at 2:09 PM, jj_uk said:

Every time my USG is rebooted, it fails to be adopted by the controller. The only solution is to factory reset the USG, then go to 192.168.1.1 and enter the controller url http://<unraid-ip>:8080/inform and then re-adopt it.

 

It's really really annoying, especially as we're having lots of electrical work done here at the moment, and the're turning off the power every few days.

 

Does anyone else have this issue?

 

 

This has been asked several times on this thread. Did you read all the suggestions already posted? Have you for example set your override inform ip to the ip of the docker server on your controller settings?

Link to post

Hi all!

Recently i just bought unifi ap ac-lr unit. 

I install unifi-controller on my unraid setup (with defualt settings)

It seems work pretty fine, it's see AP in list of devices, but i have one trouble. 

AP is all the time in status "adopting". 

I wait pretty long but still nothing happens.

I use windows unifi-controler, and it's works fine.

But i prefer use unraid controller. 

Any idea what could go wrong?

Link to post
Hi all!
Recently i just bought unifi ap ac-lr unit. 
I install unifi-controller on my unraid setup (with defualt settings)
It seems work pretty fine, it's see AP in list of devices, but i have one trouble. 
AP is all the time in status "adopting". 
I wait pretty long but still nothing happens.
I use windows unifi-controler, and it's works fine.
But i prefer use unraid controller. 
Any idea what could go wrong?
Ssh into the AP and type 'info'.

If the inform url is wrong, use 'set-inform http://unraidip:8080/inform'

Assuming the unraid controller port is 8080.
Link to post
8 hours ago, PeteAsking said:
This has been asked several times on this thread. Did you read all the suggestions already posted? Have you for example set your override inform ip to the ip of the docker server on your controller settings?

Yes. I've set it to
http://192.168.1.220
Which is my unraid server.

Edited by jj_uk
Link to post
43 minutes ago, shteud said:

can't do this (i'm never work with SSH and url don't work

and looks like it on port 8080

http://prntscr.com/vfjzwh

On windows, install a SSH client, like "putty".

 

Go to your router and find the IP address of the AP, enter the IP address into putty SSH using port 22, then connect. Enter the username ubnt and password ubnt.

 

Link to post
2 hours ago, jj_uk said:

On windows, install a SSH client, like "putty".

This is a bit orthogonal to the discussion, but Windows has had native support for ssh for over 2.5 years.  https://www.howtogeek.com/336775/how-to-enable-and-use-windows-10s-built-in-ssh-commands/. So you can just run ssh from a command prompt, assuming that it is installed. No more need for putty.

 

And you can install Windows Subsystem for Linux and have pretty much a fully functional distribution of Ubuntu as an application in Windows.  Very useful!  Install it from the Windows Store: https://www.microsoft.com/en-us/p/ubuntu/9nblggh4msv6?activetab=pivot:overviewtab

Link to post
7 hours ago, wayner said:

No more need for putty.

Need, perhaps not. Want, yes. Putty makes it easier, as you can save a single click connection for multiple devices in a list. Just a touch faster than typing out the full ssh connection each time.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.