Jump to content
BelgarionNL

6.7.0 RC5 (and 4,3,2,1, and last stable) Getting the following issues, is my USBstick dying?

10 posts in this topic Last Reply

Recommended Posts

This is what the log is spitting out on repeat:

ErrorWarningSystemArrayLogin


Feb 28 15:24:26 SERVERPRIME kernel: fat__get_entry: 1430 callbacks suppressed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30558) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30559) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30560) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30561) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30562) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30563) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30564) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30565) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30566) failed
Feb 28 15:24:26 SERVERPRIME kernel: FAT-fs (sda1): Directory bread(block 30567) failed
Feb 28 15:24:26 SERVERPRIME root: Starting Samba: /usr/sbin/nmbd -D
Feb 28 15:24:26 SERVERPRIME root: /usr/sbin/smbd -D
Feb 28 15:24:26 SERVERPRIME root: /usr/sbin/winbindd -D
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/3D printer.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/Software.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/appdata.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/audiobooks.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/backups.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/books.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/data.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/domains.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/downloads.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/isos.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/misc.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/movies.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/music.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/pictures.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/system.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/test.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: error: put_config_idx, 609: No such file or directory (2): fopen: /boot/config/shares/tv.cfg
Feb 28 15:24:27 SERVERPRIME emhttpd: Starting services...
Feb 28 15:24:27 SERVERPRIME emhttpd: shcmd (68448): /etc/rc.d/rc.samba restart
Feb 28 15:24:27 SERVERPRIME root: cp: cannot create regular file '/boot/config': Input/output error
Feb 28 15:24:27 SERVERPRIME kernel: FAT-fs (sda1): FAT read failed (blocknr 662)
Feb 28 15:24:29 SERVERPRIME root: Starting Samba: /usr/sbin/nmbd -D
Feb 28 15:24:29 SERVERPRIME root: /usr/sbin/smbd -D
Feb 28 15:24:29 SERVERPRIME root: /usr/sbin/winbindd -D

I can resolve this issue by shutting the server down, removing the usbstick. plugging it into a windows machine (no errors found) then placing it back in the server and it tends to go again for a day or 2.

 

I attached a screenshot of my desktop view. its weird.

 

Annotation 2019-02-28 152404.jpg

Share this post


Link to post

Try a different port ideally usb2

Sent via telekinesis

Share this post


Link to post

yes tried different usb ports. I originally had it on the internal motherboards 2.0 usb header and it worked perfectly for 7+ months.

 

this problem also occured twice on the usb 2.0 header.

 

Now I have been swapping usb ports but those are all 3.1 gen1 or gen 2.

https://www.asrock.com/MB/Intel/H370M-ITXac/index.asp

 

attached are the diagnostics

serverprime-diagnostics-20190228-1602.zip

Edited by BelgarionNL

Share this post


Link to post

You don't mention what flash, but I have had several (not in Unraid) of those especially small ones fail, probably due to overheating. Is it hot when you pull it? Do you have anything writing a lot to flash, such as Fix Common Problems Troubleshooting mode? The Unraid OS itself doesn't access flash a lot. Just when you boot, start/stop the array, or change something in the webUI.

Share this post


Link to post

Its a 'big/long' sandisk 16gb and the last time I pulled it out, I didn't notice it was warm. Furthermore the usbstick is sitting right in front of one of those new 30 dollar noctua fans so it gets at least some cooling from it.

 

- I dont think I write a lot of data to the usbstick, I do have fix common problems but it checks weekly and the rest is set to default. Additionally I have CA Backup/Restore which is running a daily copy to my second flash drive.

 

- Could that be causing the problem? (edit: I disabled backup to second usbdrive to see if that fixes the issue.)

 

My problem is that I want to try and swap out the usb stick for a brand new one. BUT what happens when that one fails because we can only change over the license key once a year. Am I then screwed and forced to buy a new license?

 

 

My plan: Its doing a parity check and with 8gb drives that takes a while so I will wait until it finishes before I switch to a new usbstick. I really haven't tinkered with the server at all except for normal OS updates. So I think the usbstick could be logical conclusion unless you guys come up with something better :)

 

I will follow this thread closely for the next few days in the hope you guys come up with an alternative to using a new USB stick.

Please let me know how I can contribute more data to find the cause because I really want to fix this issue seeing how everything runs on this machine from my pfsense router to my lights (home assistant) When my server goes dark I pretty much go dark... *unfortunately literally go dark :P*

 

Edited by BelgarionNL
additional info

Share this post


Link to post
14 hours ago, BelgarionNL said:

My problem is that I want to try and swap out the usb stick for a brand new one. BUT what happens when that one fails because we can only change over the license key once a year. Am I then screwed and forced to buy a new license?

The automatic process is once a year. If you do experience another failure you can email limetech and explain the situation, they will transfer it manually to another stick for you.

 

I've had a similar thing happen with one of my sticks, (bread errors) and it calmed down on its own for no discernible reason. However, your symptoms and progression definitely sound like a failing stick to me.

 

I'd do the transfer now (after the parity check) to a new stick, not wait and continue to have issues.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.