[Support] knex666 - Mopidy


59 posts in this topic Last Reply

Recommended Posts

  • 4 months later...
  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

When i fire up mopidy ive got this:   INFO Loading config from builtin defaults INFO Loading config from /etc/mopidy.conf   But when i run "mopidy local scan" i've got this:

I just added my Snapcast Template to the App-Repo you should be able to install it in community apps soon.   I never tryed to play different music. Normally you use mopidy because you want t

Already know Mopidy, trying to setup this container, and it is a little bit harder than normally. But i saw this commend, en saw i had the same "aadbbd6bbef9" in de config.   This originates

Posted Images

 

 

When i fire up mopidy ive got this:

 

INFO Loading config from builtin defaults
INFO Loading config from /etc/mopidy.conf

 

But when i run "mopidy local scan" i've got this:

 

INFO     Loading config from builtin defaults
INFO     Loading config from /root/.config/mopidy/mopidy.conf

 

Is there any solution for that?

 

 

And will you upgrade this to mopidy 3.0 ?

 

Edited by lojden
Link to post
On 1/17/2020 at 2:05 PM, lojden said:

 

 

When i fire up mopidy ive got this:

 

INFO Loading config from builtin defaults
INFO Loading config from /etc/mopidy.conf

 

But when i run "mopidy local scan" i've got this:

 

INFO     Loading config from builtin defaults
INFO     Loading config from /root/.config/mopidy/mopidy.conf

 

Is there any solution for that?

 

 

And will you upgrade this to mopidy 3.0 ?

 

Hey,

Thats really easy 

#docker exec -it Mopidy /bin/bash

root@123:# mopidy --config /etc/mopidy.conf local scan

than CTRL + A + D to exit witout clothing the docker

you can run

#docker exec -it Mopidy mopidy --config /etc/mopidy.conf local scan

as well thats the short way.

 

 

Mopidy3: I am working very hard on this. I have setup a new debian container with everything.

Iris and Spotify are not fully working on it and thats very bad.

I keep this as an experimental container hoping for some updates in the next time and will uploads it as a new one.

 

Cheers

Edited by knex666
Link to post

Here's a update to Mopidy3

 

push knex666/mopidy:3-experimental

 

RUN EXAMPLE

docker run -d --name='Mopidy3' --net='br0' --ip='192.168.100.42' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -v '/mnt/user/appdata/mopidy/':'/config/':'rw' -v '/mnt/user/appdata/mopidy/tmp/':'/tmp/':'rw' -v '/mnt/user/Musik/':'/media':'rw' -p 6600:6600 -p 6680:6680 -p 5555:5555/udp 'knex666/mopidy:3-experimental' mopidy --config /config/mopidy.conf

 

I will make a new unraid config xml for Mopidy3 soon. 

Its not jet stable and its missing Iris 

Edited by knex666
Link to post

HI,

i'm really interested in this container but i must admit that after reading here (and the github for it) i still don't understand anything how to run it (i'm also a really fresh newbie in linux).
Could you please make a little step by step guide with example files (configs and so on) how to run it? Expecially using an audio card (built in or not) to output the sound?
Thanks.

Link to post
On 1/19/2020 at 8:52 PM, knex666 said:

Here's a update to Mopidy3

 

push knex666/mopidy:3-experimental

 

RUN EXAMPLE

docker run -d --name='Mopidy3' --net='br0' --ip='192.168.100.42' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -v '/mnt/user/appdata/mopidy/':'/config/':'rw' -v '/mnt/user/appdata/mopidy/tmp/':'/tmp/':'rw' -v '/mnt/user/Musik/':'/media':'rw' -p 6600:6600 -p 6680:6680 -p 5555:5555/udp 'knex666/mopidy:3-experimental' mopidy --config /config/mopidy.conf

 

I will make a new unraid config xml for Mopidy3 soon. 

Its not jet stable and its missing Iris 

Nice! I'll try it out when its ready

 

Thanks

Edited by lojden
Link to post

Thanks for creating this. I did need longer than usual to get this started up. The main confusion was in the predefined settings, the ports weren't set and the container path for the config file was set to

/config/

even though the description said

Container Path: /config/mopidy.conf

So I created the file and set the path to it but it didn't work because it was expecting a folder, not a file.

 

After I figured this out I started a scan but noticed that all the artwork which is created is stored inside the container and not in the appdata folder or another shared volume. So when I switch the container I would loose all this data.

Link to post

Oh, thats bad, do you know where mopidy stores those files. Than you can Volumen Mount that folder. I will add it to the template. 

 

Please note that there have Bern major change between mopidy 2 and 3 thats why the configuration is different. 

 

Thanks and cheers

 

Link to post
  • 1 month later...
1 hour ago, Celsiuss said:

I'm extremely confused.

I've set up the mopidy3 image and file path mapping to my music collection. I'm also using the config example file. However, none of my music is in mopidy, but a whole bunch of random music that don't work.

Did you local Scan your files? After setting the path? 

Link to post
  • 4 weeks later...
On 4/30/2019 at 10:25 PM, knex666 said:

Hey,

 

oh ok. You have mounted your media to /media?
have you startet the process manually inside the container with #mopidy local scan? after scan is completed restart the container.

 

Cheers

hi, 

 

how do you start the process manually inside the container? 

 

I am getting the same error and have my music folder mapped to /media. 

 

Also you asked above if someonw was running snapcast from your repo. How do i do that? I cant find snapcast in the app store and i cant see any of your posts for snapcast

 

Cheers

 

Edit: also should i be using mopidy3 instead? 

 

Edited by GooseGoose
Link to post
4 hours ago, GooseGoose said:

hi, 

 

how do you start the process manually inside the container? 

docker exec CONTAINER_NAME mopidy local scan should work or

docker exec CONTAINER_NAME /bin/sh mopidy local scan 

did not test it just now.

4 hours ago, GooseGoose said:

I am getting the same error and have my music folder mapped to /media. 

 

Also you asked above if someonw was running snapcast from your repo. How do i do that? I cant find snapcast in the app store and i cant see any of your posts for snapcast

I´ve never uploaded that container. thought I did.

 

its the repository kevineye/snapcast

with post argument: snapserver -s pipe:///data/snapfifo?name=Example&sampleformat=44100:16:2

and a mapping from /mnt/user/appdata/mopidy/tmp/ to /data

 

an example config for mopidy is uploaded to github.

 

4 hours ago, GooseGoose said:

 

Cheers

 

Edit: also should i be using mopidy3 instead? 

 

Works but for me its not that beautiful because of the mussing Iris UI

Link to post

hi, 

so i tried running the command and i get the error below. I tried googling it but it seems that the command is correct but i am getting a bad result

username@servername:~# docker exec Mopidy local scan
OCI runtime exec failed: exec failed: container_linux.go:346: starting container process caused "exec: \"local\": executable file not found in $PATH": unknown

Are you able to help with this? 

 

thanks so much for your time! 

Link to post
7 hours ago, GooseGoose said:

hi, 

so i tried running the command and i get the error below. I tried googling it but it seems that the command is correct but i am getting a bad result


username@servername:~# docker exec Mopidy local scan
OCI runtime exec failed: exec failed: container_linux.go:346: starting container process caused "exec: \"local\": executable file not found in $PATH": unknown

Are you able to help with this? 

 

thanks so much for your time! 

Na, that wound work:

 

"docker exec Mopidy mopidy local scan" or  "docker exec Mopidy /folder/to/mopidy local scan"

Link to post

wow, that worked. thanks for teaching me that.

 

Do we have to have a spotify to use this docker? I used the config from https://github.com/maschhoff/docker/blob/master/mopidy/mopidy.conf and removed spotify becasue i dont have an account. It is also giving me an error sating i need to set the scrobbler, and soundcloud username and password, non of which i have in the config file 

 

my config file looks like 

[core]
data_dir = /var/lib/mopidy

[local]
media_dir = /media

[m3u]aadbbd6bbef9
playlists_dir = /var/lib/mopidy/playlists

[logging]
config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log
aadbbd6bbef9
[mpd]
hostname = 0.0.0.0
port = 6600

[http]
hostname = 0.0.0.0
port = 6680

[audio]
output = lamemp3enc ! shout2send async=false mount=mopidy ip=192.168.0.43 port=8000 password=hackme

[iris]
snapcast_enabled = true
snapcast_port = 6680

[stream]
enabled = true
protocols =
    http
    https
    mms
    rtmp
    rtmps
    rtsp
timeout = 5000

yet when i run "docker exec Mopidy mopidy config" i get the following at the bottom of the output

[spotify]
enabled = false  ; Extension disabled due to config errors.
username =   ; Must be set.
password =   ; Must be set.
client_id =   ; Must be set.
client_secret =   ; Must be set.
bitrate = 160
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries = 

[spotify_tunigo]
enabled = true
region = 
sub_genres = true
cache_time = 3600

[soundcloud]
enabled = false  ; Extension disabled due to config errors.
explore_songs = 25
auth_token =   ; Must be set.

[scrobbler]
enabled = false  ; Extension disabled due to config errors.
username =   ; Must be set.
password =   ; Must be set.

It seems even though it enabled is set to false it still won't scan

 

Thanks for all of your help! 

Edited by GooseGoose
Link to post

that was in the config file on github, which i copied and edited. I will remove it and try again

 

https://github.com/maschhoff/docker/blob/master/mopidy/mopidy.conf

 

Edit:

Okay, so i did a complete reinstall, deleting all of the files and trying again and with this as my config

[core]
data_dir = /var/lib/mopidy

[local]
media_dir = /media

[m3u]
playlists_dir = /var/lib/mopidy/playlists

[logging]
config_file = /etc/mopidy/logging.conf
debug_file = /var/log/mopidy/mopidy-debug.log

[mpd]
hostname = 0.0.0.0
port = 6600

[http]
hostname = 0.0.0.0
port = 6680

[audio]
output = lamemp3enc ! shout2send async=false mount=mopidy ip=192.168.0.43 port=8000 password=hackme

[iris]
snapcast_enabled = true
snapcast_port = 6680

[stream]
enabled = true
protocols =
    http
    https
    mms
    rtmp
    rtmps
    rtsp
timeout = 5000

I still get this as the error when i try to "docker exec Mopidy mopidy local scan"

 docker exec Mopidy mopidy local scan
/usr/local/lib/python2.7/dist-packages/mopidy/ext.py:202: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
  extension_class = entry_point.load(require=False)
INFO     Starting Mopidy 2.2.2
INFO     Loading config from builtin defaults
INFO     Loading config from /root/.config/mopidy/mopidy.conf
INFO     Loading config from command line options
INFO     Enabled extensions: mopify, iris, mpd, http, stream, spotify_tunigo, m3u, youtube, simple-webclient, tunein, local-images, softwaremixer, file, musicbox_webclient, party, api_explorer, local-sqlite
INFO     Disabled extensions: spotify, local, scrobbler, soundcloud
WARNING  Found local configuration errors, the extension has been automatically disabled:
WARNING    local/media_dir must be set.
WARNING  Found scrobbler configuration errors, the extension has been automatically disabled:
WARNING    scrobbler/username must be set.
WARNING    scrobbler/password must be set.
WARNING  Found soundcloud configuration errors, the extension has been automatically disabled:
WARNING    soundcloud/auth_token must be set.
WARNING  Found spotify configuration errors, the extension has been automatically disabled:
WARNING    spotify/username must be set.
WARNING    spotify/client_secret must be set.
WARNING    spotify/password must be set.
WARNING    spotify/client_id must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
ERROR    Unable to run command provided by disabled extension local

so the error message is about local being disabled, so i have run "docker exec Mopidy mopidy config" and the following is the local config

[local]
enabled = false  ; Extension disabled due to config errors.
library = json
media_dir =  ; Must be set.
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions = 
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .png
  .txt

it looks like media_dir hasnt been picked up from my mopidy.config file. any idea how to fix this?

 

second edit:

I go to the console for mopidy (is that sh) and when i run this command "cat ~/.config/mopidy/mopidy.conf" i get a completely different config file to the one in appdata

Edited by GooseGoose
adding second edit
Link to post
  • 2 weeks later...

so i got mopidy setup, it successfully scanned my local music. All i want to do now is play music on my android phone. The android app sees my music but no sound is happening because the file is not playing.

 

what should i have in my mopidy.conf fine to enable this? I want to just direct play music from my unraid server on my android phone

 

EDIT: nevermind, i guess i didn't realize how mopidy worked.  the android app only controls the music on the server which then plays it. I don't want to listen to the music on my server so i guess mopidy isn't for me....back to airsonic

Edited by ffhelllskjdje
Link to post
3 hours ago, ffhelllskjdje said:

so i got mopidy setup, it successfully scanned my local music. All i want to do now is play music on my android phone. The android app sees my music but no sound is happening because the file is not playing.

 

what should i have in my mopidy.conf fine to enable this? I want to just direct play music from my unraid server on my android phone

 

EDIT: nevermind, i guess i didn't realize how mopidy worked.  the android app only controls the music on the server which then plays it. I don't want to listen to the music on my server so i guess mopidy isn't for me....back to airsonic

jip ;-) but you can use snapcast for android - that works well

Link to post

This looks interesting. Are you able to do a step by step guide to getting installing a snapcast docker?

 

Also i may have missed this but, to sync between devices do you just need 1 mopidy server? what about if you wanted to play different music through the devices? 

Link to post
2 hours ago, Sassy said:

This looks interesting. Are you able to do a step by step guide to getting installing a snapcast docker?

 

Also i may have missed this but, to sync between devices do you just need 1 mopidy server? what about if you wanted to play different music through the devices? 

I just added my Snapcast Template to the App-Repo you should be able to install it in community apps soon.

 

I never tryed to play different music. Normally you use mopidy because you want to use Google Audio/Home or Snapcast to stream and sync music to every room and Mopidy is your central music station. Give it a try - I dont know

Link to post
  • 2 weeks later...

I got this working with your mopidy3 docker. Seems to work really well. 

 

then i setup your snapcast container and got it all working and streaming to multiple phones and everything was in sync. So then i installed another Mopidy3 container and changed the output to a different fifo file as i am wanting to do something like this

 

Snapcast is not finding the other fifo. Do you know where the snapserver.conf is? https://github.com/badaix/snapcast suggests that it might be in /etc/default/snapserver but the default folder doesn't seem to exist. 

 

these are the files and folders in etc in the container 

/etc # ls
TZ              group           issue           motd            passwd-         securetty       sysctl.d
alpine-release  group-          localtime       mtab            periodic        services        udhcpd.conf
apk             hostname        logrotate.d     network         profile         shadow
conf.d          hosts           modprobe.d      opt             profile.d       shadow-
crontabs        init.d          modules         os-release      protocols       shells
fstab           inittab         modules-load.d  passwd          resolv.conf     sysctl.conf

https://wiki.gentoo.org/wiki/Snapcast suggests that it might be in /etc/conf.d/snapserver but again there is no file there

 

Thanks 

 

 

Link to post
2 hours ago, GooseGoose said:

I got this working with your mopidy3 docker. Seems to work really well. 

 

then i setup your snapcast container and got it all working and streaming to multiple phones and everything was in sync. So then i installed another Mopidy3 container and changed the output to a different fifo file as i am wanting to do something like this

Snapcast is not finding the other fifo. Do you know where the snapserver.conf is? https://github.com/badaix/snapcast suggests that it might be in /etc/default/snapserver but the default folder doesn't seem to exist. 

 

these are the files and folders in etc in the container 


/etc # ls
TZ              group           issue           motd            passwd-         securetty       sysctl.d
alpine-release  group-          localtime       mtab            periodic        services        udhcpd.conf
apk             hostname        logrotate.d     network         profile         shadow
conf.d          hosts           modprobe.d      opt             profile.d       shadow-
crontabs        init.d          modules         os-release      protocols       shells
fstab           inittab         modules-load.d  passwd          resolv.conf     sysctl.conf

https://wiki.gentoo.org/wiki/Snapcast suggests that it might be in /etc/conf.d/snapserver but again there is no file there

 

Thanks 

 

 

 

 

this is very advances but a nice project!

 

snapfifo tmp is here:

/mnt/user/appdata/mopidy/tmp/

it is mounted to Mopidy /tmp/snapfifo and to snapserver /data/

all you have to do is to create another snapfifo pipe for the other Mopidy.

 

You have to change this locations:

 

Snapserver:

Post Arguments: snapserver -s pipe:///data/snapfifo?name=Example&sampleformat=44100:16:2

 

Mopidy3

 

[audio]
output = audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmp/snapfifo

Link to post
  • 2 weeks later...
On 5/4/2020 at 6:07 PM, knex666 said:

 

 

this is very advances but a nice project!

 

snapfifo tmp is here:

/mnt/user/appdata/mopidy/tmp/

it is mounted to Mopidy /tmp/snapfifo and to snapserver /data/

all you have to do is to create another snapfifo pipe for the other Mopidy.

 

You have to change this locations:

 

Snapserver:

Post Arguments: snapserver -s pipe:///data/snapfifo?name=Example&sampleformat=44100:16:2

 

Mopidy3

[audio]
output = audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmp/snapfifo

i had a motherboard die, fixed that and i can start working on this again! 

 

That is amazing! I didnt know about the post arguments. 

so i have my mopidy instances like this 

 

Mopidy3-test1

[audio]
output = audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmp/snapfifo-test1

 

 

Mopidy3-test2

[audio]
output = audioresample ! audio/x-raw,rate=48000,channels=2,format=S16LE ! audioconvert ! wavenc ! filesink location=/tmp/snapfifo-test2

 

and my snapserver post arguments:

snapserver -s pipe:///data/snapfifo-test1?name=Test1&sampleformat=44100:16:2 -s pipe:///data/snapfifo-test2?name=Test2&sampleformat=44100:16:2

 

i have also tried:

snapserver -s pipe:///data/snapfifo-test1?name=Test1&sampleformat=44100:16:2 snapserver -s pipe:///data/snapfifo-test2?name=Test2&sampleformat=44100:16:2

 

but the snapcast player on my phone only seems to pick up the first pipe file. Is this how i should be trying to do multiple streams?

 

I am also getting a weird issue with the second instance of mopidy3 where i click play and the audio works perfectly but it looks like it skips all of the songs on the front end. Do you know what would be causing this? 

1286441252_mopidy3weirdbug.gif.078a3d4cd0b639f31177545eaa393497.gif

 

cheers

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.