Jump to content
darrenyorston

Un-bonding multiple NICs

9 posts in this topic Last Reply

Recommended Posts

I have been trying to set up WOL on my Gigabyte x399 Aorus Xtreme. The manual says the board supports it.

 

I have been unable to get it to work however. I think I have isolated the issue to the boards NICs. The Aorus Xtreme has three NICs; a 10GB and two 1GB ports. It appears the 10GB NIC does not support WOL. The two 1GB NICs do.

 

In network settings unRAID shows all three NICs as bonded. I think the inclusion of the 10GB, which does not support WOL, is causing WOL to fail. As a result I am thinking that I could utilise one of the 1GB NICs as my network connection. Or maybe bond eth1 and eth2. Though I dont really need the bandwidth.

 

I cant seem to get it to work though. eth0 is the 10GB NIC, eth1 and eth2 are the 1GB NICs. eth0 is showing as bonded with eth1 and eth2.

 

Firstly, how do I stop all three NIC being bonded?

 

Secondly, how do I tell unRAID that eth1 is the NIC to utilise for network connectivity?

 

I tried setting Enable Bonding on eth0 to no then setting eth1 to bonded with eth2 however I dont get a connection. When I do this unRAID reports "Interface Ethernet Port O is down. Check cable!"

 

Also eth1 and eth2 have the message :Interface is shutdown (inactive)" next to the MAC address.

 

Any advice on how to configure network settings so as to utilise a particular NIC would be much appreciated.

Share this post


Link to post
1 hour ago, darrenyorston said:

I think I have isolated the issue to the boards NICs. The Aorus Xtreme has three NICs; a 10GB and two 1GB ports. It appears the 10GB NIC does not support WOL. The two 1GB NICs do.

 

In network settings unRAID shows all three NICs as bonded. I think the inclusion of the 10GB, which does not support WOL, is causing WOL to fail. As a result I am thinking that I could utilise one of the 1GB NICs as my network connection. Or maybe bond eth1 and eth2. Though I dont really need the bandwidth.

 

I cant seem to get it to work though. eth0 is the 10GB NIC, eth1 and eth2 are the 1GB NICs. eth0 is showing as bonded with eth1 and eth2.

 

Firstly, how do I stop all three NIC being bonded?

 

Secondly, how do I tell unRAID that eth1 is the NIC to utilise for network connectivity?

 

I tried setting Enable Bonding on eth0 to no then setting eth1 to bonded with eth2 however I dont get a connection. When I do this unRAID reports "Interface Ethernet Port O is down. Check cable!"

 

Also eth1 and eth2 have the message :Interface is shutdown (inactive)" next to the MAC address.

 

Any advice on how to configure network settings so as to utilise a particular NIC would be much appreciated.

 

I highly doubt you have your NICs all bonded together.

I have a network bond configured and this is what it looks like

 

 

bond.thumb.png.4855f51452abfa244102168f471eca2f.png

 Also note, that just because you enable it in unRAID doesnt mean its going to work.

You also need to configure your network switch to support the bond as well along with running the extra cat cables that are needed.

 

 

 As for how to tell unRAID what NIC to use, if you only need 1 NIC, only run 1 cat cable to the server.  It will only get the one IP and the port you plug it into will be it.   You can also turn off un-needed ports in the BIOS if that makes things easier for you as they will not show up in the gui.

 

 

 



 

Share this post


Link to post
Just now, JaY_III said:

 

I highly doubt you have your NICs all bonded together.

I have a network bond configured and this is what it looks like

 

 

bond.thumb.png.4855f51452abfa244102168f471eca2f.png

 Also note, that just because you enable it in unRAID doesnt mean its going to work.

You also need to configure your network switch to support the bond as well along with running the extra cat cables that are needed.

 

 

 As for how to tell unRAID what NIC to use, if you only need 1 NIC, only run 1 cat cable to the server.  It will only get the one IP and the port you plug it into will be it.   You can also turn off un-needed ports in the BIOS if that makes things easier for you as they will not show up in the gui.

 

 

 



 

Looks like all three NICs are bonded to me. Interface eth0 says "bonded" bonded members of bond0 are "eth0, eth1, eth2"

 

Both interface eth1 and eth2 show as member of bond0.

 

It doesnt matter which port I run the cable to. I get connectivity regardless of the port as they are bonded. I dont want the ports turned off in the bios as I intended to stub them and assign them to VMs.

 

Im not seeking to utilise a bonded connection. In fact I only want to utilsie a single NIC, either eth1 or eth2. At the moment I cannot work out how to do that.

NIC.png

Edited by darrenyorston
spelling

Share this post


Link to post

from the help one the page itself

 

Mode 1 (active-backup) - default
This mode places one of the interfaces into a backup state and will only make it active if the link is lost by the active interface. Only one slave in the bond is active at an instance of time. A different slave becomes active only when the active slave fails. This mode provides fault tolerance.

 

If you dont want that, change the enabled bonding to "no"

 

Share this post


Link to post

I tried setting enable bonding on eth0 to no. When I do I loose network connectivity. eth1 and eth2 show as "interface inactive". I cannot find a setting to make them active. Even setting eth1 or 2 to bonded does work. eth1 is connected to the router however it continues to remain inactive and doesnt get an IP address.

Share this post


Link to post

you have me stumped then as I have no issues using either NIC

 

If I turn my bond off, I can assign an IP to eth0 or eth1 and can access my system from either NIC, as i have both wired into my switch.

 

 

 

 

Share this post


Link to post

What I have discovered is that eth1 and eth2 need to be unchecked from the bond prior to unbonding eth0. When I do the "interface inactive" notification dissapears.

 

In theory all three NICs are now independent. However, I am still getting the message "Interface Ethernet Port 0 is down. Check cable!". I am presuming unRAID is looking for network connectivity on eth0 as opposed to any port. With a cable plugged into either eth1 or eth2 they pcik up an IP address when I select apply however there is still no netowrk connectivity. By that I mean I cant access anything. Using the GUI unRAID wont check for plugin update and Fix Common Problems reports no internet.

 

What about the internet rules at the bottom of the Network Settings page? Are they telling unRAID which ports to utilise for network connectivity? Should I re-order them so that the 10GB NIC, which doesnt support WOL, becomes eth2?

 

 

Edited by darrenyorston
spelling

Share this post


Link to post

Unraid uses eth0 as its management port, and this port requires Internet access for Unraid to work properly.

You'll need to re-arrange ports (see network rules) to assign the "correct" interface to eth0.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.