Jump to content
Sign in to follow this  
Warrentheo

Need help killing the new BlueTooth driver in 6.7.0-rc3+ (BCM20702A0 driver)

1 post in this topic Last Reply

Recommended Posts

I am having issues with the new bluetooth drivers added to UnRaid to support bluetooth in the docker containers... These drivers grab my USB bluetooth and prevents me from passing it into a VM now (Locks up VM and causes other issues)

I have already started a new bug report for this issue already, and was told this is not a bug, but a feature 😕  Not a huge problem for my situation since I only occasionally use it in my VM, however I do think other people are going to need this info, and eventually I am going to need my bluetooth again, so I have been trying to figure out how to fix this issue...

 

For various reasons, I am not willing to move the device to the passed through USB controller or other adjustments to the hardware to fix this issue, it was caused by a software change, and will need a software change to fix it...

 

The main issue is that it currently looks like there no way to disable this driver correctly, the other solutions I have found on my google searches have not worked, some things I have tried:

Quote

Added that to my go file (Reversed the order, because when I tried to type them manually, they said that bluetooth required some of the sub modules, so I tried to unload the sub modules first) :

......

rmmod btusb
rmmod btrtl
rmmod btintel
rmmod btbcm
rmmod bluetooth

# Start the Management Utility
/usr/local/sbin/emhttp &
Quote

and it causes these lines right after the winbindd -D part of the boot process:

rmmod: ERROR: Module btusb is not currently loaded
rmmod: ERROR: Module btrtl is not currently loaded
rmmod: ERROR: Module btintel is not currently loaded
rmmod: ERROR: Module btbcm is not currently loaded
/var/tmp/go: line 15: $'r\357\273\277mmod': command not found
Quote

According to the internet, I added this to my syslinux config as my next attempt:

... bluetooth.blacklist=yes ...
Quote

That showed up as this error in my syslog:

bluetooth: unknown parameter 'blacklist' ignored

 

So it appears that while the drivers have been implemented, the method for disabling them is either not implemented yet, or non-standard...  I am afraid I am at the limit of my Linux knowledge on this, and was hoping someone else might be able to help point me in the right direction... 😉

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this