Jump to content
datruedave

I don't have an appdata share and can't enable Docker

7 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Should I just create an appdata share?  And Appshare?  How do I do that?  It's not a regular user share, right?  Sorry, I'm a total newb (experience-wise if not time-wise), but my Plex plugin just stopped working and I figure it's time to get this new Docker thing working.  I tried reading through all of the pinned posts, but several of them are completely outdated, and I'm unsure how accurate some of the others are.  I made it through the Space Invaders video, but, as you can see in this screenshot, I was quickly derailed and unable to simply do what he describes.

 

ESdJ1Yv.png

 

I'm one of those guys that likes to get things going and then leaves it alone.  I know a lot of you guys tweak your servers, but I can go months and months without ever looking at my unRaid settings.

Edited by datruedave

Share this post


Link to post
Posted (edited)

Are you sure do not already have an appdata Share?     It is normally created by default and you have to actively remove it to get rid of it.

 

it is a normal user share.   It is normally set up with Use Setting set to Prefer.    The reason is that works even if you do not have a cache drive, and if you later add one files then get automatically moved to the cache drive to maximise performance of docker containers.

 

in terms of not being able to enable docker what do you have set for the docker image file under Settings->Docker.   A common mistake is to specify a folder - it needs to be an actual file name.

Edited by itimpi

Share this post


Link to post
11 minutes ago, itimpi said:

Are you sure do not already have an appdata Share?     It is normally created by default and you have to actively remove it to get rid of it.

 

it is a normal user share.   It is normally set up with Use Setting set to Prefer.    The reason is that works even if you do not have a cache drive, and if you later add one files then get automatically moved to the cache drive to maximise performance of docker containers.

 

in terms of not being able to enable docker what do you have set for the docker image file under Settings->Docker.   A common mistake is to specify a folder - it needs to be an actual file name.

I definitely don't have an appdata share and I never deleted it.  I've been using this unRaid server since before Dockers were an option, so maybe that's why it wasn't created by default?

 

So, if you can see that image, you know what I have under Settings>Docker.  I can't get past that screen without, I presume, creating appdata and Appshare.  I was hoping someone could outlined what I need to do to not mess that up.

Share this post


Link to post

The screenshot is a little hard to read but I can see enough to know they will not work :(.    You have specified a location that starts with /mnt/Appdata and that is not valid under Unraid as only disks can be mounted directly under /mnt.    0n my system the location for the docker image is set as /mnt/user/system/docker/docker.img, although I know some have used /mnt/user/appdata/docker.img.  It does not really matter as long as it is a path that is valid in Unraid.   The ‘system’ share is another one that is normally set up by default to hold files relating to docker and VMs.  Note also that case matters in Linux folder and file names.

Share this post


Link to post
Posted (edited)

If you click on it, the screenshot should be crystal clear.

 

I didn't specify anything, everything you see is what unRaid has by default. 

 

Everything I'm reading says I should use mnt/cache/something for Dockers.  But I'm still not confident that I'm grasping the concepts right.

Edited by datruedave

Share this post


Link to post
2 hours ago, datruedave said:

If you click on it, the screenshot should be crystal clear.

 

I didn't specify anything, everything you see is what unRaid has by default. 

 

Everything I'm reading says I should use mnt/cache/something for Dockers.  But I'm still not confident that I'm grasping the concepts right.

I did click on it - if anything that made it worse :)

 

I have never seen that value for the docker image file.   It is definitely not the default.   No idea where the values you are seeing have come from.   As I said the location shown for the image file is definitely not valid - it would be in RAM and would not survive a system reboot.   It needs to be located either directly on a disk, or put in a User Share (which allows the system to decide where to locate it)

Share this post


Link to post
I did click on it - if anything that made it worse
 
I have never seen that value for the docker image file.   It is definitely not the default.   No idea where the values you are seeing have come from.   As I said the location shown for the image file is definitely not valid - it would be in RAM and would not survive a system reboot.   It needs to be located either directly on a disk, or put in a User Share (which allows the system to decide where to locate it)
I assure you that when I went into the Docker settings for the first time ever, those values were already filled in like that. To me, that's the same thing as a default setting.

Can I just create the right settings/shares/whatever? Is there anything that I need to watch out for, or is it pretty safe to play around with this and try different things?

Sent from my SM-G965U using Tapatalk

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now