Jump to content
Sign in to follow this  
nanoblock

Transcoding support intel i5 9600k and asrock z390m

2 posts in this topic Last Reply

Recommended Posts

I have been browsing around the forums and I see some posts but nothing that has ultimately been able to help me resolve my issue. I have just finished a new nas build with an intel i5 9600k and an asrock z390m motherboard running 6.7.0-rc5. I have followed some guides and have igpu enabled in my bios along with primary graphics adapter as onboard and have added the line append initrd=/bzroot i915.alpha_support=1 under unraid OS section of syslinux configuration. I reboo, then type in modprobe i915 in the cli and do not see the /dev/dri directory. Has anyone been able to crack this and come up with the solution? I am also not sure if its as simple as me missing something in the bios http://asrock.pc.cdn.bitgravity.com/Manual/Z390M-ITXac.pdf page 59 seems to show the settings which would apply to enabling the quick sync.

 

Thank you in advance for the help.

Share this post


Link to post
Posted (edited)
4 hours ago, nanoblock said:

I have been browsing around the forums and I see some posts but nothing that has ultimately been able to help me resolve my issue. I have just finished a new nas build with an intel i5 9600k and an asrock z390m motherboard running 6.7.0-rc5. I have followed some guides and have igpu enabled in my bios along with primary graphics adapter as onboard and have added the line append initrd=/bzroot i915.alpha_support=1 under unraid OS section of syslinux configuration. I reboo, then type in modprobe i915 in the cli and do not see the /dev/dri directory. Has anyone been able to crack this and come up with the solution? I am also not sure if its as simple as me missing something in the bios http://asrock.pc.cdn.bitgravity.com/Manual/Z390M-ITXac.pdf page 59 seems to show the settings which would apply to enabling the quick sync.

 

Thank you in advance for the help.

The i915 graphics drivers in the Linux kernel used in current versions of unRAID do not support the iGPU in 9th generation Intel CPUs.  Apparently, the i915 drivers have been modified to support these iGPUs in the 4.20 and later version of the Linux kernel.  Once it makes its way to unRAID (the 6.7.0 rc is currently using the 4.19 kernel), we'll know for sure.

 

AFAIK, no one with a 9th generation CPU/iGPU is successfully using hardware transcoding on unRAID at the moment.

Edited by Hoopster

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this