Unraid GUI not accessible : 502 Bad Gateway


12 posts in this topic Last Reply

Recommended Posts

Hi, it seems something went wrong on my Unraid server.  The GUI doesn't load anymore.  I always get 502 Bad Gateway (nginx) when trying to load my Unraid GUI.  I want to avoid rebooting the whole server just for fixing the GUI. 

 

Is there a process I can kill to restart the GUI without a reboot ?  

 

Forgot to add, that i'm on lastest RC build.

 

Thanks!

Edited by Pducharme
Link to post
  • 9 months later...

Anything on 6.7 or 6.8 that is built in and works or maybe better instructions if this works?  I used putty to get to the server, logged in and tried to run the commands but they weren't found.  

 

From the link above.

Quote

For testing purposes I swapped menus a dozen times to the extreme, but never experienced a break.

Side note: a full restart of the GUI requires "rc.nginx restart" and "rc.php-fpm restart"

(make sure all your browser sessions are closed before restarting)

 

Link to post

Thanks, that worked.  Got a strange issue though, on both servers this has just recently occurred.  The first one I tried a clean powerdown from the command line but it didn't work.  After that I tried to access a share on the other server and it hung.  When I refreshed the GUI it hung.  Your instructions allowed be back into the gui but the share is now not accessible.  I'm attempting to pull diagnostics from the GUI but that seems to not be working.  Any other ideas?

Link to post

Is there a place to start looking for errors? I found it strange that both machines had issues around the same time. Another thread suggests looking in /var/log/nginx/error.log

Any other ways to go about pulling a diagnostic? Even after I was able to restart the GUI on the second server it was effectively hung. The shares weren’t accessible and the diagnostic wouldn’t run/download.

Link to post

Thanks. Squid gave me that above and it did fix the gui however the shares were hung and dockers wouldn’t stop, etc. There doesn’t seem to be much on this issue so I was really surprised when it happened on two different servers minutes apart.

Link to post
  • 9 months later...
  • 2 months later...

Only as feedback. I tried to enable BIND_MGT. For this it is need to execute the following:

/etc/rc.d/rc.nginx restart

 

I opened the Webterminal, executed it and the Webterminal was dead.

 

I think this happens because restarting Nginx means restarting the Webterminal and while its dead the Nginx restart command is interrupted. So finally it does not restart nginx, it kills it. But strangely it kills only the Webterminal and not the total WebGUI. So I though "hey you are having User Scripts. Let's use this to execute the restart". And now my next mistake ^^ I added a script and executed it through "Run Script" and not "Run in background". So again, nginx restart was killed while execution. And finally the complete WebGUI was dead.

 

 

Of course SSH was disabled 🙈, so I needed physical access to the server. Logged into the console, entered the command and.. nginx is not started. Ok, so I started it and everything was fine again.

IMG_20210122_011322.thumb.jpg.cddcb540840fe65d9cf7f1370c70981c.jpg

 

So reminder to myself: Never restart a Webserver through the Webserver ^^

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.