(Solved) I have broken network access to containers


2 posts in this topic Last Reply

Recommended Posts

(6.7.0-rc5)

I have been investigating an issue I have recently started to have. but I'm getting nowhere with it. 

I'll do my best to describe it with examples.

(I'm pretty sure I broke something somehow as it was working previously)

 

for the sake of showing off the issue, I have two firewall port settings set up for airsonic

settingA UnraidServer 80 4040

settingB UnraidServer 4040 4040

 

Basically shifting incoming port 80 to 4040 on unraid box

and the same with 4040.

 

if I access my machine remotely using:

www.somewebaddress.com:4040/airsonic/login     This works.

www.somewebaddress.com/airsonic/login              This does not work. 

 

However, if I instead change the firewall to point at unraid gui

settingA UnraidServer 80 80

 

then www.somewebaddress.com will show me my unraid Gui. 

 

So, I think somehow I've broken unraid's ability to pass on requests to containers. (Routing? I'm not sure on the terminology!)

This isn't specifically related to airsonic, it is affecting all of my containers. 

 

Any help anyone could give would be gratefully received.

tower-diagnostics-20190326-1203.zip

Edited by 3urningChrome
Solved issue
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.