Jump to content
linuxserver.io

[Support] Linuxserver.io - OpenVPN AS

1766 posts in this topic Last Reply

Recommended Posts

You need to add a variable with the name INTERFACE and the key bond0 to your docker container template as described in the readme.

Share this post


Link to post

My OpenVPN-AS setup to use Bond0:

 

1. Config Type: Variable

2. Name: Interface (I think you can name it whatever you like)

3. Key: INTERFACE

4. Value: bond0

Share this post


Link to post
20 hours ago, CHBMB said:

You need to add a variable with the name INTERFACE and the key bond0 to your docker container template as described in the readme.

 

Hi,

 

I have done this, still nothing.  I have attached a print screen of the settings.

Untitled.png

Share this post


Link to post

Yeah, you've setup the variable wrong.

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

One would think so but this is the only way it works. I tried the method that was described here and it doesn't work. If in deed my setup is wrong then I would not be able to view the webgui, login to the web admin or successfully connect from any device. This will lead me to the conclusion that there is something amiss with the docker.

Edited by net2wire

Share this post


Link to post
42 minutes ago, net2wire said:

One would think so but this is the only way it works. I tried the method that was described here and it doesn't work. If in deed my setup is wrong then I would not be able to view the webgui, login to the web admin or successfully connect from any device. This will lead me to the conclusion that there is something amiss with the docker.

I wasn't referring to you, I was referring to @Greygoose

Share this post


Link to post

LOL . Thanks.

As per the instructions it reads that the KEY should be bond0. That's how it's read imo. It's a little confusing. But all good. I finally got it to work. 

 

Share this post


Link to post
5 hours ago, net2wire said:

My setup:

 

 

openvpn-as-setup.png

That picture right there also solved my issue thanks everyone for the help!

 

Share this post


Link to post

Hello guys


I'm rather new to VPN's so I might have done few mistakes with my setup. I can't connect to my VPN allthough I it should in my opinion. I've made a lot of screenshots of my config, which might be easier to find the problem...

 

Ports: https://snag.gy/AhpwlY.jpg

OpenVPN: https://snag.gy/OFKSMt.jpg https://snag.gy/boOes5.jpg https://snag.gy/dKtI3y.jpg https://snag.gy/LDb8VM.jpg https://snag.gy/Dew97Y.jpg

 

Nothing has been edited on the docker so I guess the problem lies in my settings.


Thanks for any help

Share this post


Link to post

Gridrunner has done a good video guide that you might want to take a look at....

Sent from my LG-H815 using Tapatalk

Share this post


Link to post
16 hours ago, In0cenT said:

Hello guys


I'm rather new to VPN's so I might have done few mistakes with my setup. I can't connect to my VPN allthough I it should in my opinion. I've made a lot of screenshots of my config, which might be easier to find the problem...

 

Ports: https://snag.gy/AhpwlY.jpg

OpenVPN: https://snag.gy/OFKSMt.jpg https://snag.gy/boOes5.jpg https://snag.gy/dKtI3y.jpg https://snag.gy/LDb8VM.jpg https://snag.gy/Dew97Y.jpg

 

Nothing has been edited on the docker so I guess the problem lies in my settings.


Thanks for any help

 

Here's the guide I was referring to above.

Share this post


Link to post
2 hours ago, CHBMB said:

 

Here's the guide I was referring to above.

 

Thanks, as I went through the tutorial he mentioned that if you have network bonding enabled it might look different than his example. This is where my problem lies:

I get this in my config:

Interface and IP Address

Listen on all interfaces
eth0: 172.17.0.6
 
My local IP of the unraid machine is 192.168.178.200, is there a way I can get it to work with bonding enabled?

Share this post


Link to post

Yep, scroll up a few posts, or do a search, has been extensively discussed recently and is in the readme linked on the first page on both the github and docker sites.

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

Thanks for your response but I couldnt find anything in the readme. I've done some research and just found to manualy set a variable INTERFACES to bond0. After that my docker wont start anymore, removing the variable allows the docker to start again...

Share this post


Link to post

Post your docker run command with the interface parameter added

Sent from my LG-H815 using Tapatalk

Share this post


Link to post
10 hours ago, In0cenT said:

Thanks for your response but I couldnt find anything in the readme. I've done some research and just found to manualy set a variable INTERFACES to bond0. After that my docker wont start anymore, removing the variable allows the docker to start again...

Here's the link in the readme

 

Share this post


Link to post

Hi guys,

 

Sorry if i'm interupting conversations here, i'm not sure where else to post questions about OpenVPN.

 

I've been trying for ages to access my Unraid machine remotely using OpenVPN Connect from my mobile.  It seems to be working, the IP matches that of my home IP address and as such i can now access all my dockers using ip:8080, ip:8383 etc.....  BUT the one thing i cant access is the actual Unraid WebGUI!  On my home network all i need to do is type in is my unraid server name and it opens up the WebGUI, however, even though i use openvpn connect and log onto my home network, typing that in doesnt work, neither does just typing in the IP address of the server. 

 

Being honest i'm not sure i completey have everything set up correctly or not.  I followed Spaceinvader One's brilliant youtube video  as best i could but basically i have OpenVPN on my unraidwith a dynamic host name using dyndns linked to that.  I then have the DDNS section of my router filled out with the DYNDNS details (it says it connects succesfully) with a single port forwarding open for OpenVPN on my Unraid.  Other than that i download the config file from openvpn, imported to my android device and it seems to work! Just not the WebGUI.

 

Ultimately i'm trying to finish off finally getting my Unraid together with just the last two steps of being how to turn it on remotely (im guessing S3???) and once i'm done, turning it off again (via the WebGUI).

 

Any help to finish off this long long project of mine would be greatfully appreciated! (then my girlfriend can stop moaning at me!!)

Share this post


Link to post

Mine just worked without any fiddling, although I did it so long ago before the video guide.....

Share this post


Link to post

Does my setup sound correct though and should i be able to access my WebGUI as i thought?  My friend was saying he was unsure if i actually needed OpenVPN installed on Unraid or whether just connecting to my home network should be enough?

 

Thanks

Share this post


Link to post

Sounds correct.

You should be able to access the webui.

 

40 minutes ago, griff1984 said:

 My friend was saying he was unsure if i actually needed OpenVPN installed on Unraid or whether just connecting to my home network should be enough?

What?

You use this docker to connect to your home network, if you don't use this then the only other way is by using a VPN Server instance on your router/firewall....  That statement confuses me.

Share this post


Link to post

This could be where im going wrong... I can turn off the OpenVPN Docker and my unraid will still connect to the internet and i can still search for my files from my pc through the network!  Have i completely missed something here.... :/  

Share this post


Link to post
12 hours ago, CHBMB said:

Post your docker run command with the interface parameter added

Sent from my LG-H815 using Tapatalk
 

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="openvpn-as" --net="bridge" --privileged="true" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e "PGID"="100" -e "PUID"="99" -e "INTERFACE"="bond0" -p 943:943/tcp -v "/mnt/cache/appdata/openvpn-as":"/config":rw linuxserver/openvpn-as
8f850d6227c96c18ae8b76c193380870c7cbfcb6b294cc58447458ef1c14fa6e

The command finished successfully!

Logs:


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-time: executing...
dpkg-query: package 'tzdata' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: tzdata is not installed
[cont-init.d] 20-time: exited 1.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] 40-openvpn-init: executing...
[cont-init.d] 40-openvpn-init: exited 0.
[cont-init.d] 50-interface: executing...
MOD Default {} {}
MOD Default {} {}
MOD Default {} {}
MOD Default {} {}
[cont-init.d] 50-interface: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

Thanks for your help!

Share this post


Link to post
56 minutes ago, griff1984 said:

This could be where im going wrong... I can turn off the OpenVPN Docker and my unraid will still connect to the internet and i can still search for my files from my pc through the network!  Have i completely missed something here.... :/  

The purpose of this docker is to provide security for your local network and the unRAID server when you connect from the internet. If you are running openvpn on your router then you don't need this docker. If you aren't running any other vpn server then you are leaving your server and potentially your entire network wide open for anyone to attack. The basic UnRAID installation provides no protection. Simple password protections are easily hacked.

Share this post


Link to post

Thanks for your reply... The only thing im running on my router is a DDNS tracker with a host name that openvpn is using on Unraid and a single port forwarding option for openvpn on my unraid machine... My router doesnt have an openvpn option on the router, only the new routers seem to have it.  I guess i need to buy a new router!!  

 

So i'm a bit unsure of which way to proceed really.... My set up seems to work in regards of being to connect to openvpn using my phones network, giving me access to dockers via their various ports but not the actual Web GUI.  Now i'm unsure whether or not i've got the whole thing configured correctly in the first place, i want it to be as secure as possible!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.