[Support] Linuxserver.io - OpenVPN AS


1950 posts in this topic Last Reply

Recommended Posts

  • Replies 1.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I have made un updated video guide for setting up this great container. It covers setting up the container, port forwarding and setting up clients on Windows, macOS Linux (ubuntu Mate) and on cel

PSA. It seems openvpn pushed another broken bin, tagged 2.7.3 I get the same error with it as I did with the previously pulled 2.7.2   While they/us try to figure it out, you can change

Ok, I used to be able to connect to Host network with this before the update....that allowed me to be assigned an IP on my WiFi subnet, which then allowed me to access the UnRAID GUI interface.  

Posted Images

11 minutes ago, comet424 said:

thats correct reason i said there is a bug in the openvpn as program

as you see in the previous images...  Unraid is set to 1200 not 1194

yet unraid is reading another file then

Interesting. I didn't see the bottom part of your screen shot. Have you tried deleting the appdata for the openvpn configuration?

Link to post

yes i did 

ill try again later  

 

what i did was Install OpenVPN-AS

i instantly change it from 1194  to 1200  

and changed from eth0 to bond0  

and when i logged into the GUI   the gui  automaticlly set to 1194 as well   i had to manually change it..

so thats why i thinking  3 locations for the VPN Port

 

i edited the config.jon  file too  found a 1194  port so i changed it thinking that would modify unraid  but  it didnt 

reboots  Force Update like you seen.. you see it says 1200  in the force update yet it wont save it

i ran  New Permissions for AppData Rights  which really bugs me gotta keep doing that every so often  for deleting files moving   New Permissions..

 

so i figured its a bug  that its saving 3 different copies of the port address

 

but when i get home later tonight ill un install server and re delete the folder and reinstall again  3rd time the charm then lol

 

i also edited as.conf   but there was no 1200 or 1194 in there either

Edited by comet424
Link to post
2 hours ago, comet424 said:

yes i did 

ill try again later  

 

what i did was Install OpenVPN-AS

i instantly change it from 1194  to 1200  

and changed from eth0 to bond0  

and when i logged into the GUI   the gui  automaticlly set to 1194 as well   i had to manually change it..

so thats why i thinking  3 locations for the VPN Port

 

i edited the config.jon  file too  found a 1194  port so i changed it thinking that would modify unraid  but  it didnt 

reboots  Force Update like you seen.. you see it says 1200  in the force update yet it wont save it

i ran  New Permissions for AppData Rights  which really bugs me gotta keep doing that every so often  for deleting files moving   New Permissions..

 

so i figured its a bug  that its saving 3 different copies of the port address

 

but when i get home later tonight ill un install server and re delete the folder and reinstall again  3rd time the charm then lol

 

i also edited as.conf   but there was no 1200 or 1194 in there either

You're confused about app settings and port mapping. When you tell openvpn-as to listen on port X, it is listening on that port inside the container, not on unraid.

 

When you change port mapping in unraid gui, app has no idea about that change. The change is at the docker system level, not inside the container.

 

You should read the docker FAQ here to better understand how that all works

Link to post

ok  im confused now then

 

so whats the point in Docker settings of changing the Port address from 1194 to something else  

 

and what you guys mean  its listening in the app  not unraid..

Server AS  is unraid app docker...  I dont have no port for unraid   i set 1200 UDP  port OpenAS Port docker settings so i confused what you guys mean

 

Link to post

and i dont see no FAQ OpenVPN AS Docker section

 

and i set it to Bridge  and i see the 1200 port now

h ave no idea what a bridge or host is

 

as it wasnt part of the OpenVPN AS video

Edited by comet424
Link to post

so since i have it set to Bridge to get port 1200    is it going to work or wont work..  as he didnt talk about setting to Bridge   just host

 

so i should be able to get HOST 1200 right?

 

or is there a better video how to setup the Ports   

Link to post

so i gave it a shot with teh bridge mode 

doesnt work

 

i do  

openvpn --config client.ovpn

 

and get error

root@backupserver:/boot/openvpn# openvpn --config client.ovpn
Fri Mar 22 20:31:02 2019 OpenVPN 2.4.6 x86_64-slackware-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on May  7 2018
Fri Mar 22 20:31:02 2019 library versions: OpenSSL 1.1.1a  20 Nov 2018, LZO 2.10
Enter Auth Username:mike
Enter Auth Password:
Fri Mar 22 20:31:12 2019 WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.
Fri Mar 22 20:31:12 2019 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Mar 22 20:31:12 2019 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Mar 22 20:31:12 2019 RESOLVE: Cannot resolve host address: <dns address>:1200 (System error)
Fri Mar 22 20:31:12 2019 RESOLVE: Cannot resolve host address: <dns address>:1200 (System error)
Fri Mar 22 20:31:12 2019 Could not determine IPv4/IPv6 protocol
Fri Mar 22 20:31:12 2019 SIGUSR1[soft,init_instance] received, process restarting
Fri Mar 22 20:31:12 2019 Restart pause, 5 second(s)
Fri Mar 22 20:31:17 2019 WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.
Fri Mar 22 20:31:17 2019 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Mar 22 20:31:18 2019 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Mar 22 20:31:18 2019 RESOLVE: Cannot resolve host address: <dns address>:1200 (System error)
Fri Mar 22 20:31:18 2019 RESOLVE: Cannot resolve host address: <dns address>:1200 (System error)
Fri Mar 22 20:31:18 2019 Could not determine IPv4/IPv6 protocol
Fri Mar 22 20:31:18 2019 SIGUSR1[soft,init_instance] received, process restarting
Fri Mar 22 20:31:18 2019 Restart pause, 5 second(s)

so something isnt liking my dns address name dunno why  dunno why its not just working   

Link to post

im getting frustrated .. i cant delete 1194 i added a port to AS  and still wont add port i googled docker ports and that article was usless it doesnt say anyhing how to erase 1194 and replace it with 1200  

https://lime-technology.com/wp/docker-guide/

 

so im really getting frustrated   i want 1194 erased and 1200 put in its place.. in host mode  because Bridge mode doesnt work at all gui is disabled

 

open1.JPG

Link to post

ive tried googling

delete  unraid port 1194

change unraid port 1194

change openvpn as port 1194 unraid

 

i cant find anywhere to erase this damn 1194  

i figured once i change the docker port to 1200  it should change to 1200 not stay at bloody 1194

banging my head off the wall there is no documentation  how to fix this 

Link to post
7 hours ago, comet424 said:

ive tried googling

delete  unraid port 1194

change unraid port 1194

change openvpn as port 1194 unraid

 

i cant find anywhere to erase this damn 1194  

i figured once i change the docker port to 1200  it should change to 1200 not stay at bloody 1194

banging my head off the wall there is no documentation  how to fix this 

Earlier they referred to the docker faq, not a specific openvpn faq. 

You do not understand the basics of using docker, so read through the docker faq. 

 

In host mode, the port settings does not matter. You can safely use the bridge network option and use port 1200 that you insist on using. 

Read the Readme in the github link in the first post to get info about how to set up the container. 

 

Please don't use this thread as a monolog. Post everything in one post, edit the post if you want to add more info. 

Link to post
12 hours ago, comet424 said:

and i dont see no FAQ OpenVPN AS Docker section

 

and i set it to Bridge  and i see the 1200 port now

h ave no idea what a bridge or host is

 

as it wasnt part of the OpenVPN AS video

 

Link to post

@aptalca  so  I looked that article

it didn't help  I set docker  to disk4 location  instead of mnt/user   folder

I searched the real docker faq for port but that didn't help  to run Fix Common issues.. it found no issues  and yet still at 1194

so I not sure which docker issues would be considered my problem  

even a reboot and then running Fix Common Issues didn't find my error 

I checked each disk to make sure the appdata not on there   just Disk4

so I still stuck.. thanks for the FAQ link

I also find running Fix Common Issues  says errors found.. yet displays no Errors Found.. so that contradicts itself

 

I read about the one ports thing   text was in black so you had to highlight to read it..  and it said nothing how to fix it to port   said  this which there is no download folder 

 


Report post  
Posted June 2, 2017 
I want to change the port my docker container is running on or I have two containers that want to use the same port, how do I do that? 
  
So say you had four apps with random docker container ports, just edit like this... 
  

  
Don't change the container port as you can see in this bit of a Dockerfile (code used to generate a container) from nzbget, only 6789 is actually "exposed" so even if you change it in the app's webui to 6788, it won't be able to communicate as only 6789 is exposed to the host at the container/host interface.
  
# ports and volumes
VOLUME /config /downloads
EXPOSE 6789

soo  if this means edit a container file for each docker.. what is the container file.. so I can change EXPOSE 1194  to EXPOSE 1200   

as article doesn't say... and SpaceIvader only talked about editing as.conf  and I edited the config.json  and changed that 1194 to 1200 that didn't work

 

I also searched  "dockerfile"   in the OpenVPN-as folder and didn't find it

 

I also tried typing 

VOLUME /config /downloads

EXPOSE 6789

in the terminal prompt that didn't do anything either so I not sure how I edit the 

container/host file

Edited by comet424
Link to post

@trurl

yes I confused   thought it be a simple thing to do

 

I have to use HOST  because Bridge Doesn't work  the OpenVPN-AS gui doesn't work in Bridge mode  only in Host mode

 

also  SpaceInvader doesn't do  Bridge mode  does Host and he shows that the container port is 1194 that he copies well I dotn want 1194 as its already being used  by Pfsense  so I want to change that 1194  to 1200 so I can port forward

 

no one is explaining right  why in HOST mode I can not EDIT the OpenVPN-AS container change that 1194 to 1200  and save it..

no ones explaining  then how you do it right   to change the port  

from what I read from that Docker FAQ   no matter what port I set in OpenVPN-AS gui  when you log into admin  no matter what port it will never work because the docker/container always points to 1194  and will never listen to 1200

that's what I basically understand from that FAQ Docker  

and that you need to edit the host/container to change it 

 

 

"Don't change the container port as you can see in this bit of a Dockerfile (code used to generate a container) from nzbget, only 6789 is actually "exposed" so even if you change it in the app's webui to 6788, it won't be able to communicate as only 6789 is exposed to the host at the container/host interface."

 

so I searched more and squid guy wrote in different article   "The xml files are stored on the flash drive /config/plugins/dockerMan"

so I edit the OpenVPN-as xml file where it says Target 1200   Default 1194  I changed the Default to 1200 

and did a reboot 

and it didn't work  went back to 1194

 

all I want is  OpenVPN-AS to work on Port 1200  not 1194  that's all I want 

I need exact instructions to Change 1194 to 1200 

 

so yes im totally confused cuz I thought it was a Simple  change port 1194 to 1200 when you first Install OpenVPN-AS  or when you click the Edit button...

 

so yes I confused and frustrated  thought it was a simple thing to do..

 

all I know is if  I set to Bridge then it changes port 1200  yet  OpenVPN doesn't work at all then

 

 

 

when in Host mode  I can access  192.168.1.8:943  to he webgui

when in Bridge mode  webgui is now disabled but i see port 1200 instead of 1194

 

Edited by comet424
Link to post
24 minutes ago, comet424 said:

no one is explaining right  why in HOST mode I can not EDIT the OpenVPN-AS container change that 1194 to 1200  and save it..

When in HOST mode (or when assigning a container its own unique IP address), the docker system completely ignores any and all port mappings and gives the container access to any and all ports that it wants to use.  IE: In host mode or with an unique IP address it will always utilize 1194.

 

If you have another container which also wants to use 1194 then you have a few choices:

  1. Use the container in bridge mode, and you can then map 1194 to whatever host port you want.
  2. Map the other container's port 1194 to some other port (assuming that it's also running in bridge)
  3. Assign one or both of those conflicting apps their own unique IP address and you won't need to worry about port conflicts between the two of them.

As far a OpenVPN-AS is concerned, there were some reports that the later versions of it did not like running in Bridge mode for whatever reason, and the workaround was to run in HOST.

29 minutes ago, comet424 said:

so I searched more and squid guy wrote in different article   "The xml files are stored on the flash drive /config/plugins/dockerMan"

so I edit the OpenVPN-as xml file where it says Target 1200   Default 1194  I changed the Default to 1200 

and did a reboot 

and it didn't work  went back to 1194

The only way to change port mappings is to edit the container via the docker tab.  Simply changing the .xml and rebooting will not change anything with relation to the installed app.

Link to post

for unraid I don't know mappings

for windows Mapping a network drive yes

and in unraid nope

like I said all I know is what spaceinvader said in the video when you first install OpenVPN-AS  he copys the port address of 1194 that's being used.. and I know from like Plex and Deluge  you edit or Add variables or Edit... sooo what I did was EDIT 1194 to be 1200 and then save.

and my understanding is you erase 1194 and its replaced with 1200

same as when say deluge said  where to save downloads  example  /downloads     but if I write  /downloads/downloads  as example  it chooses  /downloads/downloads  not its default..

 

 

im a windows user not a unraid user  I only went to unraid because Freenas doesn't update Plex on its own and Unraid was easier for Plex

so I only use a couple things on Unraid and use it for storage  I don't play with it I set it and forget it

 

like I confused  Fix Common issues says it found errors (shows in yellow)  but it found no errors so it gives false report

 

im new to this unraid freenas pfsense  stuff.. I been a Windows Home Server uses and Windows for 30 yrs 

 

so all this stuff confuses me if its not Gui Based 

Link to post

@Squid

for what I have on my sisters UInraid 

is

Krusader 

Deluge 

OpenVPN-AS

 

i don't know how you set a differnet IP address for it

I learned how to do different IP in FreeNas

why does it always default to 1194 no matter what.

I did the Docker Tab  edit or least that's what i been saying click Docker  click Edit on OpenVPN-AS change Host3  1194 to 1200  and save   but it never changes from 1194 to 1200

 

i use 1194 VPN and 1196 for Pfsense VPN    so i want 1200 for OpenVPN-AS

so i can run rysnc 

its all i want

 

and i cant use OpenVPN-as in Bridge mode and i forget who told me in the forums here to delete network card option  in OpenVPN  so delete the variable that fixed the issue  for accessing website but nto the port 

 

sorry i not expert with this i learning as i go along

Link to post
2 minutes ago, comet424 said:

I did the Docker Tab  edit or least that's what i been saying click Docker  click Edit on OpenVPN-AS change Host3  1194 to 1200  and save   but it never changes from 1194 to 1200

If the network type is set to host then you can change it all day long and it will never take effect  Only works in Bridge mode.  By design by docker themselves

4 minutes ago, comet424 said:

i don't know how you set a differnet IP address for it

 

image.thumb.png.c2713b67333e318b17133c41b315cd7b.png

Link to post
  • trurl pinned and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.