Jump to content
linuxserver.io

[Support] Linuxserver.io - OpenVPN AS

1560 posts in this topic Last Reply

Recommended Posts

5 hours ago, Everend said:

So does this mean that I should NOT use CA Auto Update Applications to update the docker as the new version comes out?

 

My VPN refused connection with Monday's update but changing the repository as noted above fixed it.

I would not use this, when you need it with high priority. The VPN is for me a key component and woud exclude it from auto updating. Nevertheless should you stay informed about security issues of the vpn container and update it when you safely know, that the update is ok and properly working.

Share this post


Link to post
3 hours ago, Teknoclown said:

Looking further into the Forums, it seems as if there was a bad build of OpenVPN-AS pushed.  Is there anyway to change which repository is being used utilizing the command line?

I have merged your thread with the correct support thread.

 

For future reference, you can always go directly to the correct support thread for any of your dockers by simply clicking on its icon and selecting Support.

Share this post


Link to post
Posted (edited)
4 hours ago, trurl said:

I have merged your thread with the correct support thread.

 

For future reference, you can always go directly to the correct support thread for any of your dockers by simply clicking on its icon and selecting Support.

 

Do you mind changing the title back to our original one as now it has the title from the thread you merged. 

I don't have the credentials for posting as linuxserver.io. 

Edited by saarg

Share this post


Link to post
26 minutes ago, saarg said:

Do you mind changing the title back to our original one as now it has the title from the thread you merged. 

I don't have the credentials for posting as linuxserver.io. 

OOPS! Guess that went backwards. We completely lost the Docker FAQ like that one time.😅

 

Moved it from General Support back to Docker Containers too.

Share this post


Link to post
8 hours ago, trurl said:

OOPS! Guess that went backwards. We completely lost the Docker FAQ like that one time.😅

 

Moved it from General Support back to Docker Containers too.

Good thing @CHBMB wasn't involved as something would have been deleted then 😜

 

Thanks for the fix. 

Share this post


Link to post
On 3/27/2019 at 11:37 PM, markpeo said:

No need to remove and re-add the docker image. Jst edit your docker, change the repository and then hit apply. Job Done.

This worked for me. Shame we have to run a old version to fix it. Hopefully they will resolve the issues ASAP. 

Share this post


Link to post

I updated a few days ago and my OpenVPN stopped working. Reading back a few pages of this thread seems to suggest there is an issue but I noticed there is another update out now. Is this latest update meant to solve this problem or is it unrelated?

 

Also I noticed the Support link on the container no longer works - https://forums.unraid.net/topic/41631-support-linuxserverio-openvpn-as/. Am I using an old container?

Share this post


Link to post
23 minutes ago, amardilo said:

I updated a few days ago and my OpenVPN stopped working. Reading back a few pages of this thread seems to suggest there is an issue but I noticed there is another update out now. Is this latest update meant to solve this problem or is it unrelated?

 

Also I noticed the Support link on the container no longer works - https://forums.unraid.net/topic/41631-support-linuxserverio-openvpn-as/. Am I using an old container?

 

The support link error you can blame on @trurl 

We have to fix it in our template.

Share this post


Link to post
On 3/25/2019 at 8:52 AM, aptalca said:

PSA. It seems openvpn pushed another broken bin, tagged 2.7.3

I get the same error with it as I did with the previously pulled 2.7.2

 

While they/us try to figure it out, you can change your image to "linuxserver/openvpn-as:2.6.1-ls11" and it should work

A million times thank you.. was lost and couldn't find anything while at work.. came home to search more thoroughly and found your post, all working again :)

Share this post


Link to post
2 hours ago, saarg said:

The support link error you can blame on @trurl 

We have to fix it in our template.

We don't get any training😄

 

Merge seems to work exactly backwards to what you would expect. I usually use Split instead to select specific posts and split them into a new thread or into another thread. But in this case, I wanted to take the whole thread and merge it here.

 

I started from the thread the other user created, selected Merge, and gave it the URL for your support thread. You would think that would mean merge that thread into yours, but apparently not.

 

I think this may be exactly how we lost the Docker FAQ back in the early days of this forum software. I later found it in some other thread that was several pages down into the forum.

 

Ironically, I had replied to that other user telling them how to get to the correct support thread for their Docker.O.o

 

Share this post


Link to post
7 hours ago, trurl said:

We don't get any training😄

 

Merge seems to work exactly backwards to what you would expect. I usually use Split instead to select specific posts and split them into a new thread or into another thread. But in this case, I wanted to take the whole thread and merge it here.

 

I started from the thread the other user created, selected Merge, and gave it the URL for your support thread. You would think that would mean merge that thread into yours, but apparently not.

 

I think this may be exactly how we lost the Docker FAQ back in the early days of this forum software. I later found it in some other thread that was several pages down into the forum.

 

Ironically, I had replied to that other user telling them how to get to the correct support thread for their Docker.O.o

 

🤣

And here I thought you had a weekend on some nice hotel, free bar and nice dinners on @limetechs expensive doing training to become a moderator... 

Share this post


Link to post

is there a way to rollback to openvpn-as:2.6.1-ls11 using only SSH?
my server is hosted on remote site, and i lost the vpn since last update

Share this post


Link to post
On 3/28/2019 at 3:10 AM, Teknoclown said:

 Is there anyway to change which repository is being used utilizing the command line?

20 minutes ago, syniex said:

is there a way to rollback to openvpn-as:2.6.1-ls11 using only SSH?

Ultimately, the Unraid webUI is just executing docker commands. You can get help with the docker commands at the command line with docker --help. I think you just need to remove the docker and run it again using the correct repository and mappings etc.

 

Share this post


Link to post
10 minutes ago, trurl said:

Ultimately, the Unraid webUI is just executing docker commands. You can get help with the docker commands at the command line with docker --help. I think you just need to remove the docker and run it again using the correct repository and mappings etc.

 

i don't want to screw the server,

can you please guide me through?

Share this post


Link to post

Hey guys, I'm having an issue with my openVPN docker. 

 

Long story short, devices cant connect to the VPN server and the docker wont launch into the web interface (such as the admin portal).

 

Thus far, I have

 

-checked my docker settings. 

-deleted the docker image and reinstalled

-checked the log, nothing red. 

 

but to no avail...

 

 

any help or guidance would be greatly appreciated!

 

 

Share this post


Link to post
1 hour ago, Aerodb said:

Hey guys, I'm having an issue with my openVPN docker. 

 

Long story short, devices cant connect to the VPN server and the docker wont launch into the web interface (such as the admin portal)

 

Have you updated the docker container recently?  If so, do what the rest of us have done when recent "broken" versions of OpenVPN-AS were released and follow the instruction in this post by aptalca on the prior page of this forum.

 

This has solved the problem for many of us.

Share this post


Link to post
Posted (edited)

Will the temporary repo prompt for the most recent version when eventually fixed, or will we have to monitor this forum post and change back to primary repo to receive the latest fixed version?

Edited by cpthook

Share this post


Link to post
53 minutes ago, cpthook said:

we have to monitor this forum post and change back to primary repo to receive the latest fixed version?

This. When you specify a version manually, that's what you get as long as it's still available on the server.

Share this post


Link to post

I've tried the steps above by rolling back to the older version linuxserver/openvpn-as:2.6.1-ls11 and I can't get the web gui to show up still. Anyone have any ideas?

Share this post


Link to post
On 3/27/2019 at 3:57 PM, daemon1999 said:

Yeah remove your existing image.  then go click add container on the docker page. 
image.png.4ae21cc7e6e90026d33105cbd48d20b8.png
click on the template and go down to your user templates...
image.thumb.png.0fb5140a21af7d03c3ae760948d62555.png

Then click on the openvpn one. 

 

 

Then go to the repository line and change it to linuxserver/openvpn-as:2.6.1-ls11 .  

image.thumb.png.bc4bd2e0eb84a722608c6b4127f9da51.png

That is literally all I had to do.  

These steps didn't work for me. Any other ideas?

Share this post


Link to post

jh1987 does your Docker log say anything after the successfull deployment of this above Repository config?

Share this post


Link to post

Ok guys I tried the above steps, and it worked. Issue resolved. My only question now is...

 

does this mean I'm running on an older version? Will the next update just break the openvpn docket again?

Share this post


Link to post

When you specify a version manually, that's what you get as long as it's still available on the server.

 

Understood!  Thanks for the heads up..

Share this post


Link to post

This doesn't seem to work for me. I removed the docker (with also delete image ticked), then clicked add container, selected openvpn-as, and I get this error:

Command:
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='openvpn-as' --net='host' --privileged=true -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'TCP_PORT_943'='943' -e 'TCP_PORT_9443'='9443' -e 'UDP_PORT_1194'='1194' -e 'INTERFACE'='bond0' -e 'PGID'='100' -e 'PUID'='99' -v '/mnt/user/appdata/openvpn-as':'/config':'rw' 'linuxserver/openvpn-as:2.6.1-ls11' 
/usr/bin/docker: invalid reference format.
See '/usr/bin/docker run --help'.

The command failed.

 

Share this post


Link to post
On 3/31/2019 at 5:18 PM, jj_uk said:

This doesn't seem to work for me. I removed the docker (with also delete image ticked), then clicked add container, selected openvpn-as, and I get this error:


Command:
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='openvpn-as' --net='host' --privileged=true -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'TCP_PORT_943'='943' -e 'TCP_PORT_9443'='9443' -e 'UDP_PORT_1194'='1194' -e 'INTERFACE'='bond0' -e 'PGID'='100' -e 'PUID'='99' -v '/mnt/user/appdata/openvpn-as':'/config':'rw' 'linuxserver/openvpn-as:2.6.1-ls11' 
/usr/bin/docker: invalid reference format.
See '/usr/bin/docker run --help'.

The command failed.

 

I'm experiencing the same issue

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.