Jump to content
erikm101

[SOLVED] VM Can't Access Network

11 posts in this topic Last Reply

Recommended Posts

Hello,' Apologies in advance for n00b questions.

 

I installed a VM with Ubuntu Server 18.04 LTS. I have properly (I think) edited the network /yaml file. But I am unable to ping this VM, neither can I ping from the VM to anything else. Can't SSH into it, though the VNC seems to be working fine. Netplan settings are applied.

 

Any help getting this VM on my network properly would be greatly appreciated.

 

An ifconfig reveals what appears to be appropriate settings:

 

 image.thumb.png.0a32fdbf664195f98b2ec0ddf96d547f.png

 

My Unraid server is at 10.0.1.201.  My router is at 10.0.1.1.  There are no conflicting IPs on this network.

 

Net config file looks like so:

image.thumb.png.771061c93e007866f6f20c89abe93341.png

 

Share this post


Link to post
Hello,' Apologies in advance for n00b questions.
 
I installed a VM with Ubuntu Server 18.04 LTS. I have properly (I think) edited the network /yaml file. But I am unable to ping this VM, neither can I ping from the VM to anything else. Can't SSH into it, though the VNC seems to be working fine. Netplan settings are applied.
 
Any help getting this VM on my network properly would be greatly appreciated.
 
An ifconfig reveals what appears to be appropriate settings:
 
 image.thumb.png.0a32fdbf664195f98b2ec0ddf96d547f.png
 
My Unraid server is at 10.0.1.201.  My router is at 10.0.1.1.  There are no conflicting IPs on this network.
 
Net config file looks like so:
image.thumb.png.771061c93e007866f6f20c89abe93341.png
 

VNC works fine because the vnc is on the unraid, not the vnc. I am not sure, but do you have to install the driver for the network interface on Ubuntu?or you could try to change the model in the xml to e1000-82545em
Edit the cam then click the top right corner switch, then find the following code, change the model
 


I am not sure if it will work or not, since my VM is windows.

Share this post


Link to post

What type of network connection did you specify when setting up the VM?   

Share this post


Link to post
1 minute ago, erikm101 said:

@itimpi I'm not sure I understand the question. I don't recall any settings specifically related to network when I set it up.

 

You must have specified the type of network adapter (e.g virbr0).  That will determine both what drivers are needed inside the VM and also whether is a NAT connection or not.   If you are not sure you can look at the current network settings for the VM at the Unraid level.   Alternatively provide the XML for the VM and we can see it from there.

Share this post


Link to post

Ah, I see. It is setup as virbr0. I left that at default, which is why I didn't remember the setting ;)

 

Edited by erikm101
additional info

Share this post


Link to post
3 minutes ago, erikm101 said:

Ah, I see. It is setup as virbr0. I left that at default, which is why I didn't remember the setting ;)

 

OK - that adapter is a NAT type connection allowing only outbound connections which will explain why you cannot ping or ssh to the VM.   It also means that the virtio network drivers are required inside the VM - not sure if Ubuntu server includes them as standard although I would have though it did.   If you want the VM to appear as if it were directly connected to the LAN then you need a bridged network (e.g. something like br0 rather than virbr0), but you first need to make sure that has been set up in the Unraid network settings.

 

I also have no experience of editing networking files inside an Ubuntu VM.   In my experience the network 'just worked' without me having to do anything.   Someone else may be in a better position to help here.

Share this post


Link to post

Thanks. virbro is the only option I have available in the setup page. Maybe I'm misunderstanding where the network change would need to be applied?

 

 

Untitled.png

Edited by erikm101

Share this post


Link to post
15 minutes ago, erikm101 said:

Thanks. virbro is the only option I have available in the setup page. Maybe I'm misunderstanding where the network change would need to be applied?

 

 

Untitled.png

You need to go (at the Unraid level) to Settings->Network Settings and Enable Bridging.   The default name for the first bridge is br0 (although you can over-ride that if you want to.)

 

Once you have done that if you scroll to the bottom of the page you will see the routing that has been set up for both virbr0 and br0.

 

When you go back to the VM settings you should now be offered the choice of virbr0 and br0.

Edited by itimpi

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.